Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Les mises à jour de paquets suivantes ne seront PAS installées (Lu 341 fois) sujet précédent - sujet suivant

Les mises à jour de paquets suivantes ne seront PAS installées

Bonjour,

je n'ai pas trouvé de section pour se présenter. Je débarque sur OpenSuse après de longues années entre Debian, Manjaro et Fedora.

Je ne pige pas un truc pour les mise à jour.

Quand je fais zypper update j'ai des paquets qui ne veulent pas se mettre à jour alors qu'à priori il y a une MAJ disponible.

Exemple :
# zypper update
Chargement des données du dépôt...
Lecture des paquets installés...

Les 45 mises à jour de paquets suivantes ne seront PAS installées :
  ffmpeg-4 geoclue2 gstreamer-plugins-ugly gstreamer-plugins-ugly-lang insync
  libavcodec58_134 libavdevice58_13 libavfilter7_110 libavformat58_76
  libavresample4_0 libavutil56_70 libgstphotography-1_0-0 libgstplayer-1_0-0
  libheif1 libopenjp2-7 libpipewire-0_3-0 libpostproc55_9 libquicktime0
  libswresample3_9 libswscale5_9 libzbar0 noto-sans-cjk-fonts
  noto-sans-jp-bold-fonts noto-sans-jp-fonts noto-sans-jp-regular-fonts
  noto-sans-kr-bold-fonts noto-sans-kr-fonts noto-sans-kr-regular-fonts
  noto-sans-sc-bold-fonts noto-sans-sc-fonts noto-sans-sc-regular-fonts
  noto-sans-tc-bold-fonts noto-sans-tc-fonts noto-sans-tc-regular-fonts pipewire
  pipewire-lang pipewire-media-session pipewire-modules pipewire-spa-plugins-0_2
  pipewire-spa-tools pipewire-tools system-user-srvGeoClue
  typelib-1_0-Geoclue-2_0 youtube-dl youtube-dl-bash-completion
Rien à faire.

Parfois, en dessous il y a des paquets qui, eux, vont être mis à jour.

Merci pour vos explications.

LCG

Re : Les mises à jour de paquets suivantes ne seront PAS installées

Répondre #1
Hello ;)

Tu peut choisir le dépôt fournissant les mises à jour, celles non faites sont des possibilités mais pas liées au dépôt que tu utilises en ce moment.

Tu peut mettre à jour par version, architecture, patron, depuis un dépôt spécifique si besoin... selon ton besoin
voir ceci par exemple https://www.ubuntupit.com/most-useful-zypper-commands-for-suse-linux-users/

Re : Les mises à jour de paquets suivantes ne seront PAS installées

Répondre #2
Bonjour, regarde le guide du débutant, la section sur la gestion des dépôts et leur priorité et également le man appert.
As tu le dépôt Packman?
Tu peux aussi passer par yast, install/suppr de logiciel. Tu vas sur l'onglet dépôt. Un clic droit dans la fenêtre de droite, dans le popup tu choisis "tout dans cette liste". Dans la nouvelle fenêtre popup, mise à jour si disponible.

Re : Les mises à jour de paquets suivantes ne seront PAS installées

Répondre #3
En utilisant Yast , on sait pourquoi les m-à-j ne seront pas installées, de façon claire.

Re : Les mises à jour de paquets suivantes ne seront PAS installées

Répondre #4
Tu peut mettre à jour par version, architecture, patron, depuis un dépôt spécifique si besoin... selon ton besoin
voir ceci par exemple https://www.ubuntupit.com/most-useful-zypper-commands-for-suse-linux-users/
Parfaite cette page, merci :)

Bonjour, regarde le guide du débutant, la section sur la gestion des dépôts et leur priorité et également le man appert.
As tu le dépôt Packman?
Tu peux aussi passer par yast, install/suppr de logiciel. Tu vas sur l'onglet dépôt. Un clic droit dans la fenêtre de droite, dans le popup tu choisis "tout dans cette liste". Dans la nouvelle fenêtre popup, mise à jour si disponible.
J'y vois un peu plus clair grâce à ces pages. La gestion des dépôts et des paquets me semble plus fine que sur les autres distributions.
Oui j'ai activé le dépôts Pakman.

J'aurais aussi peut-être dû préciser que je suis sous Thumbleweed.

Je trouve Yast, bien que complet, un poil . . . austère . . . bref, j’aime beaucoup zypper. Superbe outil.

Je vais regarder tout ça de plus près et peaufiner mes réglages de dépôts si besoin.

Merci pour vos réponses.

Re : Les mises à jour de paquets suivantes ne seront PAS installées

Répondre #5
Hello ;=)

N'hésite pas si besoin.

Tu peut montrer les dépôts que tu as ainsi :

zypper lr -d

et je te recommande de basculer tout sur le dépôt Packman, comme indiqué ici (c'est plus simple et visuel par yast, en 3ème option à partir du 4ème point car tu as déjà packman à priori ) :
https://en.opensuse.org/SDB:Installing_codecs_from_Packman_repositories

Re : Les mises à jour de paquets suivantes ne seront PAS installées

Répondre #6
Bonjour et bienvenue @LCG‍  :)

La rubrique de présentation est ici : https://www.alionet.org/index.php?board=16.0 ;)

Sinon pour Tumbleweed, contrairement à Leap, il faut utiliser en root
zypper dup
pour mettre à jour.
C'est documenté un peu partout, dans la doc officielle, le wiki...
Le système de "vendeur" est un peu déroutant quand on n'y est pas habitué mais à l'usage c'est très pratique.
ça permet de conserver la même origine pour un paquet et à mon avis c'est ce qui fait que j'ai peu de souci avec Tumbleweed sur mon portable qui ne possède pas de carte Nvidia.

Bonne découverte d'openSUSE  :)

Re : Les mises à jour de paquets suivantes ne seront PAS installées

Répondre #7
Merci. Je l'avais repérer le zypper dup ;)

Je parcours encore la documentation quand j'ai un peu temps.
Je passe d'ailleurs le sujet en résolu.

Merci pour vos réponses.

 

Re : Les mises à jour de paquets suivantes ne seront PAS installées

Répondre #8
Bonjour,
et bienvenue,

Il existe une différence entre tumbleweed et leap sur la commande zypper dup:
sur leap la commande est configurais pour autorisé le changeant de dépôts, sur tumbleweed zypper dup n'autorise pas par défaut le changent de dépôts. il y a les options --allow-vendor-change et --no-allow-vendor-change pour changer le comportement en cas  besoin.

le zypper dup la définition dist-upgrade,  Réaliser une mise à niveau de la distribution.
le truc avec tumbleweed, le comportement est différent d'une arch : les mise à jours se font par groupe: par cliché, qui regroupe un ensemble de mise à jour des logiciels. (tu peu suivre ici : https://openqa.opensuse.org/snapshot-changes/opensuse/Tumbleweed/) qui ont testé (ici : https://openqa.opensuse.org/group_overview/1?limit_builds=50&limit_builds=400&limit_builds=20&limit_builds=400&limit_builds=100&limit_builds=400&limit_builds=50&limit_builds=400) et déployer
chaque cliché, est une nouvelle version.

un zypper up ne feras pas une mise à jours complète. sur tumbleweed je fait toujours un zypper dup.

par contre il m'arrive et de conseille de faire zypper inr (def : install-new-recommends, Installe les nouveaux paquets recommandés par les paquets installés.) sa installe des paquets que opensuse te recommande.


david

Re : Les mises à jour de paquets suivantes ne seront PAS installées

Répondre #9
Il existe une différence entre tumbleweed et leap sur la commande zypper dup:
sur leap la commande est configurais pour autorisé le changeant de dépôts, .
Je n'ai pas testé Leap 15.3 mais il me semble que la configuration qui rend automatique le changment de vendeurs, c'est juste entre les dépôts openSUSE et SUSE en lien avec le rapprochement dans la contruction des paquets entre openSUSE et SLE.
Si on prend le dépôt packman par exemple, il devrait toujours y avoir la question qui demande si on veut faire un changement de vendeur.

Re : Les mises à jour de paquets suivantes ne seront PAS installées

Répondre #10
Il existe une différence entre tumbleweed et leap sur la commande zypper dup:
sur leap la commande est configurais pour autorisé le changeant de dépôts, .
Je n'ai pas testé Leap 15.3 mais il me semble que la configuration qui rend automatique le changment de vendeurs, c'est juste entre les dépôts openSUSE et SUSE en lien avec le rapprochement dans la contruction des paquets entre openSUSE et SLE.
Si on prend le dépôt packman par exemple, il devrait toujours y avoir la question qui demande si on veut faire un changement de vendeur.
il faut regarder dans /etc/zypp/zypp.conf le paramètre solver.dupAllowVendorChange
 

Re : Les mises à jour de paquets suivantes ne seront PAS installées

Répondre #11
Dans la doc officielle pour la mise à jour de leap 15.2 vers 15.3, il est question d'une liste blanche contenant les dépôts où on n'a pas besoin d'autoriser le changement de vendeur, ce sont ceux de SUSE/openSUSE, pas les dépôts tiers.