Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Je ne peux plus mettre à jour Tumbleweed (Lu 276 fois) sujet précédent - sujet suivant

Je ne peux plus mettre à jour Tumbleweed

Bonjour,

Suite à un problème d'espace disque lors d'une immense mise à jour, je crois bien que j'ai un soucis: je ne peux plus lancer l'outil  "Yast installer et supprimer des logiciels"
(erreur: Internal error. Please report a bug report with logs.
Run save_y2logs to get complete logs.
Caller: /usr/lib64/ruby/vendor_ruby/3.3.0/yast/yast.rb:186:in `import_pure'
Details: component cannot import namespace 'Pkg')

ni effectuer "zypper dup":
Erreur: "zypper: error while loading shared libraries: librpm.so.9: cannot open shared object file: No such file or directory"

Pouvez-vous m'aider ? SI je comprends bien, je dois réinstaller zypper. Mais comment faire ?
A noter que pour faire de la place j'ai effacé tous mes snapshots. Donc pas possible de revenir à une ancienne version :-(

et plus généralement, j'ai une partition de 40Gio pour le système mais souvent, son espace ne permet pas les mises à jour. Je supprime alors des snapshot de "snapper" mais parfois ça ne suffit pas et tout se bloque. Que faire ?

Merci !

Re : Je ne peux plus mettre à jour Tumbleweed

Répondre #1
Bonjour,
Avec le problème comme tu le décris qui revient régulièrement, je sauvegarderais mes documents avec une iso live et je referais une installation avec plus d’espace disponible.
sinon je n’ai pas personnellement les compétences pour résoudre ton problème.
Essaie avec une iso de Tumbleweed pour voir si ça te propose de réparer ou mettre à niveau ton système, je n’ai jamais fait, je ne connais pas la formulation. De toute façon, sauvegarde tes docs avant.

Re : Je ne peux plus mettre à jour Tumbleweed

Répondre #2
Bonjour,

Si tu as installé tumbleweed en mode standard, tu dois avoir des snapshots qui prennent de la place.

Comme @chalu te le mentionne, je ferais déjà une sauvegarde des documents/données utiles tant que ça fonctionne, puis je regarderais pour voir si je ne peux pas supprimer des snapshots et récupérer de la place.

Re : Je ne peux plus mettre à jour Tumbleweed

Répondre #3
Bonjour,

Les deux problèmes sont distincts même s'ils ont peut-être la même origine. Yast plante sur une version de ruby qui n'est pas la bonne et Zypper sur une librairie qu'il ne trouve pas.

Aurais-tu installé un dépôt externe de développement avec une priorité particulière? Je demande ça pour ruby.

Sinon j'ai vu une solution traitant d'un problème identique afin de remettre Yast d'équerre mais elle me semble périlleuse et d'autre part tu seras bloqué avec Zypper.

Pour la librairie manquante il faudrait pouvoir réinstaller le paquet rpm dont elle dépend. Ce ne peut se faire qu'à partir du DVD d'installation (ou de la clé usb) ou d'une iso live de réparation (Tumbleweed rescue CD) : https://fr.opensuse.org/Installer_openSUSE_Tumbleweed

Ici : https://www.reddit.com/r/openSUSE/comments/5xmq9s/zypper_error_while_loading_shared_libraries/

j'ai trouvé cette procédure

Citer
...télécharger le dernier DVD d'installation d'openSUSE tumbleweed ou le CD de secours de Tumbleweed.

Utilisez-le pour vous rendre à un terminal en tant que root

Montez votre système de fichiers d'origine, par exemple mount /dev/sda2 /mnt

Utilisez la fonction chroot de zypper -R /mnt in --force rpm pour réinstaller le paquetage rpm (qui fournit librpm.so.3).


À adapter selon l'endroit où se trouve ta partition racine (/dev/sd??), et en oubliant le fait que dans la citation il est question de librpm.so.3.

Cependant, un, aujourd'hui nous en sommes à librpm.so.10 (et non librpm.so.9), deux ce n'est pas très simple à réaliser et trois je n'ai jamais pratiqué personnellement pour vraiment t'assister si tu voulais t'engager dans cette voie.

Es-tu certain de rencontrer un problème d'espace avec ta partition racine (même si 40 Go c'est trop peu par rapport à ce qui est recommandé)? Tu peux vérifier avec la commande

df -H -T

Snapper dispose d'un mécanisme de nettoyage automatique des snapshots pour éviter l'engorgement de la partition racine. Chez moi je vérifie de temps en temps la taille de celle-ci et je vois bien qu'elle fluctue et diminue avec le temps après une grosse mise à jour par exemple. Ce me semble assez efficace quand même.

Honnêtement les conseils précédents me semblent avisés (sauvegarde!) et le plus simple serait de réinstaller. Avant tu peux éventuellement tenter une mise à niveau avec le DVD d'installation.



Re : Je ne peux plus mettre à jour Tumbleweed

Répondre #4
Bonjour,

C'est un peu dommage qu'il n'existe pas de logiciel pour redimensionner les partitions sans avoir à tout réinstaller. C'est un manque profond dans la panoplie des logiciels disponibles sous Linux. Avis, donc, aux développeurs.

       

Re : Je ne peux plus mettre à jour Tumbleweed

Répondre #5
@serge-muscat : il existe depuis plus de vingt ans le partitionnement LVM qui permet le redimensionnement à chaud sur un ou plusieurs disques.


à plus,
oh!rocks

Re : Je ne peux plus mettre à jour Tumbleweed

Répondre #6
@serge-muscat : Salut!

Et je complète oh!rocks en ajoutant qu'il existe depuis un bail aussi d'autres outils quand on n'a pas fait le choix d'un partitionnement LVM, avec lesquels il faut être prudent c'est certain, mais ils existent. Quelques tutos aux hasard :

https://www.malekal.com/redimensionner-agrandir-reduire-partition-de-disque-linux/
https://fr.linux-console.net/?p=14464

Re : Je ne peux plus mettre à jour Tumbleweed

Répondre #7
Bonjour,

C'est un peu dommage qu'il n'existe pas de logiciel pour redimensionner les partitions sans avoir à tout réinstaller. C'est un manque profond dans la panoplie des logiciels disponibles sous Linux. Avis, donc, aux développeurs.
Bonjour,
C'est possible depuis longtemps à partir d'un live cd/usb.
Même une partition ext4 (même ntfs) est parfaitement redimentionnable.

Réduire une partition est plus risqué, il faut être sûr que l'espace utilisé est bien largement inférieur au nouvel espace qu'on va définir.
Par contre agrandir il n'y a aucun problème. Si la table des partitions est en msdos tu seras plafonné à 2to max par partition (si tu veux plus il faut convertir en gpt c'est possible aussi).

De nos jours, comme évoqué par @oh!rocks, avec un systême de fichier lvm le redimentionnement se fait même sans redémarrage et à la volée depuis l'os. Si c'est du lvm encrypt c'est plus compliqué par contre.

Par contre si tu veux rajouter un disque dur et que ta partition soit à cheval sur deux disques dur pour l'agrandir, ça existe mais il faut un système de fichier particulier et ça reste risqué.



 

Re : Je ne peux plus mettre à jour Tumbleweed

Répondre #8
Merci pour toutes vos réponses intéressantes.

J'ai finalement réinstallé Tumbleweed sur ma partition racine, avec un CD-R installation "réseau".
Tout fonctionne à merveille et une installation toute neuve fait du bien !

Je n'ai pas modifié la taille de la partition de 40Go mais maintenant, mon système n'utilise plus que 7Go au lieu de 37Go avant... je ne comprends pas pourquoi. Je n'avais pas d'image snapper, toutes effacées. Peut-être des logiciels installés au fil des ans (mais franchement, 30Go, je ne comprends pas).

Pour info, j'ai aussi tenté une mise à jour de la distribution mais il me manquait de l'espace sur la partition de 40Go: il en aurait fallu 45. Là, ça me dépasse.

Merci encore pour vos réponses et intéressant de savoir qu'on peut re-partitionner sans tout réinstaller. Je vais essayer.