Aller au contenu principal

Voir les messages

Cette espace vous permet de voir toutes les Voir les messages réalisées par ce membre. Vous ne pouvez voir que les Voir les messages réalisées dans les espaces auxquels vous avez accès.

Messages - chalu

1
Installation et boot / Re : Interface graphique disparue apres MAJ Opensuse !
Se priver de mises à jour du noyau, c'est se priver des mises à jour de sécurité donc pour moi, non ce n'est pas une bonne idée.
Le problème vient du driver nvidia qui ne suit pas toujours le rythme d'evolution du noyau et autres composants système.
C'est pour ça que c'est plus compliqué une rolling si tu veux utiliser le driver propriétaire nvidia.
3
Installation et boot / Re : Interface graphique disparue apres MAJ Opensuse !
la commande à faire
su -
Pour passer en root puis
zypper dup
Pour mettre à jour.
Il n’y a rien d’étonnant à ce que les pilotes Nvidia fonctionnent sous Windows, ils développent avant tout pour ce système majoritairement présent sur les PC.
Tu peux mettre à jour pour voir si ton problème est réglé.
Si ce n’est pas le cas, tu peux désinstaller les pilotes Nvidia et redémarrer.
Ceci dit comme tu as des dépôts externes, le souci peut aussi venir d’ailleurs
Mais encore une fois, Tumbleweed n’est pas faite pour les débutants. Il ne faut pas se focaliser sur la dernière version des logiciels qui n’apporte pas toujours grand-chose pour l’utilisateur.
5
Installation et boot / Re : Interface graphique disparue apres MAJ Opensuse !
Bonjour,
C’est possible que les drivers Nvidia propriétaires soient en retard sur le changement de noyau, changement fréquent sur Tumbleweed.
Tu peux tenter de démarrer sur un noyau précédent dans la page grub
Tu peux essayer par la suite de ne pas utiliser les drivers propriétaires pour éviter le problème.
Tumbleweed n’est effectivement pas la distribution la plus simple pour débuter sur linux, c’est une rolling.
Ton PC n'étant pas si récent, 2012, je te conseillerais une distribution régulière comme Leap 15.3 ou encore Debian Buster et plus particulièrement la version proposée par nos amis de Debian-Facile à destination des débutants :
https://debian-facile.org/projets:iso-debian-facile
7
Général / Re : Mises à jour sur Tumbleweed
C'est le problème des dépôts externes, tu peux avoir un paquet qui va te demander à changer de version/fournisseur pour installer ton logiciel.
Perso, j'ai préféré effectivement utiliser le dépôt Éducation.
Le terme expérimental est pour mon cas un faux-ami. Certains dépôts communautaires proposent des versions plus à jour ... si ça fonctionne.
Comme le dit jtro, il faut regarder qui propose le dépôt pour décider si on lui fait confiance.
Pour ce qui est de désactiver un dépôt, c'est à faire en toute conscience : tu te prives ainsi de mises à jour qui peuvent corriger des bugs ou des failles ... De plus avec l'évolution des versions de Tumbleweed, ça peut bloquer à un moment.
8
Général / Re : Mises à jour sur Tumbleweed
;)

Le problème d'un dépôt communautaire, c'est que ça dépend du "sérieux" et de la disponibilité du mainteneur (et du nombre de mainteneurs). Il y a plus de risque que ce dépôt pose un souci.
Avec un flatpak, la stabilité du système ne devrait pas être mise à mal. Plus on en utilise, moins il y a de librairies à installer, il peut y avoir un usage commun de librairies entre flatpak.
Je préférerais utiliser une appimage si elle fonctionne correctement.

Sinon, j'utilise de préférence un dépôt expérimental. Pour le logiciel openboard par exemple (https://software.opensuse.org/package/OpenBoard ) j'ai pris le dépôt Éducation pour avoir ce logiciel.
9
Général / Re : Mises à jour sur Tumbleweed
Bonjour,
Pour préciser un peu pour tumbleweed-cli, la commande pour mettre à jour le système n’est plus zypper dup si on l'utilise, mais  
tumbleweed update
On ne reste donc pas bloqué sur une version de Tumbleweed en utilisant tumbleweed-cli.
Cet outil a été créé pour faciliter la gestion des snapshots en facilitant, dans le cas d’un souci avec une mise à jour, le retour à une version choisie de snapshot. Toutefois si on utilise des dépôts externes, il faut aussi continuer à utiliser
zypper dup
pour mettre à jour les paquets issus de ces dépôts.

En choisissant ext4 au lieu de btrfs, tu te prives de l’usage des snapshots ce qui peut être ennuyeux sur un PC que l’on utilise au quotidien s’il y a un gros bug. Pas de retour en arrière, il faut attendre une mise à jour qui corrige.
Quels sont les logiciels issus de dépôts communautaires ? C’est probablement plus rentable d’utiliser une version flatpak, plus on en a et moins il y a de librairies à installer pour un paquet.
10
Général / Re : Fil sur la FAQ openSUSE du forum
Bonjour,
Et merci chalu pour ce fil.
Je devais faire une install pour un ex windosien, mais ce qui le "gênait" c'était (entre autres) l'affichage de grub et de ses options.
J'ai donc découvert à cette occasion que l'on peut modifier Grub sans passer par la Konsole, directement dans Yast > Système > Chargeur d'amorçage > Options du chargeur d'amorçage; et soit mettre le timing à 0 secondes soit "masquer le menu d'amorçage"; à noter que choisir cette option ne supprime pas (apparemment) le délai en seconde; si vous laissez 8 secondes, pendant 8 secondes vous aurez un écran noir (et que mettre 0 secondes ET masquer le menu ne sert à rien, et que le système désélectionne "masquer"...je le sais, je l'ai testé  ::)  :D  ).
Voilà, si ça peut aider j'en serais ravi
Bonne journée.
Bonjour :)
Un délai un peu long pour la réponse (le travail, les vacances .... toussa toussa  :D  ) mais je viens de mettre à jour la FAQ en ajoutant tes indications.
11
Programmes et logiciels / Re : Depuis la dernière Mise à Jour Firefox 93.0 (64 bits) est instable...
Bonjour,
Je viens de faire la dernière mise à jour de Tumbleweed vers la version 20211016, il y a encore eu le noyau et une bonne partie (voire tout je n'ai pas fat attention) de KDE.
KDE est en version 5.23 maintenant (voir pour les changements https://kde.org/fr/announcements/plasma/5/5.23.0/ ).
Firefox ne semble pas avoir bougé.
Je n'ai pas de souci chez moi.

Tente une mise à jour pour voir si ça règle la question.
14
Programmes et logiciels / Re : Logiciels installés qui ne se lancent pas !
Je ne vais pas pouvoir beaucoup t'aider. Je n'ai jamais eu de carte nvidia sous linux et encore moins les configurations avec deux cartes.
Je ne sais pas trop comment sont géré sous openSUSE les deux cartes.
Certains ici utilisent prime pour pouvoir sélectionner entre la carte intel et la nvidia mais il semble y avoir des bugs dernièrement.

à ta place, j'essaierais de supprimer les pilotes propriétaires nvidia pour voir si ça peut fonctionner avec le pilote libre nouveau.
si ça marche pas, je réinstallerais les pilotes nvidia et essaierais prime ...
Désolée de ne pouvoir être plus précise mais plusieurs membres ont ce type de configuration et pourront te donner des pistes sur la gestion de ces deux cartes.

Edit : sinon pour Geogebra que j'utilise aussi. J'utilise la version Linux portable en zip :
https://wiki.geogebra.org/en/Reference:GeoGebra_Installation#GeoGebra_Classic_6
J'ai décompressé l'archive dans le dossier bin de mon répertoire personnel.
L'application fonctionne sans problème mais je n'ai pas de nvidia.