Aller au contenu principal
Sujet: Leap 15.3, Packman et VLC (Lu 218 fois) sujet précédent - sujet suivant

Leap 15.3, Packman et VLC

Bonsoir,

J'ai remarqué que le référentiel Packman pour Leap 15.3 est dépourvu d'une version stable de VLC et ne propose qu'un paquet vlc-beta. Un oubli?

En attendant c'est gênant, surtout pour un nouvel utilisateur d'openSUSE car s'il installe VLC, il installe la version stable des dépôts officiels. Et s'il procède à un changement de fournisseur des paquets système vers ceux de Packman avec la commande :

zypper dup --allow-vendor-change --from packman

Il devra résoudre un problème, contradictoire dans l'énoncé et muet sur les conséquences (l'installation in fine de vlc-beta) :

Chargement des données du dépôt...
Lecture des paquets installés...
Calcul de la mise à niveau de la distribution...

Problème : le/la vlc-3.0.13-bp153.1.1.x86_64 installé(e) nécessite 'vlc-noX = 3.0.13-bp153.1.1', mais cette condition ne peut pas être remplie
 Solution 1 : Les actions suivantes seront exécutées :
  conserver l'élément vlc-noX-3.0.13-bp153.1.1.x86_64 obsolète
  conserver l'élément vlc-qt-3.0.13-bp153.1.1.x86_64 obsolète
 Solution 2 : désinstallation de vlc-3.0.13-bp153.1.1.x86_64
 Solution 3 : casser vlc-3.0.13-bp153.1.1.x86_64 en ignorant certaines de ses dépendances

Choisir une des solutions ci-dessus en tapant son numéro ou bien annuler en tapant 'a' [1/2/3/a/d/?] (a):

Je ne sais pas quoi penser de cette version bêta de VLC mais en tout cas je trouve que ce n'est pas top d'échouer là dessus dans le cadre de Leap. En attendant j'ai remplacé VLC par SMPlayer, pour moi ça peut le faire, mais bon... j'espère que ça va bouger du côté de Packman car ça peut refroidir un nouvel utilisateur qui tient à VLC.

Re : Leap 15.3, Packman et VLC

Répondre #1
pourquoi ne pas rester sur la version des dépôts? Au pire tu mets le paquet en tabou et si tu migres vers packman, vlc restera dans sa version officielle.

Re : Leap 15.3, Packman et VLC

Répondre #2
pourquoi ne pas rester sur la version des dépôts? Au pire tu mets le paquet en tabou et si tu migres vers packman, vlc restera dans sa version officielle.

Salut jtro,

Mettre le paquet en tabou revient à le protéger -- ne pas modifier dans Yast Software, à le verrouiller (je découvre).

1/ Le paquet reste dans sa version officielle mais ne sera pas mis à jour, même dans celle-ci (mais je pense que nous en sommes avertis)
2/ VLC ce n'est pas qu'un et un seul paquet (je ne parle pas des dépendances), tu le verrouilles tout seul et d'autres questions surgissent lors de la migration vers  Packman : tu veux faire quoi avec vlc-nox, vlc-codec-gsreamer, etc? Las, tu verrouilles au moins six paquets pour ne plus être ennuyé... et ça passe (encore que je me demande pourquoi ne sont pas concernés libvlc5 et libvlccore9 immuables même lors d'une désinstallation complète de VLC). Par contre, en verrouillant le seul paquet VLC, si tu veux migrer vers Packman, tu es plus ou moins bien averti d'un conflit avec vlc-beta.

Pour moi, à titre personnel, ce n'est pas un vrai souci car l'utilisation de VLC ou d'un autre est occasionnelle et je me rends compte au passage de la bonne flexibilité et de la bonne stabilité du système (j'essaie parfois des trucs, comme à présent, je recommence encore et encore, et ça ne bronche pas, je reviens sur mes pieds). Mais il y a un truc un peu trop rébarbatif avec VLC dans la situation présente.

Re : Leap 15.3, Packman et VLC

Répondre #3
C'est marrant ça, j'ai installé hier une Leap 15.3 pour un ami, et j'ai été confronté au même dilemme en configurant packman: que faire avec le paquet vlc-beta ? Qu'est-ce à dire ?
Et ce matin, avant de trouver ton post Chumi, je voulais évoquer vlc-beta… Bref.

Sur la forme, je suis d'accord avec toi Chumi, pour Leap, je trouve cela moyen… Après dans le fond, je leur fais confiance.

Je lui ai donc installé cette version vlc-beta. Je n'ai pas eu le temps de jouer avec, sinon juste l'ouvrir: la présentation est différente, très épurée, presque rien ! Il y a un menu hamburger comme on dit maintenant.

De mon côté, j'utilise occasionnellement VLC pour visionner des dvds, aussi je vais l'installer sur ma machine, on va bien voir.

C'est la version "Otto Chriek" (la version 4 naturellement)

Re : Leap 15.3, Packman et VLC

Répondre #4
Après dans le fond, je leur fais confiance.

Oui, moi aussi et pour info le problème est signalé sur le forum officiel (et ici aussi à présent) :

https://forums.opensuse.org/showthread.php/557002-Where-are-15-3-Packman-VLC-files

Je ne comprends pas la réponse de Sauerland quand il écrit : "Build is failing"

Mais toujours est-il qu'il rappelle que le dépôt de Videolan et celui de Packman ne font pas bon ménage. Mauvaise solution de contournement par conséquent à moins de se priver de Packman.

Au fait : Otto Chriek est un vampire, ça explique tout  ;)

Re : Leap 15.3, Packman et VLC

Répondre #5
Bonjour :)
Je ne comprends pas la réponse de Sauerland quand il écrit : "Build is failing"
Il y a une erreur dans la construction du/des paquets

En attendant que ce soit corrigé dans une mise à jour et que vlc soit de nouveau disponible, plutôt que d'ajouter le dépôt vlc qui posera des problèmes avec packman, il est possible d'utiliser la version flatpak de vlc.

Re : Leap 15.3, Packman et VLC

Répondre #6
Premier constat, j'ai voulu lire un dvd  il y a deux jours. La vidéo fonctionnait bien, par contre le son n''était plus au rendez-vous. Pour info, j'ai un ampli derrière et j'utilise la sortie numérique spdif (un câble coaxial). Alors qu'avec vlc 3.0.x cela fonctionnait ces derniers mois. Comme je n'avais pas l’âme à bidouiller, j'ai lancé le dvd avec smplayer (sans problème).
Sinon j'ai bien aimé la nouvelle présentation: assez austère, encore plus épuré que vlc 3.0.x et en un clic on accède à pas mal de sources possibles.