Aller au contenu principal

Sujets

Cette espace vous permet de voir toutes les Sujets réalisées par ce membre. Vous ne pouvez voir que les Sujets réalisées dans les espaces auxquels vous avez accès.

Sujets - Mirliton

1
Programmes et logiciels / Pb avec vscodium
Bonjour,
Voulant ouvrir vscodium pour faire des modifs sur les fichiers html du site de mon asso, j'ai eu la désagréable surprise que ce dernier ne fonctionnait pas. Lors du lancement, en mode graphique, j'ai un bref flash sur l'écran et plus rien.
Il en est de même en lançant le logiciel en mode console. Ici aucune erreur n'apparaît dans la console. Je retourne seulement au prompt.
mirliton@aodou-an-arvor:~> codium
mirliton@aodou-an-arvor:~>
La version installée est la dernière :
mirliton@aodou-an-arvor:~> codium -v
1.60.2
7f6ab5485bbc008386c4386d08766667e155244e
x64

Comme je suis un tantinet agacé, j'ai installé le dépôt Microsoft et j'ai installé la dernière version de Visual Studio Code. Laquelle me donne les mêmes résultats que ceux expliqués précédemment. Vu le problème identique (ce qui n'est pas très étonnant, c'est le même code), j'ai viré la version MS.

J'ai désinstallé codium ainsi que les extensions (suppression du rép. .vscode-oss) et viré le dépôt. Et j'ai de nouveau tout réinstallé de façon à avoir une install neuve en suivant les indications du site officiel.

Avez-vous rencontré le même souci ? Et comment le résoudre ?
Avec mes remerciements.
2
Programmes et logiciels / Verrouillage du pavé numérique avec sddm - Une soluce
Bonjour,
Le sujet a peut-être été abordé ici mais je n'ai pas retrouvé de trace et j'ai repensé à un souci de clavier virtuel intervenu il y a quelques temps...
Récapitulatif :
  • Le simple fait d'activer le verrouillage du pavé numérique dans KDE ne fonctionnant pas (ce qui est récurrent) car ne prenant pas en considération la déclaration faite dans le bios, j'ai cherché du côté de la configuration de sddm.
  • Renseigner /etc/sddm.conf qui est vide par défaut dans openSUSE ne donne rien.

La ?/Une solution :
  • Aller dans /usr/lib/sddm/sddm.conf.d
  • Ouvrir le fichier 00-general.conf
  • Insérer le code suivant en fin de fichier :
    [General]
    InputMethod=
    Numlock=on
L'InputMethod, c'est pour éviter un affichage intempestif du clavier virtuel (j'avais déjà eu ce problème).
Numlock verrouille le pavé numérique comme son nom l'indique.


3
Programmes et logiciels / Asunder
Bonjour,
Quelques soucis avec Asunder.
Il ne reconnaît pas la base CDDB. J'ai changé (dans Préférences/Avancé) le serveur d'informations par défaut (freedb.freedb.org) par gnudb.gnudb.org.
Le fonctionnement est très aléatoire.
Parfois, il ne voit même pas le CD inséré alors que ce dernier est bien visible dans Dolphin et lisible avec Clementine.
Comment pallier à ces dysfonctionnements ?
En équivalent, soundKonverter est long, très long... Y-a-t-il mieux ?
Un serveur de données CDDB qui est fonctionnel ?

4
Programmes et logiciels / Apparence - KDE Plasma5
Bonjour,
Après avoir installé un système tout neuf, je voudrais obtenir de nouveaux thèmes globaux ou encore un nouvel écran de démarrage.
Or, çà pédale dans la semoule. Impossible d'obtenir quoi que ce soit.
Au bout d'un certain temps, j'ai ce message sibyllin :
Erreur de réseau 4 : L'opération socket a expirée
Un problème de serveur ?
Avez-vous le même souci ?
5
Programmes et logiciels / MAJ Tumbleweed - Filesystem ne passe pas
Bonjour à tous,
Grosse mise à jour (+ de 3600 paquets) de Tumbleweed.
L'installation de filesystem plante.
Voici l'erreur (extrait) :
(   4/3632) Installing: filesystem-15.5-40.2.x86_64 ...[error]
Installation of filesystem-15.5-40.2.x86_64 failed:
Error: Subprocess failed. Error: RPM failed: Make a copy of `/bin'.                                                                                                                       
cp: cannot create hard link '/usr/bin.usrmerge/basename' to '/bin/basename': Invalid cross-device link                                                                                    
cp: cannot create hard link '/usr/bin.usrmerge/cat' to '/bin/cat': Invalid cross-device link                                                                                              
cp: cannot create hard link '/usr/bin.usrmerge/chgrp' to '/bin/chgrp': Invalid cross-device link                                                                                          
...
...
cp: cannot create hard link '/usr/bin.usrmerge/fuser' to '/bin/fuser': Invalid cross-device link
cp: cannot create hard link '/usr/bin.usrmerge/sed' to '/bin/sed': Invalid cross-device link
cp: cannot create hard link '/usr/bin.usrmerge/arping' to '/bin/arping': Invalid cross-device link
Something failed, cleaning up
error: lua script failed: [string "%pretrans(filesystem-15.5-40.2.x86_64)"]:37: exit
        installing package filesystem-15.5-40.2.x86_64 needs 4KB more space on the /var filesystem
Abort, retry, ignore? [a/r/i] (a):
Une idée du pourquoi ? Problème de rpm ?
Merci.
6
Programmes et logiciels / Création clé usb bootable
Bonjour,
J'ai créé une clé usb bootable avec Leap 15.2 dessus.
Pour ce faire j'ai utilisé SUSE Studio Imagewriter. A priori pas de problème particulier.
Lorsque je boote dessus sur la machine à laquelle je destine Leap 15.2, l'ordi me shoote en disant que la clé n'est pas une clé bootable et me demande d'insérer un disque bootable.
J'ai bien vérifié que le boot sur usb était bien autorisé et en priorité dans le bios.
J'ai fait la même opération sur ma machine habituelle, même réponse : clé non bootable.
J'ai refait la clé en utilisant UNetbootin, pour un résultat identique.
Un petit souci concernant ces 2 logiciels : rien ne m'indique que l'opération est terminée donc j'attends un certain temps avant de sortir ma clé du port.
Dolphin lit bien le contenu de cette clé dont l'intitulé est : openSUSE-Leap-15.2-DVD-x86_64695. Taille : 4.1 Gio, 4430 fichiers, 7 sous-dossiers.
Avez vous eu des soucis avec ces logiciels ?
Pour info, la clé utilisée est une SanDisk Ultra  16 GB, neuve, et j'utilise Tumbleweed.

J'ai fait un fdisk -l afin de m'assurer que la clé était bien vue et sans erreur ; à priori c'est OK.
Disk /dev/sdc: 14.53 GiB, 15597568000 bytes, 30464000 sectors
Disk model: Ultra          
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device     Boot   Start     End Sectors  Size Id Type
/dev/sdc1  *         64 5525567 5525504  2.6G  0 Empty
/dev/sdc2       5525568 5533759    8192    4M ef EFI (FAT-12/16/32)
7
Matériel / Changement disque système
Bonjour,

Je vais changer de disque système (remplacement d'un ssd 64 Gio par un 250 Gio).
Je vais prendre btrfs comme système de fichiers.
J'ai lu pas mal de trucs sur le partitionnement ou non d'un disque ssd. Les avis sont très partagés et je suis plutôt vieille école. Je reste donc sur ma faim.
Si encore utile aujourd'hui, je vais garder le partitionnement actuel mais il faudrait adapter la taille de chacune en conséquence. D'autre part, je me pose la question de savoir s'il convient de mettre la partition /var sur sdb (disque mécanique) pour cause de nombreuses écritures dans  ce répertoire et me passer du swap (qui est sur sdb), sachant que je n'utilise pas la fonction hibernation et que je ne dépasse jamais l'utilisation de mes 16 Gio de RAM.
Mon partitionnement actuel :
df -h
Filesystem      Size  Used Avail Use% Mounted on
devtmpfs        7.8G  8.0K  7.8G   1% /dev
tmpfs           7.8G     0  7.8G   0% /dev/shm
tmpfs           3.2G  2.0M  3.2G   1% /run
tmpfs           4.0M     0  4.0M   0% /sys/fs/cgroup
/dev/sda3       4.9G  904M  3.8G  20% /
/dev/sda5        35G   15G   18G  46% /usr
/dev/sda6       6.9G  3.7G  2.9G  56% /opt
/dev/sda7       5.9G  3.3G  2.3G  59% /var
/dev/sda8       2.0G  262M  1.6G  15% /srv
/dev/sda2       976M  138M  772M  16% /boot
/dev/sda9       3.1G   28M  2.9G   1% /tmp
/dev/sda1       511M  7.6M  504M   2% /boot/efi
/dev/sdb3       1.1T  427G  599G  42% /data
/dev/sdb2       830G  567G  263G  69% /home
tmpfs           1.6G   64K  1.6G   1% /run/user/1000
A court terme, j'envisage d'avoir un disque exclusivement pour /home et un autre pour /data.
Je vais peut-être (sûrement) lever un troll !
Votre avis sur la question ?
Ah oui ! Question à 10 sous ! Est-il possible de remettre certains contenus des partitions actuelles sur le nouveau disque comme les paramétrages de qemu par exemple ? Ou de cloner l'ancien sur le nouveau s'il a la même architecture ?
8
Installation et boot / Emergency mode au démarrage
Bonjour,
J'ai démarré mon fixe ce matin, comme d'habitude.
Or, que je démarre avec le noyau 5.10.16-1-default ou 5.10.14-1-default ou en mode recovery pour les deux noyaux considérés, j'ai Tumbleweed qui s'affiche (jusque là c'est OK), puis, au bout d'un certain temps (env. 1 mn) j'ai ce message :
You are un emergency mode. After logging in, type "journactl -xb" to view system logs, "systemctl reboot" to reboot, "systemctl default" or "exit" to boot into default mode.
Donnez le mot de passe du superutilisateur pour la maintenance 'ou appuyez sur Ctrl et D pour continuer) :
- Ctrl D ne donne rien. L'ordinateur tourne en rond et reste sur un curseur clignotant.
- journalctl -xb ne m'apprend rien (tout est au vert), sinon qu'il est brutalement interrompu.
- quand au reste, ben je reboote et reviens à la même problématique.
Une idée pour se dépatouiller de çà ?
Merci !
9
Programmes et logiciels / Thunderbird et images incorporées dans le texte
Bonjour,
Petit souci avec Thunderbird 78.4.0

Lorsque je copie-colle une image (capture d'écran) dans mon texte ou que j'insère une image présente sur mon disque dur, cela fonctionne et l'envoi du message se passe sans problème. Dans l'un et l'autre cas, l'image est intégrée et parvient à son destinataire.
Par contre, si je rajoute une deuxième image (par copier-coller ou par insertion), là aussi pas de souci lors de la rédaction du message. Après envoi, seule la première image est intégrée et parvient à son destinataire. Quand je jette un oeil aux messages envoyés, une seule image est effectivement présente dans le corps du message.
Que j'envoie cela à une liste de diffusion ou à un destinataire unique c'est pareil.

Avez-vous rencontré ce souci ? Et comment y remédier ?
10
Programmes et logiciels / Discover se lance à l'ouverture
Bonjour,
Depuis la dernière grosse mise à jour de Tumbleweed, j'ai Discover qui se lance dès l'ouverture de session. Ce qui devient pénible
Est-il possible de le paramétrer pour qu'il ne se lance que si besoin ? Je n'ai rien trouvé en ce sens...
En fait je ne l'utilise jamais, préférant Yast ou zypper, puis-je virer cette appli sans souci ?
Merci
11
Programmes et logiciels / Ecran de démarrage
Bonjour,
Je cherche où se cachent les écrans de démarrage (ceux qui apparaissent après le login). Je voudrais franciser un des écrans et ne trouve point .
Merci !
12
Programmes et logiciels / LibreOffice - Mais où sont passées les icones ?
La majorité des icônes des menus et barres d'outils a disparu aujourd'hui, que ce soit avec Calc, Writer et consorts
Pb suite à mise à jour (j'en ai fait une hier) ? Rencontrez vous le même souci ?

---
Eurêka ! Après tests, les thèmes sombres ne sont pas appréciés (j'utilisais principalement dark-opensuse) !
Retour des icônes en utilisant un thème clair style Breeze ou openSUSE par exemple.

Je repasse en thème clair en attendant mieux et passe en résolu.

---
Quand on est couillon...   :-[
Il me suffit de changer le style d'icône dans les options de LibreOffice et je peux garder mon thème global sombre.
13
Programmes et logiciels / Affichage sur bi écran bizarre
Bonjour,
J'ai deux écrans connectés à ma carte graphique (nVidia GTX 770). Les écrans sont identiques (même marque, même modèle, même définition).
Le résultat de inxi -Gx
 inxi -Gx
Graphics:  Device-1: NVIDIA GK104 [GeForce GTX 770] vendor: CardExpert driver: nvidia v: 440.64 bus ID: 01:00.0
           Display: x11 server: X.org 1.20.7 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa
           resolution: <xdpyinfo missing>
           OpenGL: renderer: GeForce GTX 770/PCIe/SSE2 v: 4.6.0 NVIDIA 440.64 direct render: Yes
A noter que la résolution n'apparaît pas. Problème du à la présence de 2 écrans ?

Depuis quelques temps, je suis confronté à un mini souci :
L'écran principal (le primaire) comporte la barre des tâches. Le second point du tout, ce qui est normal. Toutefois, sur l'écran secondaire je ne bénéficie plus du tout de mes applis en plein écran comme auparavant. J'ai l'emplacement de la barre des tâches, sans barre des tâches en bas de l'écran ! Problème qui ne se produit pas sur l'écran primaire.
Ce n'est pas pénalisant mais plutôt désagréable à l'oeil.
Comment y remédier ? Merci.
14
Virtualisation / QEMU/KVM - Carte réseau - Comment faire un pont
Bonjour,
J'ai procédé à l'installation de QEMU/KVM sans problème particulier.
Depuis virt-manager, j'ai importé une machine créée via Virtualbox. L'import a bien fonctionné.
Je trouve que ma VM (Win10) fonctionne bien, pas de souci côté video et c'est rapide.
Toutefois, point de réseau ! Je n'ai rien trouvé, via virt-manager, pour créer simplement un pont me permettant d'accéder à mon réseau et à internet.
Comment procéder ? Merci.
15
Virtualisation / Gestion de l'affichage dans VirtualBox
Bonjour,
Après une période d'accalmie, voici ce que j'ai dans une session VirtualBox dans laquelle je fais tourner Win 10.
Ce n'est vraiment pas terrible. A cela il faut ajouter une instabilité de l'écran.
Les Addons Invités sont bien installés.
Je remarque que si je fais tourner un Linux quelconque, je n'ai pas ce problème !
Une idée pour améliorer çà ?