Aller au contenu principal

Sujets

Cette espace vous permet de voir toutes les Sujets réalisées par ce membre. Vous ne pouvez voir que les Sujets réalisées dans les espaces auxquels vous avez accès.

Sujets - guiv

1
Programmes et logiciels / problème de mise à jour Leap 15.3
Bonjour à tous

Tentative de mise à jour Leap 15.3, et échec du fait d'une dépendance non résolue : yast2-them-oxygen 4.3.8 requiert yast2-branding 4.3.8 qui ne peut pas être fourni. Problème présent depuis quelques jours.

Bon, je veux bien croire que le thème "oxygen" ne soit plus maintenu (à supposer que cela soit l'explication?), mais est-ce que pour autant je peux supprimer le package "yast2-them-oxygen" ? Ca devrait résoudre le problème de dépendance. Sur le fond ça ne me dérange pas, et au moins ça débloquerait les mises à jour.
Je précise qu'il s'agit d'une machine familiale, donc multi-utilisateurs, et que je ne sais pas comment chacun a configuré son thème... Et j'aimerais si possible éviter que certains utilisateurs aient une surprise désagréable à l'ouverture de session ! Que pourrait-il se passer si le thème sélectionné n'est plus installé ?
Par ailleurs, suis-je le seul à avoir le problème ?
2
Installation et boot / plus de réseau après upgrade en 15.3
Upgrade de 15.2 à 15.3 avec zypper dup... plus de connexion réseau. Mais alors plus du tout.
Pas de wifi, ça encore je veux bien, c'est un vieux portable il faut probablement retrouver le driver. Mais plus de connexion Ethernet filaire non plus  :o ?! Tout le ''zypper dup' (quelques Go) est pourtant passé par là.

Là, ça m'a laissé perplexe pendant un bon moment. Parce qu'une machine déconnectée de tout, c'est assez délicat à manoeuvrer.
J'ai fini par m'en sortir avec :
lspci -v
Qui m'a permis d'identifier le module associé à l'interface réseau filaire, puis
modprobe r8169
Une fois reconnecté, pas bien difficile de retrouver ses petits et le bon paquet pour le wifi. Mais je n'arrive toujours pas à comprendre pourquoi ce module ne se monte plus tout seul... En pratique je n'utilise cette machine qu'en wifi, donc pas bien gênant, mais tout de même j'aimerais comprendre ?!
3
Matériel / scanner HP ne scanne plus en Leap 15.3
Sur ce coup-là j'accumule...
Et à chaque fois des erreurs différentes. Ça commence à être fatigant !

Après passage de 15.2 à 15.3 (zypper dup), je ne sais pas pourquoi mais hplip n'était plus installé. Je le réinstalle, l'imprimante revient. Mais pas le scanner, qui me réclame toujours ce fichu plugin.
Quand j'essaie de l'installer avec 'hp-plugin', il plante. Cette fois-ci, la dernière erreur affichée est :
PermissionError: [Errno 13] Permission non accordée: '/bin/sh'

Pourtant, je ne vois pas de pb de permission. En suivant les liens symboliques:
~> ls -l /bin/sh
lrwxrwxrwx 1 root root 11  6 mai   17:22 /bin/sh -> /usr/bin/sh
~> ls -l /usr/bin/sh
lrwxrwxrwx 1 root root 4  6 mai   17:22 /usr/bin/sh -> bash
~> which bash
/usr/bin/bash
~> ls -l /usr/bin/bash
-rwxr-xr-x 1 root root 1012544  6 mai   17:22 /usr/bin/bash

Et même en root:
PermissionError: [Errno 13] Permission denied: '/bin/sh'

Je commence à être franchement à court d'imagination...  :'(
4
Matériel / scanner HP ne scanne plus depuis mise à jour Tumbleweed
Il n'y a pas si longtemps que ça (1 ou 2 semaines) mon scanner réseau HP fonctionnait encore sans problème avec Xsane.
Comme cela arrive parfois après des mises à jour, lorsque je lance Xsane il me demande d'installer un plugin... mais cette fois-ci l'installation foire avec un message peu éloquent, du genre "ça marche pas".

Je sais que lorsqu'il télécharge ce plugin il le range dans /home/[user]/.hplip.
En l'occurrence : hplip-3.20.11-plugin.run
En faisant une copie du plugin avant que celui-ci ne soit supprimé, j'arrive à le lancer à la main et à avoir un message d'erreur plus clair, bien que très suprenant : "Error importing HPLIP modules.  Is HPLIP installed?"

Ben oui il est installé, hplip... en version 3.20.11-2.5 d'après Yast. Ca semble cohérent.

J'ai essayé de télécharger la dernière version depuis le site de HP, mais il m'informe que tumbleweed n'est pas supporté.

Une idée ?
J'espère que ça n'est pas encore une histoire de dépendance implicite, j'ai déjà bien ramé sous Leap 15.2...
5
Général / Tumbleweed ne veut plus s'éteindre (Network Manager)
Depuis quelques jours ma tumbleweed ne s'éteint plus correctement. La procédure se bloque sur :
A stop job is running for Network Manager ( / )

Avec un chrono qui s'incrémente et une échéance affichée à 1min31s. Au bout d'1min31 l'échéance passe à 3min01, puis 4min32, puis 6min02. Là il passe enfin à l'étape suivante, puis se bloque à nouveau :
A stop job is running for WPA Supplicant daemon ( / )

Ça tourne... l'échéance grimpe tranquillement jusqu'à 12min03... C'est long !
Il enchaîne et finit par rester bloqué sur un laconique "Reached target power-off", où il ne me reste plus qu'à faire un appui long sur le bouton power  :(

Pour une machine qui redémarrait en 45 secondes il y a quelques jours c'est un peu frustrant !
Comportement pas systématique, mais pas loin, c'est à dire bien trop fréquent à mon goût. Reproduit en utilisant la commande d'extinction de KDE, également avec une commande poweroff en root

Une idée ?
6
Programmes et logiciels / freecad 0.19 et tumbleweed
Depuis la dernière mise à jour de FreeCAD (0.19.1-1.1) celui-ci s'avère assez instable, et me renvoie à la pelle des erreurs "call stack is not deep enough"  :(
Un exemple assez trivial (parmi beaucoup d'autres) : depuis FreeCAD, ouvrir un fichier fonctionne sans problème. Mais en cliquant directement sur le même fichier depuis Dolphin, FreeCAD s'ouvre, me renvoie une palanquée erreurs "call stack is not deep enough", et ne m'affiche rien de rien (re- :( )
2 petites questions :
- je suis le seul dans ce-cas là ?
- quelqu'un saurait me dire comment faire un downgrade du package ? Sous Leap je saurais faire sans problème, mais sous Tumbleweed je n'ai jamais fait. Dans le software management de Yast, seule la dernière version du package apparaît (ce qui paraît logique dans une rolling release...)
7
Programmes et logiciels / plus d'icone owncloud
Salut à tous

Depuis quelques semaines, je n'ai plus d'icône pour mon client owncloud dans ma "boîte à miniatures" KDE sous Tumbleweed.
Ou plutôt l'icône n'est plus visible. Il y a bien un espace vide à la place, quand je passe la souris dessus il m'affiche le message correspondant, je peux faire un clic-droit dessus et j'ai mon menu contextuel owncloud, mais l'icône n'est plus visible.
Pas dramatique, mais bon. Comme l'icône affiche l'état de la synchronisation c'est tout de même pratique quand ça marche.
Quelqu'un a une idée ?
(note : pas de problème sur une autre machine sous Leap)
8
Matériel / Leap 15.2 et imprimante/scanner HP, galère
Salut

Ce petit post pour partager mes difficultés d'install d'une imprimante/scanner HP en Leap 15.2. Et la solution qui va avec, si d'autres ont le même problème.

Je viens de faire une fresh install de Leap 15.2, et impossible de réinstaller correctement imprimante et scanner réseau HP.
Cette imprimante/scanner fonctionne parfaitement sur 2 autres machines, une en tumbleweed, et une en Leap 15.2 (j'avais installé l'imprimante/scanner quand j'étais en 15.1).

La procédure usuelle :
- install du paquet hplip
- lancement de la commande hp-setup (soit en console, soit depuis le menu installation d'imprimante de Yast)
Comme d'habitude, je donne l'adresse IP de mon imprimante, elle est reconnue. On me demande alors d'installer un plugin. OK. Une fenêtre s'affiche pour la licence, puis une autre pour saisir le mot de passe root. Une minute plus tard, j'ai une fenêtre "plugin installé avec succès". Jusque là, je reconnais le fonctionnement habituel de l'installeur HP.
Mais... dès que je clique sur OK pour fermer cette fenêtre une seconde s'ouvre avec un message d'erreur "the device you are trying to setup requires a binary plug-in ..."
Et je me retrouve à l'étape précédente :-(

Leap 15.2 installe la version 3.19.12 de hplip
Après avoir galéré pendant un bon moment j'ai fini par aller chercher la dernière version (3.20.9) directement sur le site de HP.
Pas un rpm, mais un script, qui installe tout plein de dépendances, et qui finalement recompile hplip. Il faut prendre patience, c'est un peu long...
Echec à la première tentative, un paquet manquant (python-devel, pourtant disponible dans les dépôts). Après install de ce paquet à la main, à la seconde exécution du script tout s'est bien passé.
Ensuite, exécution de hp-setup comme d'hab, et la configuration de l'imprimante passe comme une lettre à la poste, en 1 min j'ai retrouvé mon imprimante et mon scanner, ouf !

Ca reste moyennement satisfaisant comme solution, puisque je me retrouve avec une version de hplip installée sans passer par le package manager, donc pas de mise à jour automatique.
Mais bon... au moins ça fonctionne.
9
Installation et boot / après MàJ - Plus de session KDE
Salut

et ben voilà... J'ai exactement le même problème, exactement les mêmes symptômes.
Pour l'instant je m'en suis sorti grâce à un 'snapper rollback' = je suis revenu sur une snapshot de ma partition / avant l'update.

Et je dois admettre que je suis un peu inquiet à la lecture de la solution proposée... qui ne me paraît pas triviale du tout !
Si quelqu'un a une idée je suis preneur

Pour répondre aux quelques questions posées dans ce fil:
- j'ai de la place à la racine
- je n'utilise pas les drivers nvidia
- je n'ai pas osé désinstaller kwayland (provoque trop de désinstallations d'autres paquets, dont certains utiles)