Aller au contenu principal

Sujets

Cette espace vous permet de voir toutes les Sujets réalisées par ce membre. Vous ne pouvez voir que les Sujets réalisées dans les espaces auxquels vous avez accès.

Sujets - burn2

16
Internet, réseaux et serveurs / OpenVPN ne fonctionne pas depuis Network manager KDE
Bonjour,

J'ai OpenSuse leap 15.2 d'installé.
J'ai bien openvpn d'installé.

SI j'importe mon profil vpn depuis l'applet kde (network manager du coup), le vpn ne fonctionne pas j'ai droit à:
Citer
2021-02-07T10:59:24.931143+01:00 CLEVO-WD230SD NetworkManager[1674]: <info>  [1612691964.9310] audit: op="statistics" arg="refresh-rate-ms" pid=2339 uid=1001 result="success"
2021-02-07T11:00:18.355764+01:00 CLEVO-WD230SD nm-openvpn[3885]: TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
2021-02-07T11:00:18.356122+01:00 CLEVO-WD230SD nm-openvpn[3885]: TLS Error: TLS handshake failed
2021-02-07T11:00:18.356337+01:00 CLEVO-WD230SD nm-openvpn[3885]: SIGUSR1[soft,tls-error] received, process restarting
2021-02-07T11:00:18.379756+01:00 CLEVO-WD230SD NetworkManager[1674]: <warn>  [1612692018.3796] vpn-connection[0x55618fd282e0,04bb74c1-ebbe-4fa8-9013-da8df59a90b1,"OpenVPN_INTERNET",0]: VPN connection: connect timeout exceeded.

Le profil fonctionne parfaitement network manager version gtk comme sous mate/cinnamon sur les distribs que j'ai pu tester.
Mais sous openSuse kde aucune idée de pourquoi ça ne veut pas.

Sur ce même pc si je fais une connexion manuelle depuis le profil root du coup
Citer
openvpn OpenVPN_INTERNET
Sun Feb  7 18:43:02 2021 OpenVPN 2.4.3 x86_64-suse-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Jun 20 2017
Sun Feb  7 18:43:02 2021 library versions: OpenSSL 1.1.1d  10 Sep 2019, LZO 2.10
Enter Auth Username: xxxxxxxxxxx
Enter Auth Password: **************
Sun Feb  7 18:43:24 2021 TCP/UDP: Preserving recently used remote address: [AF_INET]XXX.XXX.XXX.XXX:1194
Sun Feb  7 18:43:24 2021 UDP link local (bound): [AF_INET][undef]:0
Sun Feb  7 18:43:24 2021 UDP link remote: [AF_INET]XXX.XXX.XXX.XXX::1194
Sun Feb  7 18:43:24 2021 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Sun Feb  7 18:43:25 2021 [OpenVPN_INTERNET_Certificat] Peer Connection Initiated with [AF_INET]XXX.XXX.XXX.XXX::1194
Sun Feb  7 18:43:26 2021 TUN/TAP device tun0 opened
Sun Feb  7 18:43:26 2021 do_ifconfig, tt->did_ifconfig_ipv6_setup=0
Sun Feb  7 18:43:26 2021 /bin/ip link set dev tun0 up mtu 1500
Sun Feb  7 18:43:26 2021 /bin/ip addr add dev tun0 local 10.xx.xx.xx peer 10.xx.xx.xx
Sun Feb  7 18:43:26 2021 Initialization Sequence Completed

ça fonctionne parfaitement, et quand je vérifie mon ip elle a bien changée.
Pourquoi l'import de configuration ne fonctionne t-il pas sous openSuse kde???

Avez vous déjà eu ce genre de problème?

Merci d'avance.
17
Sécurité / Accès disque dur chiffré externe
Bonjour,

J'ai un soucis sous kde leap 15.2.
J'ai un disque dur externe chiffré qui a été chiffré depuis une ubuntu 18.04 .

Lorsque je monte le disque dur depuis mon user "normal" le montage fonctionne mais j'ai une erreur d'accès.
Voici le fonctionnement:
Je vois le volume chiffré apparaître.
Je vais dans dolphin et je clique sur le disque dur ==> il me demande mon mot de passe de chiffrement du disque dur.

Le montage se fait bien mais j'ai un message d'erreur:
Citer
Une erreur est survenue en accédant à « DD_EXTERNE ». Le système a répondu :Le périphérique est déjà monté: Device /dev/dm-3 is already mounted at `/run/media/user/DD_EXTERNE'.

Il ne s'agit pas d'un droit sur un dossier particulier, je ne vois même pas la racine du disque dur externe.
En vrais le problème n'est qu'une histoire de droit user, car si j'ouvre dolphin en mode administrateur, alors je peux accéder au contenu du disque dur chiffré.


Avez vous une idée de ce qu'il faudrait rajouter au user pour que le montage de disque dur externe chiffré fonctionne?
18
Programmes et logiciels / Problème application flatpak kde X11
Bonjour,

J'ai un soucis avec des applications flatpak sous OpenSuse 15.2 kde.
J'ai installé en flatpak element (riot).
Lorsque je lance element sur une session kde X11, ça ne fonctionne pas j'ai ça comme erreur:
Citer
latpak run im.riot.Riot
[2 zypak-helper] Portal v4 is not available
/home/user/.var/app/im.riot.Riot/config/Element exists: no
/home/user/.var/app/im.riot.Riot/config/Riot exists: no
No protocol specified
[8 zypak-sandbox] Dropping 0x1adc260 (3) because of connection closed
[8 zypak-sandbox] Host is gone, preparing to exit...
La détection des répertoires et normal vu que l'application ne se lance pas.

SI je bascule en session wayland ça fonctionne à nouveau.
Si je bascule en session full wayland à nouveau ça ne se lance pas.
Vous avez une idée de ce qui peut dauber?

Merci d'avance.
19
Sécurité / Grosse faille SUDO
Bonjour,

Je ne sais pas encore si openSuse est concernée (en toute logique oui), mais une grosse faille sur sudo a été répertoriée.
Le CVS:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3156

Et l'info de la part de l'entreprise à l'origine de la découverte:
https://blog.qualys.com/vulnerabilities-research/2021/01/26/cve-2021-3156-heap-based-buffer-overflow-in-sudo-baron-samedit


Voilà donc soit la maj est dispo et à vos majs, soit il va falloir faire gaffe d'ici là.
20
Autres distributions GNU/Linux et BSD / Suse Desktop enterprise ?
Hello

Quand on aime une distrib, on se dit qu'il peut être judicieux de participer, et pourquoi pas prendre la version "payante" source d'openSuse à savoir la version  de Suse, ou par curiosité.

La question que je me pose, c'est ça se passe comment sous Suse niveau packet/dépôt?
Genre sous openSuse on a suse software search, mais pour suse "tout cours"?
On a accès à tous les environnements de bureau ou c'est ultra limité?
NIveau logiciel idem?

Je vais voir si je peux tester la version de test pour voir les limites, mais je me pose la question? :)


Edit: niveau logiciel on a ça en plus:
https://packagehub.suse.com/

Mais ça n'est pas non plus exhaustif.
21
Matériel / OpenSuse Leap 15.2: Lenteurs et soucis sous virtualbox
Bonjour,

Niveau config j'ai une config courante, un asus UX310ua, donc avec un intel 6200u avec 2*8go de ram et un SSD 860 evo 1to.

Je trouve que la distrib est assez "lente". Par exemple lors de l'installation des mises à jour je trouve que c'est assez lent, c'est difficile à chiffrer mais ça me semble assez lent niveau accès. J'ai l'impression que ça cloche niveau support cpu.

Idem, lorsque je veux utiliser virtualbox sur mes vm d'avant, impossible d'avoir une accélération 3D. Je suis obligé de décocher la case accélération gpu sans quoi les vm ne passent pas.

Vous avez une idée de ce qui peut clocher niveau support cpu/gpu? C'est pourtant du "basique" full intel.  ::)


EDIT: je viens de me rendre compte que la case "activer VT-X/AMD-v imbriqué" était grisé chez moi.
IL faut que je trouve pourquoi déjà??? :??:
Vu que mon cpu est bien VT-D
22
Programmes et logiciels / Pas mal de logiciels manquants dans les dépôts leap
Bonjour,

Petite remarque, je trouve vraiment dommages que des logiciels "courants" ne soient pas dans les dépôts principaux.
Exemple seafile:
https://software.opensuse.org/package/seafile-client
C'est un paquet expérimental, ça implique quoi?

X2Go-client:
https://software.opensuse.org/package/x2goclient
X11:RemoteDesktop:x2go Expérimental
Encore un expérimental et en plus ce n'est pas complet, il manque des modules pour que ça s'installe, du coup obligé de se rabattre sur un communautaire (home:ithod:x2go dans mon cas).

Surpris de voir aussi que firefox est toujours en version 78 et non pas 80, c'est une version ESR je suppose?
23
Programmes et logiciels / Leap 15.2: Clementine ==> MP3 ko alors que pluggins mp3 installés.
Bonjour,

J'ai un soucis avec clementine.
Contexte:
OpenSuse Leap 15.2
Bureau cinnamon
Paquets codecs installés comme recommandé ici: https://opensuse-guide.org/codecs.php

Et pourtant quand je rajoute par exemple fréquence 3 en m3u, j'ai droit à :
"gstreamer could not create the element : autoaudiosink.
Please make sure you that you install all the necessary gstreamer pluggin".


En regardant quels sont les groupes dont mon user est membre, je me demande si ce n'est pas ça qui cloche.
Dans l'installation de base, le user n'est membre de rien.
Si on choisi un bureau comme kde/gnome vous avez quoi comme droits?

Merci d'avance
24
Installation et boot / BTRFS ou ext4?
Bonjour,

Je ne vais pas tarder à me lancer à remplacer mon ubuntu 18.04 par une Leap 15.2 sous cinnamon.
Je sais que de base openSuse part sur du btrfs pour le / et du XFS pour le /home.
Or de ce que je vois le principal intérêt de btrfs c'est les snapshot.
Dans mon cas je n'ai jamais eu à réinstaller mes distribs suite à des majs foireuses (ça peut arriver lors d'upgrade à la version +1, mais ça ne me dérange pas dans ce cas précis je prévoie toujours le cas), et je m'attends à ce qu'il en soit de même avec leap.
Partant de là, je pars du principe que je n'ai donc pas besoin des snaps qui prennent de la place pour rien.

DIfficile de me faire un avis niveau performance, en cherchant on tombe sur ça:
https://www.phoronix.com/scan.php?page=article&item=linux-50-filesystems&num=1
Qui n'est pas ultra récent mais clairement pas en faveur de btrfs?
Ou encore ça:
https://unix.stackexchange.com/questions/525613/xfs-vs-ext4-performance
Qui confirmerait que ext4 reste quand même un choix plus judicieux.

Pour quelqu'un qui a son installation en full ssd, avec comme découpage en général:
/boot (non chiffré)
/ chiffré
/swap

Vous choisiriez quoi? 
Ext4 + Lvm a un côté rassurant stable sans jamais d'ennuie, qu'en est-il réellement de btrfs/xfs?

Merci d'avance
25
Installation et boot / OpenSuse tumbleweed Installation + maj
Bonjour à tous et toutes.

Me voilà de retour (non pas pour vous jouer un mauvais tour...) pour essayer un peu OpenSuse.
Testant un peu pas mal de distrib, je me suis donc mis à tester OpenSuse tumbleweed en VM.

Pour l'installation j'ai pas mal galéré au niveau du partitionnement.
Mon but c'était de chiffrer le "/" comme je l'ai toujours fait. Normalement je mets dans un conteneur LVM mais ça n'a pas fonctionner.

Au final voilà ce que j'ai fais:
-Partition de démarrage de bios de 8m
- /boot de 1go en FAT
- / en brfs chiffré de 50go
- Swap de 8go



Une fois installé tout s'est bien passé.
Le mot de passe demandé était bien en azerty.


Récemment j'ai donc fais l'upgrade d'openSuse via la fameuse commande zypper dup.
L'upgrade est bien passée mais, maintenant au boot, après grub, pour déchiffrer la partition /, le mot de passe doit être saisi en QWERTY.

J'ai regardé dans yast dans la conf du bootloader, je ne vois rien qui précise ça.
Tout le reste est bien toujours en FR dans l'interface, seul le mdp au chargement est passé en qwerty.

Auriez vous une idée du pourquoi?


En comparaison j'ai testé sur une manjaro que j'ai installé il y a quelque temps en vm, je n'ai pas ce soucis là,  je suis toujours en FR au niveau du boot avec une installation très proche (pas de brfs mais bon le reste est identique).

Merci d'avance.

26
Présentations / Comme un grand sage a dit "I will be back" et bien i am back. :D
Bonjour à tous et toutes.

Une pensée particulière à ceux qui me reconnaîtront. ;)

En effet ceci n'est pas ma première venue sous OpenSuse, je l'ai longtemps utilisé de la version 10.2 environ à la version 13.3 (il me semble de mémoire), et j'avais pas mal participé à ce forum (enfin la précédente version) à l'époque.

Après être resté longtemps sous Ubuntu LTS, (oui c'est pas bien bouh, mais le travail surchargé et les sorties trop régulières d'openSuse par la suite m'ont forcé à basculer sur une LTS), les choix prévus par canonical pour la version 20.X (Snap un max) ne me plaisant pas, je refais un test de ce qui existe comme distrib et je me remets donc à tester OpenSuse histoire de voir s'il est envisageable pour moi de retourner à mes anciens amours. :D

Pour ceux qui ne me connaîtrait pas d'avant, considérez moi comme un newbee ça ira très bien. :D


En résumé, salutation à tout le monde!