Aller au contenu principal
Sujet: GRUB (Lu 60107 fois) sujet précédent - sujet suivant

GRUB

Bonjour à toutes et tous
Je viens de faire une MàJ de 240 paquets
Après avoir lancé ma MàJ , j'ai eu un message concernant GRUB , selon lequel il n'y avait pas de fournisseur  pour cette MàJ
Je résume le message , mais c'est le message classique du manque de fournisseur  sur un paquet donné
4 choix possibles  1) désinstaller GRUB et les dépendances , 2) je ne sais plu 3) casser grub  4) garder la version obsolète
Plein de certitudes , me disant que si il me proposait de désinstaller , c'est que forcément quelques part il y avait qque chose de neuf à mettre à la place
éh bien non
Si bien qu'au redémarrage , j'ai un écran noir avec GRUB et une invite de commande  et curseur clignotant
J'ai bien tenté " start sddm " sans conviction , et j'avais bien raison , ça n'a rien démarré
Comment faire : soit redémarrer GRUB , soit démarre une l'affichage graphique de tumbleweed
Je me dis que si j'arrive à démarrer Tumbleweed , je pourrai retrouver et installer GRUB à partir de Yast
Ou , réinstaller GRUB à partir de son écran de démarrage , sachant que je suis connecté en filaire
Merci
Bonne journée

Re : GRUB

Répondre #1
Si vous avez le dvd d'installation faites une mise à niveau. Cela réinstalle automatiquement Grub à la fin.

Re : GRUB

Répondre #2
Bonjour Sobkowiac
Merci
Je n'ai plus le media d'installation , c'est une installation de plusieurs années ( +-  2/3 ) et c'était à partir d'une clef USB
Je peux refaire facilement une nouvelle clef bootable  avec une image récente , est ce que cela marcherait ? et je ne voudrais pas perdre les données qui sont sur le disque , comme je n'ai qu'une distribution sur le disque , je ne me suis pas compliqué la tâche en faisant une partition " home " , et je m'en mords les doigts
Pour récupérer les données , je peux passer par une autre distribution , mais cette installation n'avait pas encore intégré les pilotes NVidia , et elle " marche " très bien
Avant de tenter quoique ce soit , j'attends votre confirmation ou infirmation  de ma manip suggérée
Bonne fin de journée

Re : GRUB

Répondre #3
Tu peux faire la manip' indiquée par @sobkowiak  depuis une nouvelle image.

Si tu n'as pas de home séparée, tes données sont sauvegardées dans les snapshots de btrfs (si tu utilises ce type de fichiers).

Mais pense à faire des sauvegardes régulières sur disque externe avec, au choix, rsync, luckybackup, grsync, kup, etc...


à plus,
oh!rocks

 

Re : GRUB

Répondre #4
Bonsoir oh!rocks
Merci
Je vais faire la manip demain , ça me laisse un peu plus de temps
Cela fait déjà qques temps que j'installe en btrfs , mais cette installation qui date de qques années , je ne me souviens plus si c'était btrfs ou encore ext4
Avant de faire la manip , je vais voir si je peux récupérer mes fichiers  avec une distrib sur clef
Je vous retournerai toutes les infos demain dans la journée
Bonne soirée

Re : GRUB

Répondre #5
Bonjour à toutes et tous
Je galère un peu pour dépanner et réparer ma bêtise
J'ai donc fait une copie des dossiers et fichiers que je souhaitais conserver , parce que ça ' " s'emmanchait " plutôt mal
Ensuite j'ai essayer toutes les possibilité offerte par " l'écran" d'accueil de l'installeur
1) démarrer le hdd  > écran noir et Grub  curseur en attente , comme je ne sais pas quoi lui donner , je passe à
3) mettre à niveau   >  affichage  de tous les fichiers manquants pour aller plus loin , je cale et passe à
4)Système de secours   > écran noir  comme TTY , c'est bien ,sauf que les commandes que j'avais récupérées sur le forum anglais , elles ne passent pas , comme si il manquait quelques choses ( un ordre reconnu ) . J'essais quand même " sudo yast2 " ,c'est une des lignes de commandes que j'ai trouvé , mais ça ne passe pas  . Alors
5) démarrer Linux  > je passe les étapes  en acceptant les choix  ,jusqu'a OK et  écran bleu , un curseur qui attend ,mais là encore je ne sais pas quoi lui donner
Donc je revient à 3 mettre à niveau
Là , j'avance un peu plus , puisque j'arrive à Yast , où je coche  les cases de GRUB 2  et tout ce qui va avec , et tout s'installe
Sauf que maintenant il manque des " packages "
Message
                 " impossible de lire la base de données RPM actuelle "
                  " aucun de ces fichiers n'existe "
                   "/mnt/var/lib/rpm/Packages "
                   "/mnt/var/lib/rpm/packages.rpm"
                  " /mnt/var/lib/rpm/Packages.db "
Comment faire pour monter ou charger ces fichiers
J'arrive bien à ouvrir une fenêtre quoi doit être un terminal ( byebug), mais ne prend pas en compte les commandes classiques
Si vous avez une petite idée avant la réinstall
Merci
Bonne soirée


Re : GRUB

Répondre #7
Bonsoir Chalu
 Merci pour ce lien , c'est exactement le message que j'avais
Je n'ai pas voulu supprimer " dracut " il est de toutes les MàJ et en quantité de lignes  , et ça ,depuis l'installation de cette Tumbleweed , je disais 2/3 ans , mais vu les fichiers que j'ai sauvegardés hier , ce serait plutôt 4/5 ( le temps passe :'( )
Mais , je suis quand même idiot , d'habitude , lorsque j'ai ce genre de message , j'abandonne  , et j'attends avant de faire la MàJ et je parcours les forums pour voir si ce problème est rencontré par d'autres , et là ,comme un
Je vais essayer de chercher encore un peu sur les forums , il doit bien exister un moyen de corriger ça !
Si bien que le problème "texlive " de l'autre fil , il est un peu en stand-by, je ne sais pas si il ne va pas être résolu avec une nouvelle installe
Bonne soirée

Re : GRUB

Répondre #8
La database de rpm a peut être besoin d'être reconstruite? rebuild rpmdb

Re : GRUB

Répondre #9
Bonsoir Jtro
Merci
Je dois le reconstruire en passant par l'option  " système de secours "   , c'est celle qui m'amène sur un terminal après chargement du système , et c'est la seule place où je peux utiliser la ligne de commande  en root
Est ce que " rebuild rpmdb "  est la ligne de commande complète
Je me dépanne avec une iso  (4.3 Go )sur une clef usb
Bonne soirée

Re : GRUB

Répondre #10
Salut. Regarde sur le man. Là je suis sur téléphone, pas de pc. Normalement c'est --rebuilddb.à confirmer. Ça reconstruit une base corrompue de rpm
Edit: rpm -rebuilddb

Re : GRUB

Répondre #11
@jenrem : Bonjour,

Sur trois installations de TW, sur une seule j'ai eu la question au sujet du conflit grub2 / dracut-pcr-signature. Je me suis dit qu'il était impossible de virer grub2 sans connaître de graves problèmes ultérieurement. Je suis allé voir les deux autres installations et sur celles-ci dracut-pcr-signature n'était pas installé (pas plus que sdbootutil). J'ai donc choisi l'option 2 (dracut tout seul n'en demeure pas moins installé).

Je n'ai aucune idée de la raison pour laquelle ces paquets conflictuels avec grub2 étaient installés sur ce PC.

Jette un œil sur cette page pour réparer une base de donnée RPM corrompue :

https://www.suse.com/support/kb/doc/?id=000017180

C'est de la documentation SUSE plutôt complète sur le sujet. Elle indique aussi où le système fait des sauvegardes de la base de données RPM et comment au besoin récupérer l'une d'elles.

Re : GRUB

Répondre #12
Bonsoir à toutes et tous
je viens donner un peu de nouvelles , j'avance à petit pas
Merci  Jtro , Chumi
J'ai réussi à passer les commandes , mais pas évident d'arriver sur une konsole tty de la distrib installée
En passant par une clef bootable de Tumbleweed , il faut  prendre l'option " système de secours " , on arrive sur un écran bleu  avec en premier les choix d'une image kernel  (2 dans mon cas ) ensuite on a un choix multiple 7/8 lignes , dont en premier le choix de la partition  où se trouve la distrib ( sda2 dans mon cas ) et les autres concernent les disques , je n'ai pas fait attention si il y avait la partition d'amorçage ( je vais donc refaire la manip )apès avoir choisi le disque , on se retrouve sur un écran noir .
Pour passer sur TTY , j'ai essayé  Ctrl+Alt + f1,f2,f3,f4 , je ne sais pas quelle combinaison a marcher ,mais je me suis retrouvé dans la konsole , et là j'ai pu rentrer les commandes , un temps de latence +-30"et le curseur reparaît ,j'ai rentré les 3 lignes du lien de Chumi , .
Mais comment savoir si il se passait qque chose , j'ai à nouveau rentré les lignes avec des erreurs de syntaxe , et  aussitôt  un message d'erreur comme quoi la commande n'était pas reconnu , j'en conclu qu'il s'est passé quelques chose
Après , j'ai redémarrer pour voir si cela avait recaler tout , hé bien non , je suis toujours sur l'écran noir de GRUB
Donc je continue de chercher dans les forums anglais . Je me dis qu'il doit bien y avoir une solution de dépannage , si un ordi pro se retrouve pris comme ça , si il y a des dossiers sensibles , il doit bien y avoir un moyen de dépanner . Bon , j'admet que les pros sont sûrement moins idiots que moi , mais " ya" toujours un risque
Je vous raconte tout ça , au cas ou quelqu'un aurait la même mésaventure , qu'il n'abandonne pas trop vite , le chemin est long
Bonne soirée

Re : GRUB

Répondre #13
Salut @jenrem

C'est compliqué de suivre, car tu fais plusieurs options en même temps sans aller au bout.

Je pense que tu dois commencer avec l'option « mise à niveau », qui est l'option la plus simple.

– Dans l'option « mise à niveau », tu as le choix entre combien de grub ? (Tu étais en multiboot ou pas ? ?)

Re : GRUB

Répondre #14
Bonjour Yoman
Je suis en simple boot  , 1SSD 120Go , une distrib et un SSD sur usb  pour faire les sauvegardes lorsque c'est nécessaire ( et aussi  lorsque j'y pense  :-[ )
J'ai fait toutes les options les unes après les autres ,avec redémarrage à chaque fois , bien sûr
Mise à niveau , je bloque  au niveau de " mise à jour " , c'est à ce moment là qu'il me signal
Citer
" impossible de lire la base de données RPM actuelle "
                  " aucun de ces fichiers n'existe "
                   "/mnt/var/lib/rpm/Packages "
                   "/mnt/var/lib/rpm/packages.rpm"
                  " /mnt/var/lib/rpm/Packages.db "
et je ne peux pas faire autrement que " abandon " ,l'autre choix " poursuivre " ,me ramène toujours au message ci dessus
Système de secours , je suis sur une konsole  , je suis en root , mais je ne sais pas quoi lui donner comme commande , et surtout , je ne sais pas si je suis dans le terminal de la clef ou du disque ??
Enfin , " démarrer Linux " , me donne les choix de disque et de partition . Lorsque j'ai fait mon choix , je pense être dans le terminal du disque ,mais comment le savoir ?
Dans le lien que m'a donné Chumi , il est écrit qu'il faut vérifier  dans /var/lib/rpm  si  les " Packages " sont présents , j'ai donc essayé
# nano /var/lib/rpm 
mais je ne rêvais pas du résultat
Je suis allé voir voir aussi en passant par une clef usb bootable ( Manjaro ) tous les dossiers de Tumbleweed , mais beaucoup , dont " var "  sont vides  ??
C'est peut être un peu fouillis  , mais c'est un résumé de toutes les opérations que j'ai faites depuis ma co..erie
j'espère que tu ne t'arraches pas les cheveux  après cette lecture
Bonne journée