Aller au contenu principal
Sujet: Les dépôts Leap : j'ai peut-être f... le b... (Lu 498 fois) sujet précédent - sujet suivant

Les dépôts Leap : j'ai peut-être f... le b...

Bonsoir,
J'ai donc installé OpenSuse Leap.
Et j'ai rajouté 2-3 logiciels qui n'étaient pas dans les dépôts de base : Skype, Zoom, Basket, 1 ensemble d'anciens fonds d'écran...
Et du coup, je me demande si je n'ai pas fichu le b... dans mes dépôts.

Lorsque j'ouvre le gestionnaire de logiciels de Yast, j'ai ce message d'erreur :

Citer
Une erreur s'est produite au cours de l'initialisation du dépôt. [https-download.opensuse.org-aa43ee68|https://download.opensuse.org/repositories/SUSE:/SLE-15-SP1:/Update/pool-leap-15.3/] Aucune métadonnée valide trouvée à l'URL spécifiée Historique : - [https-download.opensuse.org-aa43ee68|https://download.opensuse.org/repositories/SUSE:/SLE-15-SP1:/Update/pool-leap-15.3/] Repository type can't be determined.

La commande
zypper respos
me fait un retour suivant :
#  | Alias                                 | Name                                                                 | Enab-> | GPG Check        | Refresh    | Priority | Type   | URI                                                                                  | Service
---+---------------------------------------+----------------------------------------------------------------------+--------+------------------+------------+----------+--------+--------------------------------------------------------------------------------------+--------
 1 | ftp.gwdg.de-openSUSE_Leap_$releasever | Packman Repository                                                   | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.3/                   |
 2 | http-opensuse-guide.org-ce90ac66      | libdvdcss repository                                                 | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_15.3/                                   |
 3 | https-download.opensuse.org-214f5584  | SUSE:SLE-15-SP2:Update                                               | Oui    | ( p) Oui         | Oui        |   99     | NONE   | https://download.opensuse.org/repositories/SUSE:/SLE-15-SP2:/Update/pool-leap-15.3/  |
 4 | https-download.opensuse.org-239f642c  | openSUSE:Backports:SLE-15-SP3                                        | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | https://download.opensuse.org/repositories/openSUSE:/Backports:/SLE-15-SP3/standard/ |
 5 | https-download.opensuse.org-29d2047a  | SUSE:SLE-15-SP1:GA                                                   | Oui    | ( p) Oui         | Oui        |   99     | NONE   | https://download.opensuse.org/repositories/SUSE:/SLE-15-SP1:/GA/pool/                |
 6 | https-download.opensuse.org-30442878  | SUSE:SLE-15-SP3:GA                                                   | Oui    | ( p) Oui         | Oui        |   99     | NONE   | https://download.opensuse.org/repositories/SUSE:/SLE-15-SP3:/GA/pool/                |
 7 | https-download.opensuse.org-88e90e2a  | SUSE:SLE-15:Update                                                   | Oui    | ( p) Oui         | Oui        |   99     | NONE   | https://download.opensuse.org/repositories/SUSE:/SLE-15:/Update/pool-leap-15.3/      |
 8 | https-download.opensuse.org-98456164  | home:dimesio:branches:KDE:Extra                                      | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | https://download.opensuse.org/repositories/home:/dimesio:/branches:/KDE:/Extra/15.3/ |
 9 | https-download.opensuse.org-a805c074  | SUSE:SLE-15-SP2:GA                                                   | Oui    | ( p) Oui         | Oui        |   99     | NONE   | https://download.opensuse.org/repositories/SUSE:/SLE-15-SP2:/GA/pool/                |
10 | https-download.opensuse.org-aa43ee68  | SUSE:SLE-15-SP1:Update                                               | Oui    | ( p) Oui         | Oui        |   99     | NONE   | https://download.opensuse.org/repositories/SUSE:/SLE-15-SP1:/Update/pool-leap-15.3/  |
11 | openSUSE-Leap-15.3-2                  | openSUSE-Leap-15.3-2                                                 | Non    | ----             | ----       |   99     | rpm-md | hd:/?device=/dev/disk/by-id/usb-_USB_DISK_2.0_900061FD09170080-0:0-part2             |
12 | repo-backports-debug-update           | Update repository of openSUSE Backports (Debug)                      | Non    | ----             | ----       |   99     | NONE   | http://download.opensuse.org/update/leap/15.3/backports_debug/                       |
13 | repo-backports-update                 | Update repository of openSUSE Backports                              | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/backports/                             |
14 | repo-debug                            | Debug Repository                                                     | Non    | ----             | ----       |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.3/repo/oss/                  |
15 | repo-debug-non-oss                    | Debug Repository (Non-OSS)                                           | Non    | ----             | ----       |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.3/repo/non-oss/              |
16 | repo-debug-update                     | Update Repository (Debug)                                            | Non    | ----             | ----       |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.3/oss/                             |
17 | repo-debug-update-non-oss             | Update Repository (Debug, Non-OSS)                                   | Non    | ----             | ----       |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.3/non-oss/                         |
18 | repo-non-oss                          | Non-OSS Repository                                                   | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.3/repo/non-oss/                    |
19 | repo-oss                              | Main Repository                                                      | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.3/repo/oss/                        |
20 | repo-sle-debug-update                 | Update repository with updates from SUSE Linux Enterprise 15 (Debug) | Non    | ----             | ----       |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.3/sle/                             |
21 | repo-sle-update                       | Update repository with updates from SUSE Linux Enterprise 15         | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/sle/                                   |
22 | repo-source                           | Source Repository                                                    | Non    | ----             | ----       |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.3/repo/oss/                 |
23 | repo-update                           | Main Update Repository                                               | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/oss/                                   |
24 | repo-update-non-oss                   | Update Repository (Non-Oss)                                          | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/non-oss/                               |
25 | skype-stable                          | Skypeforlinux - stable                                               | Oui    | (r ) Oui         | Non        |   99     | rpm-md | https://repo.skype.com/rpm/stable/                                                   |

Bref, je suppose que j'ai dû installer qqch qui a nécessité des dépendances venues d'un autre dépôt. Ou je sais pas.

Mise à part le fait que j'ai ce message d'erreur à chaque fois que j'exécute le gestionnaire de logiciels de Yast, j'ai un autre souci.

Le plus simple c'est que je vous montre avec un exemple.
Je cherche les infos sur le paquet Falkon. Je tape donc
zypper info falkon
Résultat :
Le dépôt 'SUSE:SLE-15-SP2:Update' n'est pas à jour. Vous pouvez lancer 'zypper refresh' en tant que root pour le mettre à jour.
Le dépôt 'SUSE:SLE-15-SP1:GA' n'est pas à jour. Vous pouvez lancer 'zypper refresh' en tant que root pour le mettre à jour.
Le dépôt 'SUSE:SLE-15-SP3:GA' n'est pas à jour. Vous pouvez lancer 'zypper refresh' en tant que root pour le mettre à jour.
Le dépôt 'SUSE:SLE-15:Update' n'est pas à jour. Vous pouvez lancer 'zypper refresh' en tant que root pour le mettre à jour.
Le dépôt 'SUSE:SLE-15-SP2:GA' n'est pas à jour. Vous pouvez lancer 'zypper refresh' en tant que root pour le mettre à jour.
Le dépôt 'SUSE:SLE-15-SP1:Update' n'est pas à jour. Vous pouvez lancer 'zypper refresh' en tant que root pour le mettre à jour.
Chargement des données du dépôt...
Récupération de données du dépôt 'SUSE:SLE-15-SP2:Update'...
Récupération des métadonnées du dépôt 'SUSE:SLE-15-SP2:Update' ...[erreur]
Le dépôt 'SUSE:SLE-15-SP2:Update' est invalide.
[https-download.opensuse.org-214f5584|https://download.opensuse.org/repositories/SUSE:/SLE-15-SP2:/Update/pool-leap-15.3/] Aucune métadonnée valide trouvée à l'URL spécifiée                 
Historique :                                                                                                                                                                                  
 - [https-download.opensuse.org-214f5584|https://download.opensuse.org/repositories/SUSE:/SLE-15-SP2:/Update/pool-leap-15.3/] Repository type can't be determined.                            

Veuillez vérifier que l'URI définie pour ce dépôt pointe bien sur un dépôt valide.
Problème lors du chargement des données depuis 'SUSE:SLE-15-SP2:Update'
Les éléments de 'SUSE:SLE-15-SP2:Update' n'ont pas pu être chargés en raison d'une erreur.
Avertissement : Le dépôt 'openSUSE:Backports:SLE-15-SP3' semble être obsolète. Envisagez d'utiliser un autre miroir ou un autre serveur.
Récupération de données du dépôt 'SUSE:SLE-15-SP1:GA'...
Récupération des métadonnées du dépôt 'SUSE:SLE-15-SP1:GA' ...[erreur]
Le dépôt 'SUSE:SLE-15-SP1:GA' est invalide.
[https-download.opensuse.org-29d2047a|https://download.opensuse.org/repositories/SUSE:/SLE-15-SP1:/GA/pool/] Aucune métadonnée valide trouvée à l'URL spécifiée                               
Historique :                                                                                                                                                                                  
 - [https-download.opensuse.org-29d2047a|https://download.opensuse.org/repositories/SUSE:/SLE-15-SP1:/GA/pool/] Repository type can't be determined.                                          

Veuillez vérifier que l'URI définie pour ce dépôt pointe bien sur un dépôt valide.
Problème lors du chargement des données depuis 'SUSE:SLE-15-SP1:GA'
Les éléments de 'SUSE:SLE-15-SP1:GA' n'ont pas pu être chargés en raison d'une erreur.
Récupération de données du dépôt 'SUSE:SLE-15-SP3:GA'...
Récupération des métadonnées du dépôt 'SUSE:SLE-15-SP3:GA' ...[erreur]
Le dépôt 'SUSE:SLE-15-SP3:GA' est invalide.
[https-download.opensuse.org-30442878|https://download.opensuse.org/repositories/SUSE:/SLE-15-SP3:/GA/pool/] Aucune métadonnée valide trouvée à l'URL spécifiée                               
Historique :                                                                                                                                                                                  
 - [https-download.opensuse.org-30442878|https://download.opensuse.org/repositories/SUSE:/SLE-15-SP3:/GA/pool/] Repository type can't be determined.                                          

Veuillez vérifier que l'URI définie pour ce dépôt pointe bien sur un dépôt valide.
Problème lors du chargement des données depuis 'SUSE:SLE-15-SP3:GA'
Les éléments de 'SUSE:SLE-15-SP3:GA' n'ont pas pu être chargés en raison d'une erreur.
Récupération de données du dépôt 'SUSE:SLE-15:Update'...
Récupération des métadonnées du dépôt 'SUSE:SLE-15:Update' ...[erreur]
Le dépôt 'SUSE:SLE-15:Update' est invalide.
[https-download.opensuse.org-88e90e2a|https://download.opensuse.org/repositories/SUSE:/SLE-15:/Update/pool-leap-15.3/] Aucune métadonnée valide trouvée à l'URL spécifiée                     
Historique :                                                                                                                                                                                  
 - [https-download.opensuse.org-88e90e2a|https://download.opensuse.org/repositories/SUSE:/SLE-15:/Update/pool-leap-15.3/] Repository type can't be determined.                                

Veuillez vérifier que l'URI définie pour ce dépôt pointe bien sur un dépôt valide.
Problème lors du chargement des données depuis 'SUSE:SLE-15:Update'
Les éléments de 'SUSE:SLE-15:Update' n'ont pas pu être chargés en raison d'une erreur.
Récupération de données du dépôt 'SUSE:SLE-15-SP2:GA'...
Récupération des métadonnées du dépôt 'SUSE:SLE-15-SP2:GA' ...[erreur]
Le dépôt 'SUSE:SLE-15-SP2:GA' est invalide.
[https-download.opensuse.org-a805c074|https://download.opensuse.org/repositories/SUSE:/SLE-15-SP2:/GA/pool/] Aucune métadonnée valide trouvée à l'URL spécifiée
Historique :
 - [https-download.opensuse.org-a805c074|https://download.opensuse.org/repositories/SUSE:/SLE-15-SP2:/GA/pool/] Repository type can't be determined.

Veuillez vérifier que l'URI définie pour ce dépôt pointe bien sur un dépôt valide.
Problème lors du chargement des données depuis 'SUSE:SLE-15-SP2:GA'
Les éléments de 'SUSE:SLE-15-SP2:GA' n'ont pas pu être chargés en raison d'une erreur.
Récupération de données du dépôt 'SUSE:SLE-15-SP1:Update'...
Récupération des métadonnées du dépôt 'SUSE:SLE-15-SP1:Update' ...[erreur]
Le dépôt 'SUSE:SLE-15-SP1:Update' est invalide.
[https-download.opensuse.org-aa43ee68|https://download.opensuse.org/repositories/SUSE:/SLE-15-SP1:/Update/pool-leap-15.3/] Aucune métadonnée valide trouvée à l'URL spécifiée
Historique :
 - [https-download.opensuse.org-aa43ee68|https://download.opensuse.org/repositories/SUSE:/SLE-15-SP1:/Update/pool-leap-15.3/] Repository type can't be determined.

Veuillez vérifier que l'URI définie pour ce dépôt pointe bien sur un dépôt valide.
Problème lors du chargement des données depuis 'SUSE:SLE-15-SP1:Update'
Les éléments de 'SUSE:SLE-15-SP1:Update' n'ont pas pu être chargés en raison d'une erreur.
Lecture des paquets installés...


Informations sur paquet falkon :
--------------------------------
Dépôt                     : openSUSE:Backports:SLE-15-SP3
Nom                       : falkon
Version                   : 3.1.0-bp153.1.13
Architecture              : x86_64
Fabricant                 : openSUSE
Taille une fois installé  : 7,0 MiB
Installé                  : Oui
État                      : à jour
Paquet source             : falkon-3.1.0-bp153.1.13.src
Résumé                    : Modern web browser
Description               :
    Falkon is a web browser designed to well integrate with all
    common Linux desktops like GNOME and KDE Plasma.
    It supports current web standards and comes with many features,
    such as an integrated ad blocker.

    It was previously known as QupZilla.

Bon, là, moi je désactive tous les dépôts concernés pour voir ce qu'ils passe. Puis je supprime carrément les dépôts, avec Yast.


Mon hypothèse c'est que j'ai peut-être f... le b... en ajoutant des paquets sans savoir ce que je faisais précisément.

Là, je fais des mises à jour, et tout semble fonctionner normalement.

Qqn a un commentaire ou une suggestion ?




Re : Les dépôts Leap : j'ai peut-être f... le b...

Répondre #1
Mon hypothèse c'est que j'ai peut-être f... le b... en ajoutant des paquets sans savoir ce que je faisais précisément.

Là, je fais des mises à jour, et tout semble fonctionner normalement.

Qqn a un commentaire ou une suggestion ?

Tu as bien fait de virer les dépôts invalides. À priori ce sont les dépôts des lignes 3-4-5-6-7-9-10 dans le retour de la commande

zypper repos

La présence de ces dépôts est une anomalie dont tu n'es pas du tout responsable.

Voir cette discussion : https://www.alionet.org/index.php?topic=1220.0

Re : Les dépôts Leap : j'ai peut-être f... le b...

Répondre #2
Bonjour 👋 
Est-ce que ton problème peut provenir de l’installation de paquets à partir du site https://software.opensuse.org
il y a beaucoup de soucis avec, des dépôts ajoutés qui font passer Leap sur TW, des dépôts invalides...
il y a un problème de maintenance avec la structure actuelle basée sur Ruby. Il est prévu de continuer ce service mais il y a un manque de devs sur ce projet pour l’instant si j’ai bien compris, ce qui est fait que ça n’a pas beaucoup avancé 
source : https://lists.opensuse.org/archives/list/factory@lists.opensuse.org/thread/F6SU2X2XFWX4OGEWLP4WO3JBKVHIFC6X/

 

Re : Les dépôts Leap : j'ai peut-être f... le b...

Répondre #3
Merci pour vos réponses.

J'ai une idée du coupable. J'ai voulu retrouver le vieux fond d'écran Open Suse, le noir avec l'ampoule. Et je ne trouvais pas. Et je tombe sur un forum qui indique comment installer une série d'anciens fonds d'écran. Je me demande si le b... n'est pas venu de là.

Bon, là j'ai tout viré et ça joue.

Juste une question : Y'a-t-il une commande me permettant de vérifier s'il y a des paquets qui ne sont plus rattachés à aucun dépôt ? C'est juste pour être sûr que je ne me retrouve pas avec des paquets qui traînent et ne soient plus mis à jour après que j'ai viré les dépôts mentionnés plus haut.

Re : Les dépôts Leap : j'ai peut-être f... le b...

Répondre #4
Dans YaST > Installer et supprimer des logiciels
Dans l'onglet Vue en haut à gauche, tu choisies "catégories de paquets"
puis dans la liste qui s'affiche "paquets orphelins"
normalement ça te donne la liste des paquets installés sur le système et qui ne sont plus dans les dépôts activés dans ton sources.list

Et pour la commande, en utilisateur :
zypper packages --orphaned

Re : Les dépôts Leap : j'ai peut-être f... le b...

Répondre #5
Dans YaST > Installer et supprimer des logiciels
Dans l'onglet Vue en haut à gauche, tu choisies "catégories de paquets"
puis dans la liste qui s'affiche "paquets orphelins"
normalement ça te donne la liste des paquets installés sur le système et qui ne sont plus dans les dépôts activés dans ton sources.list

Et pour la commande, en utilisateur :
zypper packages --orphaned
Merci !
Mais en fait entre-temps d'autres soucis avec les dépôts (je viens de lancer une discussion).
J'essaie d'éviter de rajouter des dépôts. Mais je voudrais aussi éviter de trop recourrir aux flatpak et autres (pas toujours pratique). Et résultat, je me retrouve avec divers dépôts... Et ce type de problèmes.

Re : Les dépôts Leap : j'ai peut-être f... le b...

Répondre #6
@Grompf‍ je n’ai pas trouvé ta nouvelle discussion ?


Re : Les dépôts Leap : j'ai peut-être f... le b...

Répondre #8
@jtro merci !