Aller au contenu principal
Sujet: Problème de wifi sur Asus M415D (Lu 188 fois) sujet précédent - sujet suivant

Problème de wifi sur Asus M415D


  Bonjour,

Je n'arrive pas à me connecter sur le wifi depuis que j'ai installé opensuse 15.4, il n'y a pas de ssid dans la boîte en bas à droite. J'essaie de télécharger un driver rtl8821ce sur le site de opensuse, mais ça ne fonctionne pas, ce sont des données qui apparaissent plutôt qu'un fichier à télécharger. Quelqu'un saurait-il comment je peux faire autrement? Merci déjà pour votre aide.
Quelques renseignements pour le moment:

sudo lspci -nnkd ::280
01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter [10ec:c821]
        Subsystem: AzureWave Device [1a3b:3040]
        Kernel modules: rtw88_8821ce


zypper lr -U
Les priorités des dépôts sont sans effet. Tous les dépôts activés partagent la même priorité.

#  | Alias                                        | Name                                                                                        | Enab-> | GPG Check        | Refresh    | URI
---+----------------------------------------------+---------------------------------------------------------------------------------------------+--------+------------------+------------+---------------------------------------------------------------------------------
 2 | openSUSE-Leap-15.4-1                         | openSUSE-Leap-15.4-1                                                                        | Non    | ----             | ----       | hd:/?device=/dev/disk/by-id/usb-Kingston_DataTraveler_2.0_5B870F000110-0:0-part2
 7 | repo-debug-non-oss                           | Debug Repository (Non-OSS)                                                                  | Non    | ----             | ----       | http://download.opensuse.org/debug/distribution/leap/15.4/repo/non-oss/
 6 | repo-debug                                   | Debug Repository                                                                            | Non    | ----             | ----       | http://download.opensuse.org/debug/distribution/leap/15.4/repo/oss/
 9 | repo-debug-update-non-oss                    | Update Repository (Debug, Non-OSS)                                                          | Non    | ----             | ----       | http://download.opensuse.org/debug/update/leap/15.4/non-oss/
 8 | repo-debug-update                            | Update Repository (Debug)                                                                   | Non    | ----             | ----       | http://download.opensuse.org/debug/update/leap/15.4/oss/
12 | repo-sle-debug-update                        | Update repository with debuginfo for updates from SUSE Linux Enterprise 15                  | Non    | ----             | ----       | http://download.opensuse.org/debug/update/leap/15.4/sle/
10 | repo-non-oss                                 | Non-OSS Repository                                                                          | Oui    | (r ) Oui         | Oui        | http://download.opensuse.org/distribution/leap/15.4/repo/non-oss/
11 | repo-oss                                     | Main Repository                                                                             | Oui    | (r ) Oui         | Oui        | http://download.opensuse.org/distribution/leap/15.4/repo/oss/
14 | repo-source                                  | Source Repository                                                                           | Non    | ----             | ----       | http://download.opensuse.org/source/distribution/leap/15.4/repo/oss/
 5 | repo-backports-update                        | Update repository of openSUSE Backports                                                     | Oui    | (r ) Oui         | Oui        | http://download.opensuse.org/update/leap/15.4/backports/
 4 | repo-backports-debug-update                  | Update repository with updates for openSUSE Leap debuginfo packages from openSUSE Backports | Non    | ----             | ----       | http://download.opensuse.org/update/leap/15.4/backports_debug/
16 | repo-update-non-oss                          | Update Repository (Non-Oss)                                                                 | Oui    | (r ) Oui         | Oui        | http://download.opensuse.org/update/leap/15.4/non-oss/
15 | repo-update                                  | Main Update Repository                                                                      | Oui    | (r ) Oui         | Oui        | http://download.opensuse.org/update/leap/15.4/oss/
13 | repo-sle-update                              | Update repository with updates from SUSE Linux Enterprise 15                                | Oui    | (r ) Oui         | Oui        | http://download.opensuse.org/update/leap/15.4/sle/
 1 | ftp.gwdg.de-openSUSE_Leap_$releasever        | Packman Repository                                                                          | Oui    | (r ) Oui         | Oui        | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.4/
 3 | opensuse-guide.org-openSUSE_Leap_$releasever | Libdvdcss Repository                                                                        | Oui    | (r ) Oui         | Oui        | http://opensuse-guide.org/repo/openSUSE_Leap_15.4/


zypper search -s rtl8821 rtw88
Chargement des données du dépôt...
Lecture des paquets installés...
Aucun élément correspondant n'a été trouvé.

Re : Problème de wifi sur Asus M415D

Répondre #1
J'ajouterais cette information-ci:

nmcli device
DEVICE  TYPE      STATE     CONNECTION
lo      loopback  non-géré  --     



Re : Problème de wifi sur Asus M415D

Répondre #4
Bonjour,
D’après ce fil https://forums.opensuse.org/showthread.php/555054-rtl8821ce-wireless
ça devrait fonctionner sur TW.
Il y avait besoin d’un driver pour Leap 15.3 mais Sauerland a désactivé la construction du paquet pour Leap 15.4 ce qui semblerait indiquer que ça doit fonctionner tout seul 🤔 ou alors il s’est trompé pour Leap 15.4
A ta place je le contacterais directement ou je ferais un fil sur le forum anglais.
Sauf si ce n’est pas une installation neuve mais une mise à jour depuis Leap 15.3 ou alors tu as ajouté des dépôts , essayé d’installer un driver ?
A la lecture du fil, j’ai l’impression que cette carte à un souci avec certaines versions du noyau.
Que donne cette commande chez toi
sudo journalctl -b | grep -i rtw 

Édit : j’ai été trop lente pour faire mon message. Par contre le numéro est RTL8821CE, ce n’est pas la même chose que ce dont parle @sobkowiak  et @jtro

Re : Problème de wifi sur Asus M415D

Répondre #5
@ chalu,ok,j'avais pas les yeux en face des trous.
@AlioI : ne tiens pas compte de mon message. Bonne nuit et à demain
Édit: apparemment le driver pour rtl8821ce n'est pas dispo pour la 15.4. sauerland s'arrête à la 15.3. idem sur software opensuse.org.

Re : Problème de wifi sur Asus M415D

Répondre #6
  Merci à tous pour vos réponses appréciées.
  Voici ce que donne la commande requise par Chalu:

sudo journalctl -b | grep -i rtw 
[sudo] Mot de passe de root :
juin 17 13:43:13 localhost kernel: rtw_8821ce 0000:01:00.0: enabling device (0000 -> 0003)
juin 17 13:43:13 localhost kernel: rtw_8821ce 0000:01:00.0: Firmware version 24.8.0, H2C version 12
juin 17 13:43:13 localhost kernel: rtw_8821ce 0000:01:00.0: rfe 4 isn't supported
juin 17 13:43:13 localhost kernel: rtw_8821ce 0000:01:00.0: failed to setup chip efuse info
juin 17 13:43:13 localhost kernel: rtw_8821ce 0000:01:00.0: failed to setup chip information

Re : Problème de wifi sur Asus M415D

Répondre #7
@ Chalu: En effet c'est une mise à jour depuis Leap 15.3, mais je n'ai rien installé depuis (quoique peut-être des dépôts mais pas pour rtl8821).

Re : Problème de wifi sur Asus M415D

Répondre #8
Oui mais tu l’avais peut-être fait sur Leap 15.3
Tu donneras le retour de
zypper se -si rtw rtl8821
Ça permettra peut-être de voir si tu as des paquets qui traînent
Par contre je ne regarderai ça que demain, je vais dormir la fraîcheur arrive ;)

Re : Problème de wifi sur Asus M415D

Répondre #9
En effet.
Voici ce que donne la commande suivante:
zypper se -si rtw rtl8821
Chargement des données du dépôt...
Lecture des paquets installés...

S | Name                 | Type   | Version            | Arch         | Repository
--+----------------------+--------+--------------------+--------------+----------------
i | libKPimImportWizard5 | paquet | 21.12.3-bp154.1.19 | x86_64       | Main Repository

Re : Problème de wifi sur Asus M415D

Répondre #10
Bonjour encore,

A ce que je vois Sauerland s'occupe déjà du problème que j'ai. J'ai trouvé cette page d'il y a une semaine, toujours ouverte, où quelqu'un a un problème similaire au mien: https://forums.opensuse.org/showthread.php/570983-After-upgrade-problem-with-wifi-hotspot-in-my-laptop
Et sur cette page-ci il est maintenant possible de télécharger un driver pour 15.4, même si ça ne marche malheureusement pas pour le moment. Mais cette page ne permettait pas de faire l'installation en un clic par yast hier alors que cette démarche peut être amorcée aujourd'hui (mais elle bloque): https://software.opensuse.org/package/rtl8821ce-kmp-default

Re : Problème de wifi sur Asus M415D

Répondre #11
Tu peux retourner le résultat de 
uname -a
Le chips de ta carte pose problème effectivement, on trouve plusieurs fils.
Suis ce que Sauerland va faire, pour l’instant la construction du paquet firmware  pour Leap 15.4 est toujours désactivé.

Re : Problème de wifi sur Asus M415D

Répondre #12
Désolée pour le temps de réponse, je n'avais pas accès à cet ordinateur cette fin de semaine.
Voici ce que donne la commande suivante:
uname -a
Linux localhost.localdomain 5.14.21-150400.22-default #1 SMP PREEMPT_DYNAMIC Wed May 11 06:57:18 UTC 2022 (49db222) x86_64 x86_64 x86_64 GNU/Linux

Je suis allée sur le forum anglais, où Sauerland me donne une série de choses à faire, que je ne comprends pas pour le moment, mais un ami m'aidera. Voici la page:
https://forums.opensuse.org/showthread.php/571403-RTL8821CE-on-Leap-15-4

Re : Problème de wifi sur Asus M415D

Répondre #13
Bonjour, en attendant donne le résultat de
/sbin/lspci -nnk | grep -iA3 net

Re : Problème de wifi sur Asus M415D

Répondre #14
@AlioI‍ : Sauerland te donne les lignes de dépôts que tu dois supprimer. Ils sont certainement apparus lorsque tu as utilisé le one-click install sur le site des logiciels openSUSE.
Pour les supprimer tu peux le faire en graphique avec YaST > dépôts
tu sélectionnes la ligne et tu supprimes, attention de ne pas te tromper de ligne 😉
Ensuite Sauerland te dit que ta carte devrait marcher sans rien installer de plus.
Il te dit qu’il faudrait désinstaller les vieux paquets
rtl8821ce-kmps 
et
rtw88-kmps 
si ils sont installés.
Tu fais la commande
 zypper se -si rtl8821ce 
si elle ne renvoie pas de paquets comme lui c’est bon. Je t’avais fait faire cette vérification plus haut et il n’y avait pas ces paquets, mais tu en as peut-être maintenant si tu as fait des essais depuis.
Tu lui donnes le retour de cette commande et aussi celle indiquée par @jtro
Tu peux aussi lui donner la commande que l’on a fait plus haut avec journalctl
Je pense que tu as une version qui n’est pas prise en charge par ton noyau.
Vérifie aussi les mises à jour du système, le problème pourrait être résolu s’il a été rapporté.