Aller au contenu principal
Sujet: freecad 0.19 et tumbleweed (Lu 230 fois) sujet précédent - sujet suivant

freecad 0.19 et tumbleweed

Depuis la dernière mise à jour de FreeCAD (0.19.1-1.1) celui-ci s'avère assez instable, et me renvoie à la pelle des erreurs "call stack is not deep enough"  :(
Un exemple assez trivial (parmi beaucoup d'autres) : depuis FreeCAD, ouvrir un fichier fonctionne sans problème. Mais en cliquant directement sur le même fichier depuis Dolphin, FreeCAD s'ouvre, me renvoie une palanquée erreurs "call stack is not deep enough", et ne m'affiche rien de rien (re- :( )
2 petites questions :
- je suis le seul dans ce-cas là ?
- quelqu'un saurait me dire comment faire un downgrade du package ? Sous Leap je saurais faire sans problème, mais sous Tumbleweed je n'ai jamais fait. Dans le software management de Yast, seule la dernière version du package apparaît (ce qui paraît logique dans une rolling release...)

Re : freecad 0.19 et tumbleweed

Répondre #1
bonsoir,as tu été voir sur software opensuse?

Re : freecad 0.19 et tumbleweed

Répondre #2
Salut,
Tu devrais plutôt faire une déclaration de bug.
Le logiciel est fonctionnel si tu lances puis ouvres un fichier mais par contre l’ouverture directement dans dolphin pose problème d’après ton message.
Essaie d’obtenir un message précis à fournir pour le forum et la déclaration de bug.
Essaie de lancer dolphin depuis un terminal en tapant en utilisateur normal 
dolphin
Ensuite tu navigues dans un répertoire avec un fichier pour freecad, tu cliques pour l’ouvrir et tu regardes les messages du terminal que tu copies colles dans ton rapport de bug et ici

Re : freecad 0.19 et tumbleweed

Répondre #3
Merci pour vos réponses.

Concernant l'ouverture depuis dolphin : le problème est a priori purement interne à FreeCAD. Ca n'est qu'un exemple des très nombreux cas d'erreur. Indépendamment de ça, j'ai droit à des erreurs très souvent, dès que je manipule un peu des objets dans FreeCAD. Le simple fait de déplacer une pièce dans la vue 3D amène parfois ce type d'erreur, également lorsque je dessine des nouveaux éléments avec le sketcher. Mais de manière assez aléatoire. J'ai cité le problème d'ouverture de fichier dans mon post précédent, car au moins il est systématique, et donc trivial à reproduire.

Effectivement sur software opensuse il y a dans les paquets communautaires une version 0.18, je vais tester ça.


 

Re : freecad 0.19 et tumbleweed

Répondre #5
Il y a un thread en anglais sur le forum freecad (thread non résolu mais peut-être explicatif ?) :
https://forum.freecadweb.org/viewtopic.php?t=56148
Merci pour l'info, la description du problème a l'air très cohérente avec ce que je vois chez moi.
Pas réussi à faire un downgrade (revenir en 0.18.x) depuis opensuse software, conflit de dépendances non résolu.
Bon, je sens que je vais être obligé d'attendre un peu une prochaine mise à jour... Les aléas de la rolling release !


Re : freecad 0.19 et tumbleweed

Répondre #7
Petite mise à jour : j'ai posté sur le forum de FreeCAD (ici)
La solution que l'on m'a proposée = passer sur la dernière version, depuis Github
Ca fonctionne effectivement, avec cette version le problème est résolu (voir le lien ci-dessus). Mais du coup il faut utiliser la version de FreeCAD au format AppImage...

En pratique ça ressemble à un problème d'intégration avec Qt
La dernière version AppImage intègre un FreeCAD plus récent que la version actuellement disponible dans Tumbleweed... mais avec un Qt plus ancien.
A voir comment ça va évoluer !

Re : freecad 0.19 et tumbleweed

Répondre #8
D'autres ont manifestement eu le même problème. On me demande sur le forum FreeCAD quel est le moyen de remonter le problème côté OpenSUSE...
De fait, mieux vaudrait ne pas laisser cette version dans les dépôts, si elle s'avère instable dans l'environnement Tumbleweed.
Sauriez-vous comment faire ?