Aller au contenu principal
Sujet: Dual-boot mageia Leap 15.3 impossible problème EFI (Lu 517 fois) sujet précédent - sujet suivant - Sujet provenant de Leap 15.3 Beta : Impo...

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #15
Hello,

J'ai 2 ssd et je suis en efi.
Windows 10 sur un ssd, Mageia sur l'autre.
Pour opensuse Leap ou Tumbleweed j'ai sélectionné le ssd de mageia, puis ext4, j'ai décoché pour la partition swap et j'ai laissé sur "supprimer si nécessaire" pour les partitions existantes. Et au démarrage J'avais Opense, Mageia et Windows.

Bizarre ton problème

Pour le moment je n'ai plus Mageia.

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #16
 :-[
Bonjour à tous,

Depuis 2heure du mat je suis dessus! Mais rien à faire Suse et MGA ne sont pas compatibles sur ma machine  :D  : pourquoi ça ? j'en sais rien !
Si j'installe Suse (qui me propose le choix) je démarre Suse sans problème -voir photo- mais pas Mageia.

ICI le Grub d'OpenSuse

➤ Je réinstalle MGA et c'est exactement l'inverse qui se produit.
Dans les deux cas : Écran noir avec le Logo "MAG" de MSI et une flèche qui tourne ... qui  tourne ... sans résultat.

L'image est mauvaise mais on voit bien le LEAP en bas avec sa fléche au dessus et le logo en brillance de MAG le bios.

Donc, je suis à nouveau avec MGA et évidement Suse est inaccessible. Enfin si !!  Je peux accéder à ses dossiers et fichiers, sorti de là rien d'autre à faire. Je suis sur Mageia par commodité (nous sommes plusieurs) Et Suse étant en beta il ne serait pas prudent de travailler dessus.

J’ai regardé dans le bios et c'est là que ça se complique : Une seule distribution est présente;  quand j'avais le choix entre OMA et MGA voir mon post avec image N°1 .
Mais MGA ou OpenSuse ?? Pas possible c'est ou l'un ou l'autre.


Je suis en train de bouffer mon chapeau !
Donc il serait possible qu'un paramètre dans le bios ne serait pas activé ou mal configuré, j'ai parcouru le manuel mais je n'ai rien vu.
Quelque chose m'échappe surement, mais pendant l'installation j'ai pris mon temps, bien réfléchit avant de valider: résultat NADA !

  Si vous avez une suggestion je suis preneur !

En me relisant j'ai pensé  (si c'est possible! !!) peut-on modifier les images dans le dossier /boot/EFI ?
Je m'explique je modifie le boot mga en y ajoutant le boot de Suse ou un truc dans ce genre là ?

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #17
Cé ayéééez !!

J'y suis enfin arrivé, ce n'est pas tout parfait et lisse mais çà fonctionne : J'ai enfin un double ammorçage OpenSuse <> Mageia.
Je vais boire l'apéro, et, cet aprés midi je vous fait un petit aperçu des la manip à faire .
C'est plus que tortueux et j'espère que çà tiendra : je vais faire des sauvegardes.

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #18
Bonjour à tous!
Avant toutes choses, je doute que cette installation soit perenne.
Je tiens à préciser que ma carte-mére est une B550-MSI sortie en ±Juin 2020 et, qui demande des drivers spécifique pour W10.
Évidement rien de tout ça pour quel que Linux ce soit, donc à mon avis c'est du bidouillage en vue.
 Je ne suis pas un pro de grub et encore moins de UEFI alors je fais comme je peux.

Mageia et Open Mandriva sont installés (correctement en dual-boot EFI) sans problème d'aucune sorte, une installation que je qualifierais de "classique" .
- J'ai donc décidé de tenter Open suse Leap 15.3 beta, Leap 15.2 ne reconnaissant pas le matériel.

Je vais installer Suse à la place de OMA ceci afin de conserver Mageia qui contient les applis et tous ce que j'utilise.
➤ Afin de partir sur du moins compliqué je demande à Suse de formater le /boot/efi (pour éviter les embrouilles et mélanges) l'installation se passe correctement : juste penser à désactiver le secure boot de Suse.
- Évidement ; au démarrage, Suse propose Mageia 8 qui ne se lance pas.
Je réinstalle le bootloader  de MGA via l'USB et résultat :
Au démarrage MGA propose Open Suse leap 15.3 ... qui ne se lance pas.
 :D
Dans Mageia je vais dans le CCM (± Yast) Démarrage/Configurer le démarrage du systeme.
 
Détecter les autres OS et placer dans /EFI.
Redémarrage ... Mageia boot mais pas Suse.
Pourtant elle est "vue" dans le bios :
Grand moment de solitude !
🏴 Je réinstalle Suse 15.3 en lui demandant cette fois de ne pas formater boot/efi.
Et au redémarrage enfin Leap15.3 est accessible mais pas de façon attendue.
Je n'ai pas le chargeur Suse vous savez la bande verte qui défile en bas de l'écran, non j'ai le logo de : «MAG bios MSI» sur fond noir avec une flèche qui tourne et LEAP écrit en blanc.
Cela reste un mystère.
J'ai; au démarrage, le grub de MGA qui propose Leap 15.3, + MGA qui se lance normalement (avec son chargeur bleu) mais si je demande Suse j'obtiens ceci :

montage pour visuel

Donc ?? Mon avis il y a un souci avec Suse, quelque chose qui n'est pas ou mal reconnu avec le matériel.
Ce qui est étonnant c'est que je n'ai aucun souci avec d'autres distributions pour peu, qu’elles soient  récentes.
Je ne les ai pas toutes essayées non plus faut pas délirer, et certaines ne me conviennent pas tout simplement.
Montage non perenne car à mon avis au moindre changement de kernel quelque chose se passera mal.

✘ Comme je l'ai dit je ne suis pas un "kador" du boot comme du EFI et je suis ouvert à toutes les propositions.
Ou, si des personnes ont le même souci avec ce matériel ce serait sympa de le signaler.

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #19
Merci pour ton retour :)
J’ai essayé de faire une machine virtualbox en UEFI pour tester le dual-boot mais l’installation de mageia ou openSUSE n’a jamais voulu commencer , écran noir et bien sûr en décochant la case UEFI aucun souci pour lancer l’installation mais ce n’est plus pertinent pour ton problème.
Dans le wiki Ubuntu on lit qu’il ne faut pas installer Grub2 mais faire un update grub depuis le premier système linux installé pour qu’il reconnaisse le second.
https://doc.ubuntu-fr.org/tutoriel/multiboot_avance#si_vous_avez_deja_au_moins_un_linux_eventuellement_un_windows_et_que_vous_installez_un_deuxieme_linux
Ne pas formater la partition EFI est la bonne démarche, il me semble l’avoir lu, il faudra que je recherche.

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #20
Salut

J'ai installe hier soir Mageia 8 en triple boot openSUSE, Windows. Ca se fait tout seul !!

Il ne faut effectivement jamais formater la partition EFI.

Pour info la séquence de boot EFI de VirtualBox est bugge. Du coup pour Mageia, tu arrives sur la console EFI, mais en tapant les bonnes commandes ca fonctionne.

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #21
Je suis actuellement sur Leap 15.3, la mise à jour de 1049 paquet est en cours j'ai vu passer un:
---- - - paquet perl-Bootloader-0.933-1.2.x86_64 
?? qui sait.

Oui c'est vrai il ne faut pas formater EFI lors de l'installation du deuxième OS, c'est presque une évidence.
Je l'ai fait en premier lieu pour ne pas avoir OMA dans les pattes et du fait compliquer le pourquoi du comment.

J'ai installe hier soir Mageia 8 en triple boot openSUSE, Windows. Ca se fait tout seul !!
Oui, mais avec quel matériel une B550 ?
Si oui, c'est que tout simplement il y a Windows au milieu, perso je n'ai pas W10 juste 2 Linux. Elle est peut-être là la différence.
Sur de nombreux PC W10 étant en général pré-installé alors ; oui!! Ne pas formater EFI reste le plus sage.
Le web est plein de tuto sur çà ou bien souvent il est dit :
<<Ce tuto est prévu pour un pc avec Windows 10.
Windows 10 doit toujours être installé en mode EFI
>>

Seconde Édition:
Mise à jour faites, reboot ...mais toujours le Logo "MAG de MSI" bon le principal étant de pouvoir passer sur Leap 15.3 et de "voir" ce que çà donne.
Je suis en root mode graphique; pas d'user pour le moment.
J'ai lu le lien donné par Chalu oui ... c'est pour le MBR pour le EFI : Cet ici mais c'est avec l’installateur Calamares qui à mon avis n'est pas très top.
Et quoi qu'il en soit toujours avec Windows au milieu.

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #22
Merci pour ton retour :)
J’ai essayé de faire une machine virtualbox en UEFI pour tester le dual-boot mais l’installation de mageia ou openSUSE n’a jamais voulu commencer , écran noir et bien sûr en décochant la case UEFI aucun souci pour lancer l’installation mais ce n’est plus pertinent pour ton problème.
Dans le wiki Ubuntu on lit qu’il ne faut pas installer Grub2 mais faire un update grub depuis le premier système linux installé pour qu’il reconnaisse le second.
https://doc.ubuntu-fr.org/tutoriel/multiboot_avance#si_vous_avez_deja_au_moins_un_linux_eventuellement_un_windows_et_que_vous_installez_un_deuxieme_linux
Ne pas formater la partition EFI est la bonne démarche, il me semble l’avoir lu, il faudra que je recherche.

Pour démarrer Mageia 8 sur VirtualBox en EFI quand tu arrives sur le shell EFI.

FS1:
cd EFI
cd BOOT
bootx64.efi

Re : Dual-boot mageia Leap 15.3 impossible problème EFI

Répondre #23
Le truc , c’est que je n’ai pas l’impression d’arriver à un shell juste écran noir et rien, pour mageia et Leap 15.3
Je ferai un fil quand j’aurai plus de temps à consacrer à virtualbox et ne pas polluer ce fil.
Là ma priorité va être une installation d’anaconda pour une formation python  ;)