Aller au contenu principal
Sujet: webcam intégrée non reconnu (Lu 838 fois) sujet précédent - sujet suivant

webcam intégrée non reconnu

Bonjour,
Etant donné nouveau sur ce site, excusez-moi si je fait des impairs !
Cela fait quelques temps que je suis à la recherche d'un système d'exploitation autre que Windows, car eu la mauvaise surprise d'apprendre que les vieilles clés de XP jusque certains win 7 avaient été bloquées ou suspendue, après avoir téléphoné à Microsoft.
Et étant donné que c'est un PC que je dois donner à un ami égyptien, et pas envie de mettre encore la main à la poche et que notre ami n'a jamais eu de PC, donc cela sera plus facile pour lui.
J'ai déjà essayé plusieurs systèmes alternatifs, tous avaient le même problème ( en plus d'autres), impossible d'activer la webcam intégrée, j'ai essayé toutes les combinaisons possibles, évidement aussi Fn+F7, mais rien n'y fait, donc je suppose qu'elle n'est pas reconnue, bon avant avec Windows on allait dans le gestionnaire de périphériques on trouvait, ici pas possible.
Pour il est bien dit que OpenSuse reconnaît tout les périphériques !
C'est un PC portable Fujitsu Siemns Amilo Xi 2528. Aussi, la caméra fonctionnait avec Windows. J'ai les pilotes d'origines de la webcam que j'ai retrouvé sur le net, mais impossible de l'installer, normal, je comprend .
Y a-t-il une ou des lignes de commandes à réaliser, en sachant que je ne suis pas en fait de toutes ces manipulations, à part quelques bases ! Je suppose une question par message donc ,je suis encore pour un bout de temps :D
D'avance merci
Thoutmosis

 

Re : webcam intégrée non reconnu

Répondre #1
bonjour et bienvenue.
peux tu nous donner le résultat (en root) de
lsusb
à taper dans un terminal. Utilise les balises code pour le résultat de la commande en cliquant sur #
Sous quel programme as tu vu que ta webcam n'est pas reconnue?

Re : webcam intégrée non reconnu

Répondre #2
EDIT: en fait c'est en validant mon message que je me suis aperçu que jtro avait été plus rapide.

Bonjour,

Peux-tu indiquer le retour des commandes suivantes tapées dans une fenêtre de terminal (ou sinon sous le Gestionnaire de périphériques de Windows en donnant les ID correspondants à la webcam)?

lsusb
sudo lspci
sudo dmesg | grep video
Exemple de résultat sur mon portable pour la commande lsusb (ma webcam n'est pas listée par lspci c'est juste pour voir le reste de ta config):

bernard@linux-xxxxx:~> lsusb
Bus 005 Device 004: ID 0c45:62c0 Microdia Sonix USB 2.0 Camera
----
Bus 008 Device 002: ID 0a5c:2101 Broadcom Corp. BCM2045 Bluetooth
----
Bus 002 Device 002: ID 046d:c542 Logitech, Inc. Wireless Receiver

Dans le résultat affiché les éléments à repérer pour ta webcam, si elle n'était pas reconnue (ce qui n'est pas le cas pour la mienne), se sont les identifiants du périphérique, dans mon cas ID 0c45:62c0 (pour Windows ça serait USB\VID_0C45&PID_62C0) et de faire des recherches à ce sujet.

C'est pas parce que la webcam marchait parfaitement sur le Fujitsu sous Windows XP ou 7 que, par exemple, la seule réinstallation de Windows 10 ou 11 dessus permettrait un fonctionnement sans faille de celle-ci sur le nouveau système. J'ai l'exemple d'un voisin pour qui sa webcam n'est plus fonctionnelle après mise-à-jour vers Windows 10 (son portable est un Clevo vendu sous la marque EssentielB de Boulanger)...

Re : webcam intégrée non reconnu

Répondre #3
Bonjour,
Merci pour votre réponse rapide, mais lorsque je tape " lsusb , j'obtiens une série de lignes commençant par
"bus 001 "etc.. en tout 9 ligne dont une avec la souris et bluetooch , les autres terminant par root hub , mille excuse je ne vois pas comment insérer la photo de l'écran avec toutes les lignes de commande. Mais je ne vois pas une ligne avec camera ?
Et quand je tape les autres commandes " sudo  lspci " et "sudo dmesg | grep video ", après quelques lignes , sudo demande mon nom de passe de root, mais impossible, et en plus quand je veux fermer le terminal, un message me dit qu'il a un processus en court.
Mais rien ne se passe.
Sûrement fait une erreur quelque part, n'étant pas habitué aux lignes de codes. Je crois que je vais me résilier à placer une webcame externe ???
Aussi, j'avais essayé d'utiliser "VLC " et Cheese, mais aucune de ces applications ne reconnaît, de camera intégrée.
D'avance merci.
Thoutmosis

Re : webcam intégrée non reconnu

Répondre #4
Quand tu as le résultat de ta commande, tu le copies,en le sélectionnant puis ctrl +v. Tu le colles dans ta réponse,ctrl + v entre des balises code(#). Sinon on ne peut pas t'aider.
Tu n'as pas d'utilisateur root?  Essaies avec sudosu et il te demandera ton MDP utilisateur.
 Quand tu lances cheese,fais le dans un terminal, et note les messages d'erreurs.
 

Re : webcam intégrée non reconnu

Répondre #5
Si tu n'es pas familier avec la ligne de commande, tu peux aussi tenter de "glaner" quelques infos sur la caméra en lançant Kinfocenter.

Cliquer sur le menu du Lanceur d'applications --> onglet Applications --> Système --> Centre d’informations.
Aller ensuite dans le sous-menu Périphériques --> Périphériques USB par exemple.

Mais si tu retrouves ton pass administrateur, alors tu peux lancer YaST et dans le sous-menu Matériel lancer le module Informations sur le matériel.
 
Les infos récupérées à partir du résultat de la commande dmesg peuvent permettre d'identifier le problème rencontré avec ta webcam (chipset vidéo non compatible avec le kernel ou firmware ou module manquant?).

Peux-tu quand même préciser aussi quelle version d'openSuse tu as installé? Leap, Tumbleweed ou autre Linux?

Re : webcam intégrée non reconnu

Répondre #6
Bonjour,
Merci d'essayer de m'aider, il st vrai pas habitué aux lignes de codes.
Et quand on parle de balises c'est ce signe " [ " ?
Je m'efforce de comprendre et de m'appliquer, car en faisant des recherches il est vrai,
 il  a un fameux de paquet pour les lignes de codes, c'est fous , mais amusant !
Et comme je suis curieux de tout !
Thoutmosis :D

Re : webcam intégrée non reconnu

Répondre #7
Et quand on parle de balises c'est ce signe " [ " ?

Bonjour,

Non. Les balises qu'on te demande d'utiliser servent à mettre en forme le code sur le forum, à lui donner un aspect particulier.

Quand tu postes la réponse d'une commande, tu surlignes cette réponse et tu cliques sur # dans l'éditeur du forum.

Comment faire en image (cliquer pour agrandir) :


Re : webcam intégrée non reconnu

Répondre #8
@Thoutmosis

Peux-tu confirmer que ta webcam est une Chicony par exemple, comme indiqué sur le site Fujitsu/Siemens: https://support.ts.fujitsu.com/IndexDownload.asp?lng=fr&OpenTab=



Peux-tu  confirmer que le résultat de la commande lsusb affiche une ligne avec le texte:
Bus 0xx Device 0xx: ID 0402:5602 xxxxxxxxxxxxxxxx
Infos obtenu à partir des pilotes fournis par Fujitsu/Siemens pour ton portable:
BisonCam WebCam
CamM5603D DeviceId= VID_0402&PID_5602    (ALi5603D ?)
Sinon, le résultat de la commande suivante peut aussi être intéressant à consulter pour y rechercher une référence à la webcam:
dmesg | grep usb
dmesg | less        (pour "naviguer" dans le fichier log du système et y rechercher le problème avec la cam)
Dans Linux, l'important n'est pas de trouver la marque d'un périphérique (une webcam Chicony dans notre exemple), mais plutôt le VRAI chipset utilisé dessus, car c'est à lui que doit correspondre le "pilote" (module du kernel)...

Des infos sur la compatibilité du chipset de la webcam peuvent être trouvées sur:
http://www.ideasonboard.org/uvc/#devices
https://www.linuxtv.org/wiki/index.php/Webcam_devices

Lu sur le WiKi d'Ubuntu: https://doc.ubuntu-fr.org/webcam_tableau#webcams_integrees_ali
Il n'est pas sûr non plus que la webcam soit fonctionnelle sous Windows 10 et 11, mais uniquement sous XP, Vista et 7?

Re : webcam intégrée non reconnu

Répondre #9
Bonjour,
Mille excuse, mais je n'ai pu vérifier plus tôt mes message.
Et, pour votre question, je n'avais pas remarqué le nom "Chicony", mais pour le reste c'est tout à fait cela, car la page support me donne tout les drivers possible pour le PC.
Donc, j'ai les pilotes, mais impossible de les installer ???
Et oui, elle était fonctionnelle sous Vista 32 Bits.
Je vais m'atteler à vérifier tout cela ! :D
Aussi, je vais vérifier, s'il me reste pas un disque dur dans un coin, pour y remettre Vista et puis
dans le Gestionnaire de périphériques, je devrais retrouver le "Chipset" utilisé par la caméra ?
Encore merci, en croissant les doigts.
Thoutmosis

Re : webcam intégrée non reconnu

Répondre #10
Bonjour,
Oups merci à Chumi pour les balises.
Thoutmosis