Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Lecture flux vidéos impossible. [résolut] (Lu 724 fois) sujet précédent - sujet suivant

Lecture flux vidéos impossible. [résolut]

Bonjour, meilleurs vœux 2023...
Depuis quelques temps (MAJ?...) impossible de lire des flux vidéos quelque soit le navigateur utilisé alors que ça fonctionnais auparavant et sans que j'ai fait de modification. Le lecteur VLC fonctionne bien pour lire des vidéos sur disque. J'ai essayé de désinstaller VLC et de réinstaller avec les codecs nécessaires de divers manières dont j'ai finit par oublier les manipulations tant elles ont été nombreuses, sans succès.
Finalement je me suis rabattus sur cette solution glanée sur la toile...

Manifestement il me manque des éléments que je n'arrive pas à installer:
pepit@wawa:~> sudo zypper in vlc vlc-codecs
Problème : l'élement vlc-3.0.18-371.1.x86_64 à installer nécessite 'vlc-noX', mais cette exigence ne peut pas être remplie

J'ai essayé sans cette exigence mais j'ai plus le lecteur du tout!  :o
 
J'ai tenté d'ajouter le dépôt contenant vlc-noX manquant conseillé:
sudo zypper addrepo https://download.opensuse.org/repositories/openSUSE:Factory/standard/openSUSE:Factory.repo
Fichier '/repositories/openSUSE:Factory/standard/openSUSE:Factory.repo' introuvable sur le medium 'https://download.opensuse.org/'
Ce liens ne fonctionne pas le dépôt semble inexistant, il doit manquer un truc dans l'adresse que je ne trouve pas. Du coup je tourne en rond!  ;)
Si quelqu'un a une solution pas trop "exiguë", je suis preneur!


Re : Lecture flux vidéos impossible.

Répondre #2
salut tu peux aussi faire ça
sudo zypper in opi && sudo opi codecs

Re : Lecture flux vidéos impossible.

Répondre #3
Salut.
Tant qu'à glaner de l'info sur le web : https://guide-opensuse.alionet.org/codecs
;)
à plus,
oh!rocks

 Merci, oui, j'avais vu cela, mais comme j'avais installé via les dépots VLC il est déconseillé de mélanger avec ceux de Pacman!

Du coup, j'ai tenté cette solution:
salut tu peux aussi faire ça
sudo zypper in opi && sudo opi codecs

Ca fonctionne de nouveau, merci beaucoup à vous deux!  8) 



Re : Lecture flux vidéos impossible. [résolut]

Répondre #4
la commande avec opi ajoute le dépôt packman et fait ce qui est indiqué dans le guide de manière automatique.

Re : Lecture flux vidéos impossible. [résolut]

Répondre #5
Effectivement je l'ai constaté, ça a aussi enlevé celui de VLC il me semble, la manœuvre a été assé lourde et longue.  :)

Re : Lecture flux vidéos impossible. [résolut]

Répondre #6
Je ne pense pas que la commande opi ait supprimé le dépôt vlc, mais elle a pu passer le paquet vlc sur le dépôt packman ce qui rend le dépôt vlc inutile.
Maisc'est à vérifier car je n'ai jamais utilisé cette commande. Tu peux vérifier tes dépôts depuis YaST > Dépôts de logiciels
ou en ligne de commande utilisateur
zypper lr -d

Re : Lecture flux vidéos impossible. [résolut]

Répondre #7
Effectivement le dépot VLC est toujours présent, il vaut peut être mieux l'enlever?

Re : Lecture flux vidéos impossible. [résolut]

Répondre #8
Effectivement le dépot VLC est toujours présent, il vaut peut être mieux l'enlever?
Oui tout à fait à condition que vlc soit effectivement en provenance du dépôt packman ;)

 

Re : Lecture flux vidéos impossible. [résolut]

Répondre #9
Merci, le dépôt VLC était toujours présent mais VLC proviens bien de packman, donc supprimé. ;) .