Aller au contenu principal
Sujet: problème avec samba 4.15.4+git.324… (Lu 575 fois) sujet précédent - sujet suivant

problème avec samba 4.15.4+git.324…

Bonjour,

le service samba ne se lance plus correctement avec
Repository         : Update repository with updates from SUSE Linux Enterprise 15
Name               : samba
Version            : 4.15.4+git.324.8332acf1a63-150300.3.25.3

toto-PC:/home/thierry # systemctl status smb
● smb.service - Samba SMB Daemon
     Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Fri 2022-03-04 08:49:33 CET; 1h 45min ago
       Docs: man:smbd(8)
             man:samba(7)
             man:smb.conf(5)
    Process: 5362 ExecStartPre=/usr/share/samba/update-apparmor-samba-profile (code=exited, status=0/SUCCESS)
    Process: 5370 ExecStart=/usr/sbin/smbd --foreground --no-process-group $SMBDOPTIONS (code=exited, status=1/FAILURE)
   Main PID: 5370 (code=exited, status=1/FAILURE)
     Status: "daemon failed to start: Samba failed to init printing subsystem"
      Error: 13 (Keine Berechtigung)

Mär 04 08:49:32 toto-PC systemd[1]: Starting Samba SMB Daemon...
Mär 04 08:49:33 toto-PC smbd[5370]: [2022/03/04 08:49:33.087119,  0] ../../source3/smbd/server.c:1734(main)
Mär 04 08:49:33 toto-PC smbd[5370]:   smbd version 4.15.4-git.324.8332acf1a63150300.3.25.3-SUSE-oS15.0-x86_64 started.
Mär 04 08:49:33 toto-PC smbd[5370]:   Copyright Andrew Tridgell and the Samba Team 1992-2021
Mär 04 08:49:33 toto-PC systemd[1]: Started Samba SMB Daemon.
Mär 04 08:49:33 toto-PC smbd[5370]: [2022/03/04 08:49:33.143853,  0] ../../lib/util/become_daemon.c:120(exit_daemon)
Mär 04 08:49:33 toto-PC smbd[5370]:   exit_daemon: daemon failed to start: Samba failed to init printing subsystem, error code 13
Mär 04 08:49:33 toto-PC systemd[1]: smb.service: Main process exited, code=exited, status=1/FAILURE
Mär 04 08:49:33 toto-PC systemd[1]: smb.service: Failed with result 'exit-code'.

J'ai installé la version précédente (la 4.13.13+git.539.fdbc44a8598-3.20.2)
v  | samba                          | Paket      | 4.15.4+git.324.8332acf1a63-150300.3.25.3 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | samba                          | Paket      | 4.13.13+git.539.fdbc44a8598-3.20.2       | x86_64 | Update repository with updates from SUSE Linux Enterprise 15

Le service samba fût à nouveau fonctionnel (je crois que c'est cette sortie, mais peu importe…):
toto-PC:/etc/samba # systemctl status smb  
● smb.service - Samba SMB Daemon
     Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled; vendor preset: disabled)
     Active: active (running) since Fri 2022-03-04 11:03:40 CET; 2s ago
       Docs: man:smbd(8)
             man:samba(7)
             man:smb.conf(5)
    Process: 10774 ExecStartPre=/usr/share/samba/update-apparmor-samba-profile (code=exited, status=0/SUCCESS)
   Main PID: 10778 (smbd)
     Status: "smbd: ready to serve connections..."
      Tasks: 4 (limit: 4915)
     CGroup: /system.slice/smb.service
             ├─10778 /usr/sbin/smbd --foreground --no-process-group
             ├─10780 /usr/sbin/smbd --foreground --no-process-group
             ├─10781 /usr/sbin/smbd --foreground --no-process-group
             └─10782 /usr/sbin/smbd --foreground --no-process-group

Mär 04 11:03:40 toto-PC systemd[1]: Starting Samba SMB Daemon...
Mär 04 11:03:40 toto-PC smbd[10778]: [2022/03/04 11:03:40.579565,  0] ../../lib/util/become_daemon.c:153(daemon_ready)
Mär 04 11:03:40 toto-PC systemd[1]: Started Samba SMB Daemon.
Mär 04 11:03:40 toto-PC smbd[10778]:   daemon_ready: daemon 'smbd' finished starting up and ready to serve connections

Mon scanner réseau (imprimante…) put à nouveau accéder à mon dossier 'scan' via samba…

Une recherche google ici montre que plusieurs distributions sont (ont été) impactées.

Pour info, je suis ici avec Leap 15.3, je ne sais pas ce qu'il en est avec Tumbleweed…

Re : problème avec samba 4.15.4+git.324…

Répondre #1
:hello:

j'ai vu passer pas mal de pb avec samba sur debian aussi.
ça a l'air d'être un problème généralisé. :/

Re : problème avec samba 4.15.4+git.324…

Répondre #2
Je viens de me lever un peu tard…
Ce matin tout est rentré dans l'ordre. Peut-être la mise à jour tardive d'hier (le paquet samba n'a pas changé), difficile à dire. Peut-être le fait d'avoir réinstallé samba 4.13.13, puis à nouveau samba 4.15.4, je ne sais pas.
Toujours est-il que mon scanner réseau envoie à nouveau le scan vers un dossier "samba" de mon ordi, avec une version 4.15.4
thierry@toto-PC:~> systemctl status smb.service 
● smb.service - Samba SMB Daemon
     Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled; vendor preset: disabled)
     Active: active (running) since Sat 2022-03-05 09:49:28 CET; 41s ago

Version            : 4.15.4+git.324.8332acf1a63-150300.3.25.3

Je mets le sujet résolu.

Re : problème avec samba 4.15.4+git.324…

Répondre #3
À nouveau le service smb ne démarre pas. (4.15.4)
Je passe avec l'ancienne version, la samba 4.13.13 , ça roule…

Re : problème avec samba 4.15.4+git.324…

Répondre #4
J'ai eu un souci équivalent avec le message d'erreur "failed to init printing subsystem" et ai dû ajouter une option pour les imprimantes (dans Global) pour que cela fonctionne... Mais mon samba ne partage pas d'imprimante

disable spoolss = Yes

 

Re : problème avec samba 4.15.4+git.324…

Répondre #5
Bonjour,

je te remercie un peu tard Raoul pour la parade.  ;) Je l'avais aussi lu, sans l'essayer. Je la garde sous le coude…

Aujourd'hui, j'ai le cœur à tenter de nouveau la mise à jour vers samba 4.15.4.

Le service a démarré  8) intéressant.

Bonne journée.