Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Fournisseur des paquets  (Lu 4634 fois) sujet précédent - sujet suivant

Fournisseur des paquets

Bonsoir à toutes et tous
Est il possible en ligne de commande de connaître la provenance d'un paquet
Exemple :  Je cherche un paquet  " zypper search   le nom du paquet "
J'ai la réponse de l'existence du paquet  , donc je suppose qu'il est installable dans Tumbleweed , donc je fais
" zypper install le _nom _du _paquet
Réponse " aucun fournisseur trouvé pour esptool "( c'est l'appli que je cherchais )
D'où ma question , peut on trouver le fournisseur ( dépôt)d'un paquet lorsque l'on fait une recherche en ligne de commande
Ce qui me permettrait d'installer éventuellement le dépôt en question
Merci
Bonne soirée

Re : Fournisseur des paquets

Répondre #1
Bonsoir @jenrem!
Je pense que zypper se -s packageName devrait répondre à tes besoins.
N'hésite pas à regarder man zypper pour encore plus d'options.
En espérant que ça t'aidera.
Pascom

Re : Fournisseur des paquets

Répondre #2
Bonsoir et merci Pascom
C'est exactement ce qu'il me fallait
C'est aussi une surprise , puisque tous les paquets sont dans le  dépôt principal  OSS
Je ne comprend pas pourquoi zypper m'a répondu lors de ma tentative d'installation qu'il ne trouvait pas de fournisseur pour ces paquets   que j'ai aussi trouvés dans Yast , mais sous l'appellation  " pythonxx-esptool"
Merci
Je passe en résolu
Bonne soirée

Re : Fournisseur des paquets

Répondre #3
@jenrem : Bonsoir,

Tu fais une recherche sur esptool et zypper te trouve quelque chose contenant la chaîne de caractères epstool. Chez moi zypper trouve trois paquets aux doux noms de python39-esptool, python310-esptool, python311-esptool mais un paquet nommé simplement et strictement epstool n'existe pas dans mes dépôts. Je ne pourrai donc pas installer esptool en faisant zypper in esptool (aucun fournisseur trouvé). Par contre j'aurais plus de chance en tentant avec le nom complet de l'un des trois paquets listés plus haut (pour autant que l'un d'eux corresponde à ce que je cherche vraiment).

Zypper travaille avec les dépôts qu'il a sous la main et ne sait rien des dépôts qui ne sont pas installés.

Tu peux par contre faire une recherche plus large ici : https://software.opensuse.org/explore

J'ai ce résultat pour epstool : https://software.opensuse.org/package/epstool?search_term=epstool

Citer
Il n'y a pas de paquet officiel disponible pour ALL Distributions

Par contre il existe un paquet expérimental pour Tumbleweed qui nécessitera d'installer un dépôt supplémentaire.

Edit @jenrem :  j'ai posté ma réponse en même que toi. Si jamais l'un des paquets python-epstool ne correspond pas à ce que tu cherches vraiment, mes indications finales ne seront peut-être pas inutiles.

Re : Fournisseur des paquets

Répondre #4
Bonsoir Chumi
Merci , effectivement , il y a 3 paquets
S | Name              | Type   | Version   | Arch   | Repository 
--+-------------------+--------+-----------+--------+----------------------
  | python39-esptool  | paquet | 4.6.2-1.2 | noarch | Dépôt principal (OSS)
  | python39-esptool  | paquet | 4.6.2-1.2 | noarch | repo-oss
  | python310-esptool | paquet | 4.6.2-1.2 | noarch | Dépôt principal (OSS)
  | python310-esptool | paquet | 4.6.2-1.2 | noarch | repo-oss
  | python311-esptool | paquet | 4.6.2-1.2 | noarch | Dépôt principal (OSS)
  | python311-esptool | paquet | 4.6.2-1.2 | noarch | repo-oss
jenrem@jenmy-celsiusw410:~>
 
Je pense que c'est ce que tu as trouvé
Et comme tu le dis si bien ,  je ne sais pas lequel je dois installer
Installe un dépôt supplémentaire , j'ai packman , et je n'aime pas trop diversifier trop de dépôts
Je crois que  " Arduino " et " esp  " ( moins sûr ) sont développés sous Arch , comme j'ai Manjaro , je vais regarder si le paquet " esptool " est présent et si il y en a plusieurs comme ici
Je ferai ça demain , et je viendrai rendre compte de mes " trouvailles "
Je suivrai aussi tes liens pour en savoir un peu plus
Bonne soirée
edit , ce que je ne comprends pas trop , c'est que tous les paquets ont la même version??

Re : Fournisseur des paquets

Répondre #5
;=)

Pour esptool je trouve ceci :

Résumé                    : A serial utility to communicate & flash code to Espressif ESP8266 & ESP32 chips
Description               :
    A command line utility to communicate with the ROM bootloader in Espressif ESP8266 & ESP32 microcontrollers.

    Allows flashing firmware, reading back firmware, querying chip parameters, etc.


ici tu vois la dernière version en date de python : https://www.python.org/downloads/
(3.12.1 à ce jour)

après il faut voir ce qu'il te faut comme version de python, info dispo dans le nom du paquet python***-esptool

tu auras donc accés via le dépot OSS à la version 4.6.2-1.2 d'esptool pour le python désiré , 3 versions de python au choix.

Re : Fournisseur des paquets

Répondre #6
Bonsoir Manchette
 Ma version de python et la 3.11..., donc la version à installer de esptool et la version python311-esp
J'hésitais entre la version Python installée sur l'ordi ou la version de l'esp easy , qui est plus difficile à trouver
Merci pour toutes ces infos ,je vais essayer de flasher ce matériel et je verrai ce que ça donne
Bonne soirée

Re : Fournisseur des paquets

Répondre #7
attention fais bien tes sauvegardes avant ce type de manip :=)

Re : Fournisseur des paquets

Répondre #8
Re Manchette
Oui , l'autre jour j'ai voulu installer " Arduino " qui était apparemment dispo , mais au redémarrage, écran noir  et comme je ne me rappelais plus de la commande pour lancer sddm , j'avais une image iso sur clef , j'ai réinstallé Tumbleweed ,
C'est pour cette raison que j'ai posé ma question sur l'origine des paquets  avant de faire une installation
Et en cherchant la façon de flasher la carte , je vais avoir besoin de Arduino , ce qui m’inquiète un peu
Je ne suis pas sûr que Arduino soit dispo pour Tumbleweed , il va falloir que je cherche plus avant
Bonne soirée