Aller au contenu principal

Sujets

Cette espace vous permet de voir toutes les Sujets réalisées par ce membre. Vous ne pouvez voir que les Sujets réalisées dans les espaces auxquels vous avez accès.

Sujets - burn2

1
Matériel / SSD sous opensuse (discard/noatime)
Bonjour,

En regardant les options de montage de mes partitions de ssd, je me rends compte qu'il n'y a ni noatime, ni discard sur les partitions.
J'ai rajouté noatime car c'est une option très utile pour limiter l'usure des ssd, mais pour discard y a il une autre méthode de fstrim en place chez openSuse?

j'ai cherché rapidement pour l'instant je n'ai rien trouvé de catégorique.


EDIT: j'aurais du préciser mes partitions:
/boot ==> EXT4
LVM Encrypt
      / ==> EXT4
      /swap

DAns une telle configuration faut-il activer discard ou pas? ET comment s'effectue le trim du coup?

Edit2, il semblerait que ça soit fait par timer:
systemctl status fstrim.timer
● fstrim.timer - Discard unused blocks once a week
   Loaded: loaded (/usr/lib/systemd/system/fstrim.timer; enabled; vendor preset: enabled)
   Active: active (waiting) since Wed 2021-04-21 08:54:05 CEST; 1h 44min ago
  Trigger: Mon 2021-04-26 00:00:00 CEST; 4 days left
     Docs: man:fstrim

Mais si je fais un sudo fstrim -a ça ne semble pas vouloir du coup comment être sûr que le trim est bien fait?

2
Programmes et logiciels / Réactivité général openSuse
Bonjour,

Petite question, avez vous constaté un manque de réactivité d'openSuse?
Je l'ai sur plusieurs machines et je constate à chaque fois les mêmes "lenteurs" à l'ouverture de programme.

En gros si j'ouvre firefox/chromium/thunderbird ou autre, je trouve que c'est toujours plus lent, que les mêmes applications que j'ouvrirais sous Manjaro ou autre par exemple.
IL en est de même sur les paquets flatpak.

Au début je me disais que c'était propre à la version Leap, mais je viens d'installer la version tumbleweed à jour sur le pc portable à base de ryzen 4800H/32go/SSD Samsung evo 860 2to et pareil, je trouve que ça manque de réactivité. (tout a été installé en Ext4 LVM Encrypt).
J'ai leap installé sur 3 Pcs différents et tumbleweed sur cette nouvelle machine tout juste arrivée et je constate toujours ces petits temps de chargement qui me semblent anormaux surtout une fois le logiciel déjà lancé.

Exemple simple, j'ouvre firefox, je le referme, je le réouvre ==> Le temps d'ouverture est > à 1s, on doit être entre 1 et 2s.
Normalement ça devrait être presque instantané.
Mais ce n'est pas propre à firefox, si je fais le même test sous chromium, c'est un peu plus rapide, mais j'ai aussi ce temps de chargement d'une seconde

Il faudrait que je refasse le test en vm pour comparer les bureaux/systême de fichier, mais ça reste assez visible comparé à Manjaro Kde par exemple.  (un pote a aussi perçu ça en machine virtuelle)

Vous constatez quoi de votre côté?

Avez vous constaté cela?
3
Virtualisation / Virtualbox et Tumbleweed bon ménage???
Bonjour;

Y a t-il du monde qui utilise virtualbox sous tumbleweed en host?
Y a t-il des soucis de module kernel qui ne suit pas et qui pause problème ou non c'est toujours bien mis à jour à chaque fois en même temps?


Merci d'avance.
4
Programmes et logiciels / OpenSuse Leap 15.2: Archive 7z non ouvrable
Bonjour,

J'ai un soucis sous kde, je n'arrive pas avec dolphin à ouvrir des fichier 7z que j'avais fait avec 7zip depuis windows.
A chaque fois j'ai ce genre de message:
Citer
"Le chargement de l'archive /home/user/TMP/travail.7z a échoué avec l'erreur suivante :
Impossible de trouver un module d'extension approprié. Ark ne semble pas pouvoir prendre en charge ce format de fichier."

Le même fichier est bien ouvrable depuis Ubuntu 18.04 par exemple, ce n'est donc que ARK qui n'arrive pas à l'ouvrir, avez vous une idée du pourquoi?
P7zip est bien installé.

5
Matériel / Compilation Kernel
Bonjour,

Je devrais récupérer une machine avec un cpu 4XXX, donc cpu "renoir".
Pour de tels cpu il faut normalement un kernel 5.9 voir plus récent pour avoir un igp bien supporté.

Dans les premiers retours, sur la 15.3, ces cpus semblent enfin correctement supportés, mais pas sur que ça soit suffisamment backporté pour avoir quelque chose de parfait.
Je sais qu'il existe un dépôt KERNEL "stable", mais celui ci contient toujours le tout dernier kernel (genre le 5.11 en ce moment), et personnellement par sécurité je préférerais avoir le contrôle et potentiellement rester sur le LTS.

Vous avez déjà compilé un kernel à la mano sous openSuse?
Peut-on garder la configuration effectuée par le noyau Suse, et l'appliquer en compilant un noyau 5.10 ou on va forcément repartir sur du vanilla?

Qu'en est-il sur tumbleweed niveau kernel, c'est du vanilla ou les patchs de suse sont aussi appliqués?

merci d'avance.
6
Programmes et logiciels / Kde: Désactiver les mise à jour automatique
Bonjour,

Pour un pc portable de la famille, je souhaiterais supprimer la vérification automatique de l'applet kde d'opensuse leap.
Savez vous comment on peut faire ça?

En fait je souhaites que le truc ne fasse aucune recherche automatique histoire que ça ne fasse pas de notification.
Les mises à jour c'est moi qui les fait quand j'y suis donc je ne veux pas que ça les dérange avec des notifs en boucle.

Dans les options on ne peut visiblement que décaler les recherches à une fois tous les mois et pas mettre "jamais".
J'ai trouvé quelques pistes mais si jamais vous avez une procédure spécifique je suis preneur. :)
7
Programmes et logiciels / Okular problème encodage PDF
Bonjour,

J'ai un soucis avec okular, il n'arrive pas à lire certains pdf.
Si j'ouvre le pdf avec LibreOffice draw, le pdf est parfaitement lisible.
Si je copie colle le texte du pdf entre le pdf et le navigateur, le texte redevient bon.

Vous avez déjà eu ce genre de soucis d'encodage?



9
Matériel / Optimus NVidia Opensuse LEAP
Bonjour,

Juste un petit message pour fournir des informations à ceux qui auraient le même soucis que moi.
JE possède donc un pc portable avec un gpu nvidia 960M avec une solution "optimus".

Nvidia c'est "caca" sous linux mais bon on fait avec ce qu'on a.
J'ai installé les pilotes nvidia et  suse-prime c'est installé tout seul, je pensais ça suffisant.
Le switch intel/nvidia fonctionnait, je m'attendais donc à ce que tout soit ok.

Oui mais en fait non!
Je ne comprenais pas pourquoi mon ventilo jouait au yoyo de manière très désagréable.
Après recherche en fait ce n'est pas suffisant!

Il faut aussi faire ça:
https://github.com/openSUSE/SUSEPrime
En gros il faut:
Télécharger l'archive zip contenant tous les fichiers.

Puis dans mon cas (gpu plus anciens) faire:
zypper in bbswitch
Se placer dans l'archive dézippée précédemment téléchargée puis depuis un terminal root:
if [ ! -s /etc/modprobe.d/09-nvidia-modprobe-bbswitch-G04.conf ]; then
  cp 09-nvidia-modprobe-bbswitch-G04.conf /etc/modprobe.d && dracut -f
fi

et enfin:
if [ ! -s /usr/lib/systemd/system/prime-select.service ]; then
  cp prime-select.service /usr/lib/systemd/system && \
  systemctl enable prime-select
fi


Après reboot:
/usr/sbin/prime-select get-current
Driver configured: intel
[bbswitch] NVIDIA card is OFF

Et le ventilo se calme enfin!!!  :-*
ET passe donc de 0T/min à un régime très léger en surf et non pas des "on/off" en continu!!!


Voilà en espérant que cela puisse servir à quelqu'un. ;)
11
Matériel / Fréquence CPU figée à 3ghz Leap 15.2 KDE
Bonjour,

J'ai un soucis sur mon openSuse leap 15.2 KDE sur mon pc portable à base de i5 4310M (je suis sur l'igp en ce moment)
En idle normalement le ventilateur arrive à se couper.
Là le ventilateur cpu passe son temps à jouer au yoyo.

La température est toujours entre 50 et 60° en idle sur le pc portable là ou normalement elle est sous les 50°.
(j'avais entre 40 et 50° en idle sous ubuntu mate + compiz).

Après analyse, je vois que le cpu reste TOUJOURS dans les 3ghz, même en idle.
En regardant via htop, je vois qu'il y a un poil de charge mais rien de grave, entre 2 et 5% max sur chaque coeur selon les "top" avec le navigateur ouvert.
Mais même en le fermant, avec des cœurs à 0%, la fréquence ne tombe pas à 800mhz ou plus bas comme elle le pourrait.

J'ai testé de vérifier que la fréquence min soit bien configurée via:
Citer
sudo cpupower frequency-set --min 800MHz
De forcer le profil via powersave:
Citer
sudo cpupower frequency-set -g powersave

Tout est pourtant ok:
Citer
sudo cpupower frequency-info
analyse du CPU 0 :
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency:  Cannot determine or is not supported.
  limitation matérielle : 800 MHz - 3.20 GHz
  régulateurs disponibles : performance powersave
  tactique actuelle : la fréquence doit être comprise entre 800 MHz et 3.20 GHz.
                  Le régulateur "powersave" est libre de choisir la vitesse
                  dans cette plage de fréquences.
  current CPU frequency: Unable to call hardware
  current CPU frequency: 3.09 GHz (asserted by call to kernel)
  boost state support:
    Supported: yes
    Active: yes

Mais rien n'y fait, le cpu reste toujours dans les 3ghz, si je mets en mode performance ça passe à 3.2.
Si je réduis la fréquence maximale, la fréquence bouge bien.
Je me dis que c'est un soucis de paliers de fréquence ou de % à chaque palier mais je ne vois pas configurer pour ça.

Avez vous déjà eu ce genre de soucis?



EDIT: ça semble être ce même genre de pb
https://www.reddit.com/r/openSUSE/comments/i10zhe/cpu_clock_speed_ramping_up_on_leap_152/


EDIT2: à tester aussi au cas ou
https://forums.opensuse.org/showthread.php/521878-CPU-running-with-top-speed-all-the-time
12
Internet, réseaux et serveurs / OpenVPN ne fonctionne pas depuis Network manager KDE
Bonjour,

J'ai OpenSuse leap 15.2 d'installé.
J'ai bien openvpn d'installé.

SI j'importe mon profil vpn depuis l'applet kde (network manager du coup), le vpn ne fonctionne pas j'ai droit à:
Citer
2021-02-07T10:59:24.931143+01:00 CLEVO-WD230SD NetworkManager[1674]: <info>  [1612691964.9310] audit: op="statistics" arg="refresh-rate-ms" pid=2339 uid=1001 result="success"
2021-02-07T11:00:18.355764+01:00 CLEVO-WD230SD nm-openvpn[3885]: TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
2021-02-07T11:00:18.356122+01:00 CLEVO-WD230SD nm-openvpn[3885]: TLS Error: TLS handshake failed
2021-02-07T11:00:18.356337+01:00 CLEVO-WD230SD nm-openvpn[3885]: SIGUSR1[soft,tls-error] received, process restarting
2021-02-07T11:00:18.379756+01:00 CLEVO-WD230SD NetworkManager[1674]: <warn>  [1612692018.3796] vpn-connection[0x55618fd282e0,04bb74c1-ebbe-4fa8-9013-da8df59a90b1,"OpenVPN_INTERNET",0]: VPN connection: connect timeout exceeded.

Le profil fonctionne parfaitement network manager version gtk comme sous mate/cinnamon sur les distribs que j'ai pu tester.
Mais sous openSuse kde aucune idée de pourquoi ça ne veut pas.

Sur ce même pc si je fais une connexion manuelle depuis le profil root du coup
Citer
openvpn OpenVPN_INTERNET
Sun Feb  7 18:43:02 2021 OpenVPN 2.4.3 x86_64-suse-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Jun 20 2017
Sun Feb  7 18:43:02 2021 library versions: OpenSSL 1.1.1d  10 Sep 2019, LZO 2.10
Enter Auth Username: xxxxxxxxxxx
Enter Auth Password: **************
Sun Feb  7 18:43:24 2021 TCP/UDP: Preserving recently used remote address: [AF_INET]XXX.XXX.XXX.XXX:1194
Sun Feb  7 18:43:24 2021 UDP link local (bound): [AF_INET][undef]:0
Sun Feb  7 18:43:24 2021 UDP link remote: [AF_INET]XXX.XXX.XXX.XXX::1194
Sun Feb  7 18:43:24 2021 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Sun Feb  7 18:43:25 2021 [OpenVPN_INTERNET_Certificat] Peer Connection Initiated with [AF_INET]XXX.XXX.XXX.XXX::1194
Sun Feb  7 18:43:26 2021 TUN/TAP device tun0 opened
Sun Feb  7 18:43:26 2021 do_ifconfig, tt->did_ifconfig_ipv6_setup=0
Sun Feb  7 18:43:26 2021 /bin/ip link set dev tun0 up mtu 1500
Sun Feb  7 18:43:26 2021 /bin/ip addr add dev tun0 local 10.xx.xx.xx peer 10.xx.xx.xx
Sun Feb  7 18:43:26 2021 Initialization Sequence Completed

ça fonctionne parfaitement, et quand je vérifie mon ip elle a bien changée.
Pourquoi l'import de configuration ne fonctionne t-il pas sous openSuse kde???

Avez vous déjà eu ce genre de problème?

Merci d'avance.
13
Sécurité / Accès disque dur chiffré externe
Bonjour,

J'ai un soucis sous kde leap 15.2.
J'ai un disque dur externe chiffré qui a été chiffré depuis une ubuntu 18.04 .

Lorsque je monte le disque dur depuis mon user "normal" le montage fonctionne mais j'ai une erreur d'accès.
Voici le fonctionnement:
Je vois le volume chiffré apparaître.
Je vais dans dolphin et je clique sur le disque dur ==> il me demande mon mot de passe de chiffrement du disque dur.

Le montage se fait bien mais j'ai un message d'erreur:
Citer
Une erreur est survenue en accédant à « DD_EXTERNE ». Le système a répondu :Le périphérique est déjà monté: Device /dev/dm-3 is already mounted at `/run/media/user/DD_EXTERNE'.

Il ne s'agit pas d'un droit sur un dossier particulier, je ne vois même pas la racine du disque dur externe.
En vrais le problème n'est qu'une histoire de droit user, car si j'ouvre dolphin en mode administrateur, alors je peux accéder au contenu du disque dur chiffré.


Avez vous une idée de ce qu'il faudrait rajouter au user pour que le montage de disque dur externe chiffré fonctionne?
14
Programmes et logiciels / Problème application flatpak kde X11
Bonjour,

J'ai un soucis avec des applications flatpak sous OpenSuse 15.2 kde.
J'ai installé en flatpak element (riot).
Lorsque je lance element sur une session kde X11, ça ne fonctionne pas j'ai ça comme erreur:
Citer
latpak run im.riot.Riot
[2 zypak-helper] Portal v4 is not available
/home/user/.var/app/im.riot.Riot/config/Element exists: no
/home/user/.var/app/im.riot.Riot/config/Riot exists: no
No protocol specified
[8 zypak-sandbox] Dropping 0x1adc260 (3) because of connection closed
[8 zypak-sandbox] Host is gone, preparing to exit...
La détection des répertoires et normal vu que l'application ne se lance pas.

SI je bascule en session wayland ça fonctionne à nouveau.
Si je bascule en session full wayland à nouveau ça ne se lance pas.
Vous avez une idée de ce qui peut dauber?

Merci d'avance.
15
Sécurité / Grosse faille SUDO
Bonjour,

Je ne sais pas encore si openSuse est concernée (en toute logique oui), mais une grosse faille sur sudo a été répertoriée.
Le CVS:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3156

Et l'info de la part de l'entreprise à l'origine de la découverte:
https://blog.qualys.com/vulnerabilities-research/2021/01/26/cve-2021-3156-heap-based-buffer-overflow-in-sudo-baron-samedit


Voilà donc soit la maj est dispo et à vos majs, soit il va falloir faire gaffe d'ici là.