Aller au contenu principal

Voir les messages

Cette espace vous permet de voir toutes les Voir les messages réalisées par ce membre. Vous ne pouvez voir que les Voir les messages réalisées dans les espaces auxquels vous avez accès.

Messages - pepit

2
Programmes et logiciels / Re : Problème avec python gi.repository
Ca avance!  ;)
pepit@wawa:~/FlatCAM_beta_8.994_sources> python3 /home/pepit/FlatCAM_beta_8.994_sources/FlatCAM.py
Traceback (most recent call last):
  File "/home/pepit/FlatCAM_beta_8.994_sources/FlatCAM.py", line 6, in <module>
    from app_Main import App
  File "/home/pepit/FlatCAM_beta_8.994_sources/app_Main.py", line 47, in <module>
    from appCommon.Common import LoudDict
  File "/home/pepit/FlatCAM_beta_8.994_sources/appCommon/Common.py", line 88, in <module>
    class LoudUniqueList(list, collections.MutableSequence):
AttributeError: module 'collections' has no attribute 'MutableSequence'

J'ai peut être une configuration à faire?
3
Programmes et logiciels / Re : Problème avec python gi.repository
Alors, dans le désordre! :)

Pyqt installé:
python310-AnyQt - PyQt4/PyQt5 compatibility layer
python310-python-qdatamatrix - A PyQt4/PyQt5 widget for viewing and editing a DataMatrix object
python38-AnyQt - PyQt4/PyQt5 compatibility layer
python38-python-qdatamatrix - A PyQt4/PyQt5 widget for viewing and editing a DataMatrix object

L'installation de flatcam que j'ai fait est à partir du lien direct de la page d'acceuil flatcam, je me suis pas rendu dans la section "download" Je pensait que c'était la dernière version "beta".
Ben en fait non, c'est la version beta de 8.5!  :'(  pas fait attention!
Bon je réessaye avec la version beta 8.994...
4
Programmes et logiciels / Re : Problème avec python gi.repository
J'ai essayé d'installer cette version : https://software.opensuse.org/package/flatcam?search_term=flatcam

Puis celle-ci : http://flatcam.org/download
Après avoir installé Python3-rasterio comme demandé, je me suis retrouvé avec une rafale de dépendances non résolues. J'ai laissé tomber.

Normal, dans un fichier texte du répertoire flatcam nommé "requirements", il y a les dépendances à installer ainsi qu'une procédure pour le faire simplement.
5
Programmes et logiciels / Re : Problème avec python gi.repository
Tu as un environnement virtuel ou c'est directement dans ton système ?

Edit : j'ai regardé un peu plus ce logiciel. La version 8.5 est vieille et basée sur qt4 qui ne doit plus être trop présent sur Tumbleweed, essaie une version plus récente.
Merci pour vos aides, non, je n'ai pas d’environnement virtuel, j'ai installé la dernière version (test)
pepit@wawa:~> ~/flatcam/flatcam
Traceback (most recent call last):
  File "/home/pepit/flatcam/flatcam", line 11, in <module>
    from PyQt4 import QtGui
ModuleNotFoundError: No module named 'PyQt4'

Pourtant j'ai installé les dépendances contenant PyQt4 pour python  3.1 et 3.8...
8
Programmes et logiciels / Problème avec python gi.repository [résolut]
Bonjour,
je cherche à lancer flatcam et j'obtiens la réponse suivante:

pepit@wawa:~/Téléchargements/FlatCAM-8.5> python FlatCAM.py
Traceback (most recent call last):
  File "FlatCAM.py", line 9, in <module>
    from gi.repository import Gtk
ImportError: No module named gi.repository

Hors python gobject contenant gi est bien installé.
11
Internet, réseaux et serveurs / Re : Lecture flux vidéos impossible.
Salut.
Tant qu'à glaner de l'info sur le web : https://guide-opensuse.alionet.org/codecs
;)
à plus,
oh!rocks

 Merci, oui, j'avais vu cela, mais comme j'avais installé via les dépots VLC il est déconseillé de mélanger avec ceux de Pacman!

Du coup, j'ai tenté cette solution:
salut tu peux aussi faire ça
sudo zypper in opi && sudo opi codecs

Ca fonctionne de nouveau, merci beaucoup à vous deux!  8) 


12
Internet, réseaux et serveurs / Lecture flux vidéos impossible. [résolut]
Bonjour, meilleurs vœux 2023...
Depuis quelques temps (MAJ?...) impossible de lire des flux vidéos quelque soit le navigateur utilisé alors que ça fonctionnais auparavant et sans que j'ai fait de modification. Le lecteur VLC fonctionne bien pour lire des vidéos sur disque. J'ai essayé de désinstaller VLC et de réinstaller avec les codecs nécessaires de divers manières dont j'ai finit par oublier les manipulations tant elles ont été nombreuses, sans succès.
Finalement je me suis rabattus sur cette solution glanée sur la toile...

Manifestement il me manque des éléments que je n'arrive pas à installer:
pepit@wawa:~> sudo zypper in vlc vlc-codecs
Problème : l'élement vlc-3.0.18-371.1.x86_64 à installer nécessite 'vlc-noX', mais cette exigence ne peut pas être remplie

J'ai essayé sans cette exigence mais j'ai plus le lecteur du tout!  :o
 
J'ai tenté d'ajouter le dépôt contenant vlc-noX manquant conseillé:
sudo zypper addrepo https://download.opensuse.org/repositories/openSUSE:Factory/standard/openSUSE:Factory.repo
Fichier '/repositories/openSUSE:Factory/standard/openSUSE:Factory.repo' introuvable sur le medium 'https://download.opensuse.org/'
Ce liens ne fonctionne pas le dépôt semble inexistant, il doit manquer un truc dans l'adresse que je ne trouve pas. Du coup je tourne en rond!  ;)
Si quelqu'un a une solution pas trop "exiguë", je suis preneur!
13
Internet, réseaux et serveurs / Re : Code de filtrage procmail
C'est vrai que l'anglais et moi ça fait pas bon ménage, du coup, les traductions google n’intègre pas les subtilité du langage, surtout s'il est technique; Et même sans ses excuses ça reste compliqué, je ne suis pas programmeur, pour moi "a+ "est une entité alors qu'en fait le "a" n'était que l'exemple remplaçable.C'est vrai que l' "*" je l'avais intégré sous forme d'exemple. Bref, même avec vos aide extra, j'ai du mal à comprendre!

Si je comprend pas très bien en somme: "a*" désigne toute séquence de zéro ou caractères alphabétiques et le a+ que des séquences de caractères alphabétique. Sauf qu'avec un point devant censé remplacer n'importe quel caractère y compris les zéros j'ai du mal à saisir la différence entre "*" et "+"

Toujours est il que ma dernière mouture semble fonctionner. En fait j'ai l'impression que lorsque procmail trouve une erreur dans une recette, elle n'est pas exécutée du tout. Hors dans ma recette j'avais écrit ceci:
* !(To|Cc):(.*Monprénom MonNom.*|.*pseudo@gmail.com.*|.*pseudo@orange.fr.*|.*pseudo@hotmail.com.*)

Procmail semble mal digérer l'espace entre Monprénom et Monnom... Ce qui donne:
* !(To|Cc):(.*MonNom.*|.*pseudo@gmail.com.*|.*pseudo@orange.fr.*|.*pseudo@hotmail.com.*)
Et là, ce soir, j'ai reçu un message dont le "to" ne comportais aucunes des 4 chaînes de caractères ci-dessus et donc retrouvé dans ma poubelle!  :)

A confirmer, j'en attend d'autre à filtrer entre le dimanche et le lundi de chaque semaine...
14
Internet, réseaux et serveurs / Re : Code de filtrage procmail
Je ne suis pas sur que procmail comprenne cette ponctuation!

D'après les man pages le "+" n'existe pas. je ne comprend pas non plus la "\" car il est écrit ceci:
Citer
\    To quote any of the above at the start of the line.

le  "^"avant " from, to, cc, indique à procmail de chercher à partir du début de la ligne. hors ce que je cherche à faire ici est non pas de chercher les caractères présent dans ma liste pour les mettre à la poubelle, ce qui reviendrais a jeter tout les mail qui me sont adressé, mais exactement l'inverse!

D'après les man pages:
Citer
!    Invert the condition.
En fait ici je cherche si les caractères de ma liste sont absent pour diriger les mails concerné à la poubelle.

Cette recette fonctionnais lorsque j’entrai mes adresses comme ceci: .*(<moi>|<moi@tartempion>|etc).*; mais il y avais des trous dans la raquette, car il suffisait que les "<>" n'y soient pas ou qu'il y ai des espaces.

Ceci dit, étant loin d'être bon,  j'attends le résultat de ma dernière correction, et si elle s'avère inefficace j'essaierai les ".+" et les "\" pour voir ce que ça fait.
 
15
Internet, réseaux et serveurs / Re : Code de filtrage procmail
Par contre ma seconde recette anti-spam ne fonctionne toujours pas malgré le même format:
# 2) Règle d'indésirables non explicitement adressé bien classé à "l'horizontale" (complément spam).
:0
* !(To|Cc):(.*Moi MonNom.*|.*pseudo@gmail.com.*|.*pseudo@orange.fr.*|.*pseudo@hotmail.com.*)

$MAILDIR/Poubelle/new

Pourquoi?