Aller au contenu principal
Sujet: Tumbleweed et hplip (Lu 965 fois) sujet précédent - sujet suivant

Tumbleweed et hplip

Bonjour à tous,

Je suis nouveau sur le forum et merci de me confirmer que je m'adresse au bon forum pour le problème suivant.

Je suis sous Tumbleweed (20230429). Il y a quelques jours j'ai fait une réinstallation complète de Tumbleweed, ainsi que de Fedora 38 en dual boot.

J'ai une imprimante-scanner HP Envy 5540 qui, avant la réinstallation de Tumbleweed, fonctionnait parfaitement, comme imprimante et scanner WiFi. Après la réinstallation, j'ai installé cette imprimante scanner à l'aide de hplip. Le résultat est que l'imprimante fonctionne en Wifi, mais pas le scanner, qui fonctionne à condition d'être relié par câble USB.

Pour remarque, tout fonctionne très bien en WiFi sous la version la plus récente de Fedora.

Sous Tumbleweed, j'ai essayé de réinstaller hplib. Voici les messages que j'obtiens dans le fichier joint. Je soupçonne que le problème est une incompatibilité de versions :

Merci de votre aide.

René



Re : Tumbleweed et hplip

Répondre #1
Où avez vous récupéré cette version ? Celle des dépôts de Tumbleweed est 3.22.10-2.1, et elle fonctionne parfaitement.

Re : Tumbleweed et hplip

Répondre #2
Bonjour @René‍ :)
J'ai eu le même souci aujourd'hui après une mise à jour. L'imprimante fonctionnait, mais il n'y avait plus le scanner.
J'ai supprimé l'imprimante dans YaST et refait l'installation, j'ai opté pour hp-setup cette fois-ci.
En choisissant la configuration manuel et en indiquant l'ip de l'imprimante visible sur son écran de contrôle.
L'imprimante est maintenant reconnue ainsi que le scanner.
J'utilise hplip des dépôts officiels openSUSE Tumbleweed.
C'est la deuxième fois que ça m'arrive suite à une maj du système.

Re : Tumbleweed et hplip

Répondre #3
Bonjour Sobkowiak et bonjour Chalu,

Merci pour vos réponses et votre attention.

Devant l'insuccès du fonctionnement de hplip à partir du dépôt de Tumblewwed, je l'avais chargé à partir du site de HP en suivant la procédure indiquée. Sans aucun succès non plus.

Je viens de recommencer en utilisant Yast pour désinstaller hplip, le réinstaller et initialiser l'imprimante et le scanner. Ca ne fonctionne toujours pas.

Parmi les messages d'erreur j'ai noté ceci :

Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
qt.qpa.plugin: Could not find the Qt platform plugin "wayland" in ""
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.

J'ai lancé la commande :

$ echo QT_QPA_PLATFORM=wayland

Mais le résultat reste inchangé.

A noter que sous Fedora 38 qui fonctionne, la session est également une session wayland.

Re : Tumbleweed et hplip

Répondre #4
Le souci vient peut-être de Wayland, faites un essai avec Plasma.

Re : Tumbleweed et hplip

Répondre #5
Sur mon portable, c'est KDE et j'utilise Wayland.
Le message d'erreur semble indiquer qu'il manque des librairies QT.
ça ressemble à un vieux bug : https://forums.opensuse.org/t/qt-qpa-plugin-could-not-find-the-qt-platform-plugin-wayland-in/147950
As-tu libqt5-qtwayland installé ?

Edit : ceci dit, tu écris "parmi les messages d'erreurs", ce serait bien d'avoir tous les messages pour y voir clair ;)

Re : Tumbleweed et hplip

Répondre #6
Ce qui est étonnant c'est que Wayland fonctionne avec Tumbleweed et par avec Leap 15.4. En tout cas sur mon pc. J'avais aussi essayé d'installer la version 3.23 de Hplip, mais il y avait un tas de dépendances non résolues et non installables à moins de prendre le risque de casser le système.

Re : Tumbleweed et hplip

Répondre #7
Sur mon PC avec TW, je n'ai pas de dépôt externe et pas de souci de dépendances pour installer hplip.
D'ailleurs je ne l'ai pas réinstallé. En voyant que j'avais perdu le scanner, j'ai simplement supprimé mon imprimante pour la réinstaller dans YaST. Avec le scanner en USB, je n'avais jamais eu ce souci de "disparition" de scanner, ça doit être lié au wifi et au mises à jour de certains paquets du système. Heureusement, ça ne le fait pas à chaque maj !

Re : Tumbleweed et hplip

Répondre #8
Le problème vient uniquement de la version 3.23 de hplip, la 3.22 ne pose aucun souci et le jour où j'ai changé de fournisseur d'accès, j'ai tout simplement changé l'adresse ip de l'imprimante.