Aller au contenu principal
Sujet: > python 3.6 ? Quand ? (Lu 4518 fois) sujet précédent - sujet suivant

> python 3.6 ? Quand ?

Bonsoir,
Recemment passé sur 15.5, je retrouve le probleme similaire rencontré sur 15.4, avec Python.
Je dis bien similaire et non odentique ...
Python est en version 3.6 sur OpenSuse alors que la version courante est sur 3.12.3
Ce qui pourrait entrainer la question suivante:
pourquoi 3.11.9 sur Tumbelweed et que 3.6 sur OS15.5 ?
Deja que je suis en deuil de pas avoir pu reinstaller W$ alors soyez sympa :-)
Cdt
Ooo

Re : > python 3.6 ? Quand ?

Répondre #1
@scooter33 : Bonsoir,

Bon je n'y connais rien à Python mais jette un œil sur cette discussion :

https://forums.opensuse.org/t/opensuse-15-5-python-version/168719/4

Un intervenant a les deux versions. Je ne sais pas si ça peut poser un problème.

Maintenant si je regarde dans ma VM de Leap 15.6 RC, il y a une version 3.6.15 qui est installée et si je fais une recherche sur python311, je trouve une version 3.11.5 candidate à l'installation. Ce doit être sensiblement la même chose sur Leap 15.5.

Si tu trouves, ne désinstalle pas la 3.6 par contre. Elle n'est pas là par hasard. Enfin je ne saurais te dire comment bricoler pour bosser avec une version de Python plutôt qu'avec une autre.

Re : > python 3.6 ? Quand ?

Répondre #2
Il y a du python 3.12 sur Tumbleweed.

Re : > python 3.6 ? Quand ?

Répondre #3
Il y a du python 3.12 sur Tumbleweed.

oui j'ai vu ca
mais j'aimerai mieux etre sur la base que sur une virtuelle
et qui plus est, je n'ai pas reussi aujourd'hui a finir la maj de tumbelweed; ca plante en plein update... expulsion de la machine virtuelle complete.

Re : > python 3.6 ? Quand ?

Répondre #4
@scooter33 : Bonsoir,
Maintenant si je regarde dans ma VM de Leap 15.6 RC, il y a une version 3.6.15 qui est installée et si je fais une recherche sur python311, je trouve une version 3.11.5 candidate à l'installation. Ce doit être sensiblement la même chose sur Leap 15.5.
bonsoir,
ca ressemble a ce qui est sur OS15.5 en fait
j'ai bien ces deux versions (je n'ai vu la 3.11 qu'apres avoir utilisé zypper se) mais ca ne tape jamais sur la 3.11
L'inconnue finalement ca serait de savoir comment modifier pour avoir une utilisation de 3.11 par défaut et non de 3.6.. tout en gardant les deux pour la compatibilité, j'entends bien.

Re : > python 3.6 ? Quand ?

Répondre #5
Pourquoi as-tu besoin de la version 3.11 ?

 

Re : > python 3.6 ? Quand ?

Répondre #6
Pourquoi as-tu besoin de la version 3.11 ?
yt-dlp me demande de faire un update parce que non compatible avec 3.6
quand je veux faire l'update depuis le terminal il me dit que l'update se fait depuis la ou ca a ete installé.. donc depuis yast
et depuis yast c'est pas possible d'aller au dela de python 3.6
je commence a avoir le cerveau qui se fait des noeuds :-(