Aller au contenu principal
Messages récents
1
Matériel / Re : Imprimante Brother MFC-J1300DW
Dernier message par Longviauroy -
Bonjour et merci pour ces précisions.
L'installation semble bien se passer mais le problème c'est quand il y a la demande du type de connexion avec réponse Y/N. Si on répond Non, il n'y a pas d'autre information à saisir et ça ne fonctionne pas. Si on répond Yes, s'affiche alors une liste d'une quinzaine de configurations et là...j'avais un peu tout essayé sans succès, mais pas l'USB. Etant en réseau, il ne m'est pas venu à l'idée de choisir cette option.
Je vais donc réessayer.
En l'état, l'imprimante fonctionne bien, en revanche je ne suis pas convaincu par l'application Skanlite.
Sous Debian Buster, aucun problème et L'application Sane fonctionne parfaitement.
Je re-essayerai ce week-end.
Encore merci
2
Programmes et logiciels / Re : Quel logiciel dans les dépôts openSUSE pour assembler des pdf ?
Dernier message par sobkowiak -
Bonjour,

Même chose que squid-f ou Philoupes. Je m'arrange le plus souvent avec LibreOffice Draw ou encore pdftk.

Master PDF Editor (logiciel propriétaire) est très très bien mais en version gratuite, au bout de quelques temps, il laisse des tags partout et est limité. Ce qui fait que l'on doit passer à la version payante (78 € environ) si on veut continuer à l'utiliser.
L'usage avec Leap ne pose aucun souci mais avec Tumbleweed, le logiciel ne se lance pas et produit une erreur.
/opt/master-pdf-editor-5/masterpdfeditor5: symbol lookup error: /opt/master-pdf-editor-5/masterpdfeditor5: undefined symbol: _ZN10QMutexPool17globalInstanceGetEPKv
Comme on l'a compris, il n'est pas et ne sera pas dans les dépôts.


Il y a la même erreur avec Leap 15.1, aussi bien dans la version dépôt que la propriétaire. C'est pourquoi je préconisais une version plus ancienne qui, elle, fonctionne.
3
Matériel / Re : formatage de clé USB
Dernier message par sobkowiak -
Citer
je n'ai pas trouvé Erase disk sur mon Gparted qui date de 2012... J'ai probablement mal cherché
J'ai  la version 2018, mais Erase disk (ou tout simplement Erase) figure bien sur le bureau sous la forme d'une gomme rouge et blanche. Il était aussi présent sur les versions précédentes. On le trouve aussi par le menu, mais je ne me souviens plus dans quelle catégorie.
4
Programmes et logiciels / Re : Mise à jour paquets
Dernier message par val03 -
Je n'ai jamais utilisé KDE.
J'ai xfce 4.14 sur Tumbleweed mais le mettre sur Leap je ne vais pas m'y aventurer maintenant  :D ou alors en machine virtuelle

Je vais tester yast en console ça peut être cool.

A cette instant j'ai Package Update Indicator qui me propose des mise à jour, ça na rien à voir avec Yast il me semble? Savoir ce que c'est
5
Programmes et logiciels / Mettre à jour ses dépôts
Dernier message par manchette -
Je vous partage une méthode qui je l'espère pourra aider en cas d'incohérences rencontrées sur votre machine.


Recherche du dépôt maudit en cas de soucis avec des dépôts non stables :


"Elle va marcher beaucoup moins bien forcément…" 

Ca marchait très bien … et puis un jour    BAM, Patatra ... rien ne va pas plus, voir typiquement cette scène mythique :

https://www.youtube.com/watch?v=lgCiVQ7gaLw


Je suis sûr que si vous êtes en train de lire ceci c’est que vous avez l’esprit curieux (si , si, au moins un peu, ...voir beaucoup) ⇒ du coup vous avez certainement envie (voir besoin ?) de tester pleins de logiciels ou environnements variés liés a vos loisirs ou a votre travail…

Alors il va vous falloir apprendre à lutter contre cette envie irrésistible d’ajouter des dépôts sans précaution préalable en attribuant une priorité à vos dépôts.

En cas d’incohérences constatées ou erreurs étranges :

La gestion des dépôts peut amener des incohérences dans les paquets.
A terme les incohérences peuvent entraîner diverses anomalies.

Exemples :
- j’ai fait une mise à jour et plus rien ne marche ...
Hé oui ... ca marchait avant, avant que ca ne marche plus, ca nous est tous arrivé (...forcément un jour ça va marcher beaucoup moins bien :D).
- Incohérences dans les versions des paquets
- Erreur de type d’utilisateur 
- ou encore interface graphique qui clignote dans kde …

Pour éviter ces ennuis voici les bonnes pratiques :

Phase 1 : Essayer de limiter au maximum le nombre de dépôts.

Phase 2 : Apprendre à bien gérer les éventuels ajouts : ou comment limiter la casse et retomber sur ses pieds si besoin.



mon test, si c'était pour moi :

   1- passer tous les repos dans /etc/zypp/repos.d à disabled (désactivé), sauf oss/non-oss/oss-update/non-oss-update (et kernel-latest si il y a du hardware récent sur ce laptop/cette machine).

Cela peut se faire par exemple via Yast/logiciels/ dépôts de logiciels.

(Les priorités seront à 99. Autre exemple possible : 100 pour oss et non-oss, 99 pour oss-update et non-oss-update et 110 pour le noyau)

   2- lancer 'zypper dup'
(ctrl+alt+F1 se connecter comme root, et lancer zypper ref && zypper dup)

   3- attendre... et rebooter (j'utilise shutdown -r now, on peut utiliser reboot)

   4- regarder les logs, si besoin  (quels logs? Voir * NB ci-dessous) --> d'après moi tout devrait être ok



* NB :
En général, comme le problème de base est "bien visuel" (ex: un crash ?), il n'y a peut-être même pas besoin de log :=)
Mais si besoin :
Les « logs » sont un enregistrement des traces liées au fonctionnement du système, ils permettent de retrouver certaines anomalies en fonction de qui écrit dans quoi  :

 - au niveau systeme:  journalctl -f

 - si il reste des applications graphiques qui écrivent dans le log legacy/déprécié (?):
tail -f $HOME/.xsession-errors



   5- passer tous les autres repos en enabled (activé) , SAUF ceux qui concernent gnome/kde/autre système interface graphique utilisateur, et avec une priorité inférieure à 99 (en laissant un trou pour 98 et 97)

   6- lancer zypper dup pour appliquer les dépendances en fonction des priorités choisies

   7- attendre... et rebooter

   8- regarder les logs   --> d'après moi tout devrait être ok


   9- insérer UN par UN les repos qui concernent gnome ou votre interface graphique préférée, avec une priorité entre 99 et celle des autres repos déjà activés --> utiliser le "trou" 98 et 97....

   10- lancer zypper dup pour appliquer les dépendances en fonction des priorités choisies

   11- attendre... et rebooter

   12- regarder les logs  --> d'après moi les problèmes devraient ré-apparaître

   13- couper les branches pourries, contacter le mainteneur du repo, pester sur ceux qui polluent gnome (ou autre interface graphique) à cause de leur distro qui a tout cassé en mode "f**k, it works on my machine", etc, ...
( = car ca marche chez eux ils ne pensent pas aux autres utilisateurs qui ont une autre config, une autre interface graphique par exemple. Voir pire forcent leurs fonctionnements propres et autres bidouilles internes, pour amener les autres à fonctionner idem … )

exemple :
avec le kde officiel (rien de "latest" dans mes repos car je veux un
truc stable pour travailler), mon laptop/appareil fonctionne (...pour le moment :D ;=) )


- - - si vous n'avez pas ajouté de dépôt exotique (hors de ceux de base), le système sera remis à jour de façon cohérente.
Après le dup le système devrait revenir à la normale. Mais alors il vient d'où le bug ?
Hé bien là il faudra creuser au cas par cas... selon la configuration, le pépin et le besoin.


- - - quid du dépôt pourri important et "impossible" à couper ? : genre pour kde frameworks, ou qt5 ... (je ne connais pas les dépôts gnome importants).
Peut être faudra t'il accepter  (temporairement ? ) de façon de faire, et tourner avec les 4 dépôts originaux ? (oss, non oss et updates)



Si besoin était de trouver d’autres pistes :
Rassurez vous : vous n’êtes pas seul, et ni le premier, ni le dernier à qui ce problème est arrivé.
Il y a donc de bonnes chances qu’une recherche internet puisse pour donner de sérieuses pistes de solution(s). Utilisez un moteur de recherche et cherchez l’erreur rencontrée.
6
Programmes et logiciels / Re : Mise à jour paquets
Dernier message par manchette -
Xfce ca fait un moment que je n'ai pas essayé, mais tu peut aussi le mettre à jour j'imagine.

- Via les dépôts opensuse :
il semble que se soit dispo selon https://news.opensuse.org/2019/08/23/xfce-4-14-lands-in-tumbleweed/
Les dépots sont ici :
 https://en.opensuse.org/Xfce_repositories


- A la main, il faut tout faire mais en théorie ca peut fonctionner : https://xfce.org/download



Ce n'est pas forcément mieux en console, c'est une autre façon de faire, très puissante, selon le besoin et usages que tu as.






Pour les mises à jour de logiciels via yast : https://fr.opensuse.org/YaST_Software_Management

Tu peut aussi t'amuser à tester yast en console (mode texte) : https://fr.opensuse.org/SDB:Starting_YaST
, très utile quand ca plante :)

7
Matériel / Re : formatage de clé USB
Dernier message par Pascal -
Bonjour

Attention FAT32 ne permet pas les fichiers de plus de 4 Gio, le mieux pour une clé c'est exFat qui n'a pas cette limite.

Les paquets pour exFat ne sont pas installés par défaut sur openSUSE.

Les deux paquets a installer.

S  | Nom         | Résumé                                | Type  
---+-------------+---------------------------------------+-------
i+ | exfat-utils | Utilities for exFAT file system       | paquet
i+ | fuse-exfat  | Free exFAT file system implementation | paquet
8
Programmes et logiciels / Re : Mise à jour paquets
Dernier message par val03 -
Salut !!!

Merci de ta réponse je confondais dup et up lol

Pour l'instant je n'ai plus de mise a jour à faire, je testerai quand il y en aura d'autre.

Cependant avant de faire zypper dup j'ai étais dans Yast logiciels, installer supprimer des logiciels et il y avait rien. Une fois dans  installer supprimer des logiciels comment faire pour faire des mises à jour ? Faut-il aller dans configuration, mise à jour en ligne (si je vais dessus il me dit d'installer yast2-online-update-configuration) ? Désole je ne connais pas Yast.

J'ai utilisé ta commande : zypper --non-interactive remove --clean-deps logiciel (ristretto) pour essayer et ça ne se réinstalle pas. merci  :)
Pour désinsller les logiciel j'utilise Yast et souvent il me met une fenêtre avertissement avec 3 choix : désinstallation, conserver ou casser. j'utilise désinstallation. ou sinon je fais zypper remove logiciel. c'est mieux de le faire en console?
Je suis les commande depuis cette page
https://www.linuxtricks.fr/wiki/rosetta-tableau-comparatif-des-outils-urpm-yum-zypper-emerge-et-apt

Au début je voulais utiliser Leap 15.1 mais XFCE est en 14.2 et non pas en 14.4.
9
Programmes et logiciels / Re : Mise à jour paquets
Dernier message par manchette -
Hello ;=)

Tu as le choix : via yast ou via la console, passe plutôt par yast au départ.

Avec yast tu vas dans logiciels, installer supprimer des logiciels.

Pour leap pour mettre à jour les logiciels tu utilises en console :
zypper refresh
zypper up


(dup est aussi utilisable pour Leap, d'où la confusion peut être :
1-Pour passer de leap n à n+1 , exemple en mai sortira la leap 15.2 : là on utilisera zypper dup. Il y a une procédure à respecter ; mais il ne faut pas confondre avec l'usage quotidien de mise à jour des logiciels.
2-Par ailleurs pour remettre en cohérence le système si besoin)


mais pour Tumbleweed le fonctionnement est différent : distribution upgrade (dup) et non up :
zypper refresh
zypper dup.



Si tu utilises ceci pou un logiciel donné ca se réinstalle aussi ?
zypper --non-interactive remove --clean-deps logiciel
10
Programmes et logiciels / Re : Downgrade de paquet ? Possible ?
Dernier message par manchette -
Salut ;=)

Il y a une mode de la rolling release qui fait que l'on veut tester, c'est logique et je comprends tout à fait ce mouvement, notamment pour avoir le dernier truc en date.
Après peut être y  a t'il de vrais besoins derrière et là ca aide vraiment, mais il faut voir les risques d'instabilités potentielles ;)
(dégâts collatéraux ?)