Aller au contenu principal
Sujet: OpenSUSE Leap 15.3 et la famille chrome (Lu 734 fois) sujet précédent - sujet suivant

OpenSUSE Leap 15.3 et la famille chrome

Salut la communauté,
depuis une mise à jour globale récente de ma distribution OpenSUSE Leap 15.3, toute la famille des navigateurs *chrome* est affectée d'un mal étrange.

A la base je suis un utilisateur de Vivaldi mais pour vérifier j'ai installé Google Chrome et Chomium et toutes ont le même comportement.

Désormais, lorsque l'un de ces navigateurs essaye d'ouvrir une boite de dialogue (CTRL+S par exemple pour sauver une page) et bien la fenêtre de la boîte de dialogue s'ouvre pendant 1 seconde environ puis se ferme toute seule après. Le phénomène est reproductible sur n'importe lequel des navigateurs cités ci-dessus. Ma distribution est bien sûr à jour. J'ai vu sur un forum Vivaldi qu'un utilisateur avait déjà posté quelque chose de similaire (ce qui me laisse à penser que le problème n'affecte pas que mon installation).

Auriez-vous constater quelque chose de similaire, y aurait-il une piste à explorer pour corriger ce problème ?

NB : Firefox lui ne souffre pas du dit problème mais je ne souhaite pas tout basculer sous Firefox, j'aimerais retrouver l'usage du navigateur Vivaldi.

Merci à tous et bonne soirée.

Cordialement,
Franck

Re : OpenSUSE Leap 15.3 et la famille chrome

Répondre #1
Salut
Pour ma part, je viens de faire un essai et je n'ai aucun soucis avec vivaldi sur leap à jour.
Mais désolé, je n'ai pas de solution ni d'idée.
Qu'est-ce qui était dit sur le forum de vivaldi ?

Re : OpenSUSE Leap 15.3 et la famille chrome

Répondre #2
Merci pour ta réponse C2G9.

Oups, j'ai honte, c'est pas bien, je n'était pas retourné aujourd'hui voir le forum Vivaldi aujourd'hui.
Alors, pour préciser, j'utilise l'environnement Gnome et si tu utilises KDE (ou un autre environnement), c'est peut-être pour ça que tu n'as pas eu le problème.

Voici le lien du forurm Vivaldi concernant ce problème : https://forum.vivaldi.net/topic/70577/vivaldi-crashes-download-dialog

Au final, il semble que le problème vienne bien d'une mise à jour des paquets xdg-desktop-portal-gtk et xdg-desktop-portal-gtk-lang.
Le seul contournement actuel serait de "downgrader" ces paquets à une version précédente et de faire un zypper lock dessus en attendant un correctif définitif pour ne plus qu'ils se mettent à jour.

Je vais essayer ça et je posterai dans le forum, cela pourra peut-être servir à dépanner d'autres utilisateurs.

Re : OpenSUSE Leap 15.3 et la famille chrome

Répondre #3
Bonsoir, et bien je viens de faire le test et le problème vient bien de ces paquets.

Avec la commande suivante, on peut "downgrader" vers la version inférieure et le problème des boîtes de dialogue disparaît sur chrome, chromium et vivaldi. Si cela peut aider quelqu'un, voici les commandes à passer :

# zypper install --oldpackage xdg-desktop-portal-gtk=1.8.0-3.3.1 xdg-desktop-portal-gtk-lang=1.8.0-3.3.1
# zypper addlock xdg-desktop-portal-gtk xdg-desktop-portal-gtk-lang

Il restera a surveiller une mise à jour de ces paquet dans une version supérieure à 1.8.0-3.6.1

Re : OpenSUSE Leap 15.3 et la famille chrome

Répondre #4
Je suis bien avec KDE et xdg-desktop-portal-gtk et xdg-desktop-portal-gtk-lang sont tous deux installés sur mes machines. Et aucun soucis. Donc ça vient probablement bien de gnome mais avec une "subtilité" en plus. Bizarre …
Le principal est que ça fonctionne !

Re : OpenSUSE Leap 15.3 et la famille chrome

Répondre #5
Oui, effectivement c'est curieux surtout si la version de tes paquets est 1.8.0-3.6.1. Le diable se cache toujours dans les détails  :D
Merci pour ton intérêt à mon soucis en tout cas.

Re : OpenSUSE Leap 15.3 et la famille chrome

Répondre #6
Comme tu vois :
Informations sur paquet xdg-desktop-portal-gtk :
------------------------------------------------
Dépôt                     : Update repository with updates from SUSE Linux Enterprise 15
Nom                       : xdg-desktop-portal-gtk
Version                   : 1.8.0-3.6.1
Architecture              : x86_64
Fabricant                 : SUSE LLC <https://www.suse.com/>
Taille une fois installé  : 750,8 KiB
Installé                  : Oui (automatiquement)
État                      : à jour
Paquet source             : xdg-desktop-portal-gtk-1.8.0-3.6.1.src
Résumé                    : Backend implementation for xdg-desktop-portal using GTK+
Description               :
    A backend implementation for xdg-desktop-portal that is using GTK+ and
    various pieces of GNOME infrastructure, such as the org.gnome.Shell.Screenshot
    or org.gnome.SessionManager D-Bus interfaces.


Informations sur paquet xdg-desktop-portal-gtk-lang :
-----------------------------------------------------
Dépôt                     : Update repository with updates from SUSE Linux Enterprise 15
Nom                       : xdg-desktop-portal-gtk-lang
Version                   : 1.8.0-3.6.1
Architecture              : noarch
Fabricant                 : SUSE LLC <https://www.suse.com/>
Taille une fois installé  : 92,4 KiB
Installé                  : Oui (automatiquement)
État                      : à jour
Paquet source             : xdg-desktop-portal-gtk-1.8.0-3.6.1.src
Résumé                    : Translations for package xdg-desktop-portal-gtk
Description               :
    Provides translations for the "xdg-desktop-portal-gtk" package.
Il doit y avoir quelque chose dans gnome qui fait qu'il y ait un bug avec xdg-desktop-portal-gtk et xdg-desktop-portal-gtk-lang

Re : OpenSUSE Leap 15.3 et la famille chrome

Répondre #7
oui,je confirme,étant sur gnome, j'ai le même bug sous chromium, que je n'utilise quasiment jamais...


Re : OpenSUSE Leap 15.3 et la famille chrome

Répondre #9
Citer
Désormais, lorsque l'un de ces navigateurs essaye d'ouvrir une boite de dialogue (CTRL+S par exemple pour sauver une page) et bien la fenêtre de la boîte de dialogue s'ouvre pendant 1 seconde environ puis se ferme toute seule après. Le phénomène est reproductible sur n'importe lequel des navigateurs cités ci-dessus. Ma distribution est bien sûr à jour. J'ai vu sur un forum Vivaldi qu'un utilisateur avait déjà posté quelque chose de similaire (ce qui me laisse à penser que le problème n'affecte pas que mon installation).
Auriez-vous constater quelque chose de similaire, y aurait-il une piste à explorer pour corriger ce problème ?


Bonjour,
Exactement le même problème  ici avec Leap 15.2 KDE.
et Vivaldi   5.0.2497.38 (Stable channel) stable (64 bits)
Révision   7c6d0949a1c049b97a691a81fdca00bac12f60db

Pas de probème avec d'autres navigateurs, Firefox, Opera, Dissenter, Chrome.

Re : OpenSUSE Leap 15.3 et la famille chrome

Répondre #10
opera même problème

Re : OpenSUSE Leap 15.3 et la famille chrome

Répondre #11
problème réglé via maj xdg aujourd'hui sur leap. vous pouvez maquer le sujet comme résolu si c'est bon également pour vous.