Aller au contenu principal
Sujet: Zypper : Plusieurs questions a propos des dépôts... (Lu 425 fois) sujet précédent - sujet suivant

Zypper : Plusieurs questions a propos des dépôts...

Chers zamis,

Hier ou avant hier j'essaie de faire une petite mise à jour avec mon TW et j'ai le message d'erreur non bloquant ci-dessous :
Alienware:~ # zypper dup
Retrieving repository 'home:zawel1:gstreamer' metadata ..............................................................................[error]
Repository 'home:zawel1:gstreamer' is invalid.
[https-download.opensuse.org-73492db5|https://download.opensuse.org/repositories/home:/zawel1:/gstreamer/openSUSE_Tumbleweed/] Valid metadata not found at specified URL
History:
 - [https-download.opensuse.org-73492db5|https://download.opensuse.org/repositories/home:/zawel1:/gstreamer/openSUSE_Tumbleweed/] Repository type can't be determined.

Please check if the URIs defined for this repository are pointing to a valid repository.
Warning: Skipping repository 'home:zawel1:gstreamer' because of the above error.
Some of the repositories have not been refreshed because of an error.
Je sais ... C'est le mal d'utiliser des dépôts non officiel et honnêtement ... Je ne me rappelle vraiment plus pourquoi j'avais basculé gtreamer sur ces dépôts... (pas taper... :o )
Bref, j'ai plusieurs questions :
- Comment savoir si ce dépôt est définitivement "mort" (j'ai attendu en me disant c'est juste un problème ponctuel)
- Comment savoir en ligne de commande quels packages sont sur "tel" dépôts par exemple ... ?
- Comment savoir s'il va pas y avoir des effets de bord délétères lors des changements ?
Merci d'avance pour vos réponses
Philippe
PS : Y a pas vraiment d'urgence car ça n'a pas bloqué les mises à jour, juste les packages de ce dépôt ne se mettent pas a jour... Et pour l'instant, aucune conséquences.

Re : Zypper : Plusieurs questions a propos des dépôts...

Répondre #1
Salut :)

La page du mainteneur n'existe plus sur l'Open Build Service (404 not found) :

https://build.opensuse.org/package/show/home%3Azawel1%3Agstreamer/gstreamer-0_10-plugins-base

Tu peux donc éliminer ce dépôt et récupérer ensuite les paquets gstreamer par le dépôt packman.

Yast  peux te lister une liste de logiciels installés par dépôt.


à plus,
oh!rocks

Re : Zypper : Plusieurs questions a propos des dépôts...

Répondre #2
Salut @oh!rocks
Merci pour ta réponse.
Je suis allé dans Yast regarder et c'est un peu le "bordel" ... j'ai des paquet de gstreamer qui sont rattaché a OSS, d'autre à ce dépôt et d'autres a un autre dépôt perso... Et ... ça fonctionne quand même.
--
Ce qui me gène le plus c'est que lorsque je regarde les 3 packets qui sont rattachés au dépôt qui est décédé (Azawe1) il n'y a pas d'alternative pour choisir un autre dépôt (c'est en rouge dans Yast)
Si je zigouille le dépôt en question, comment je fais pour rapatrier les packages qui étaient sur ce dépôt ?
Je dois les désinstaller avant (avec la cascade de désinstallation qui vient avec...) ou une fois le dépôt zigouillé j'aurais la possibilité de changer les dépots des package susmentionnée ?
...
Je sais pas si j'ai été clair dans mon exposé ... Pas certain... :o
Amicalement
Philippe

Re : Zypper : Plusieurs questions a propos des dépôts...

Répondre #3
En utilisant Yast, recherchez le paquet Gstreamer concerné, et cliquez sur "version". Vous aurez la liste des versions dont celle de Packman si le dépôt est installé. Il suffit de cocher cette version et faire de même pour tous les paquets concernés, en  n'oubliant pas évidemment de cliquer sur "Accepter".

Re : Zypper : Plusieurs questions a propos des dépôts...

Répondre #4
Bonsoir @sobkowiak ,

Justement je me suis mal exprimé mais ce que je voulais dire dans "pas d'alternative" c'est que lorsque je regarde les versions il n'y en a pas d'autre...
Cf. la copie d'écran ci-joint.
Amicalement
Philippe

Re : Zypper : Plusieurs questions a propos des dépôts...

Répondre #5
Perso, je tenterais de désinstaller les gstreamer du dépôt HS pour voir justement quelles dépendances sont concernées.

Il y a peu de risques que ça mette à mal ton système.

Note ces éventuelles dépendances puis supprime les gstreamer en question, puis le dépôt HS  puis zypper ref puis réinstalle les éventuelles dépendances.

N'oublie pas de cocher Options > Nettoyage lors de la suppression dans YaST.

Sur ma Tumbleweed, la collection de gstreamer provient du dépôt OSS.


à plus,
oh!rocks

Re : Zypper : Plusieurs questions a propos des dépôts...

Répondre #6
On trouve une version dans "Main Repository". Vous n'avez pas ce dépôt ?

Re : Zypper : Plusieurs questions a propos des dépôts...

Répondre #7
Bonsoir @sobkowiak
Heuuu... C'est quoi l'URL de ce dépôt ?
ça me dit rien non...
Amcalement
Philippe

Re : Zypper : Plusieurs questions a propos des dépôts...

Répondre #8
Bonsoir @oh!rocks
J'ai fait ça et effectivement il ne semble s'être rien passé de vraiment gênant ... Mais j'ai pas tout testé mes logiciels depuis...
Mais, les packages sont toujours en rouge dans Yast
Amicalement
Philippe


Perso, je tenterais de désinstaller les gstreamer du dépôt HS pour voir justement quelles dépendances sont concernées.

Il y a peu de risques que ça mette à mal ton système.

Note ces éventuelles dépendances puis supprime les gstreamer en question, puis le dépôt HS  puis zypper ref puis réinstalle les éventuelles dépendances.

N'oublie pas de cocher Options > Nettoyage lors de la suppression dans YaST.

Sur ma Tumbleweed, la collection de gstreamer provient du dépôt OSS.


à plus,
oh!rocks

Re : Zypper : Plusieurs questions a propos des dépôts...

Répondre #9
Heuuu... C'est quoi l'URL de ce dépôt ?
Si vous êtes sur Tumbleweed, effectivement, il ne figure pas dans les dépôts, par contre on trouve gstreamer-base dans le dépôt Opensuse-Tumbleweed et Opensuse-Tumbleweed-Oss. Je viens de le vérifier sur ma version de Tumbleweed installée sur VBox où Gstreamer-base à une m-à-j vers 1.20.4-1.1

Re : Zypper : Plusieurs questions a propos des dépôts...

Répondre #10
- Comment savoir s'il va pas y avoir des effets de bord délétères lors des changements ?

À partir de maintenant, pour ceux ne lisant pas l'anglais → https://translate.google.com/?hl=fr&sl=en&tl=fr&op=translate

Les deux options suivantes permettent selon le "man zypper" de déminer.
J'ai déjà testé --dry-option tout seul (sans --download-only), ça marche très bien.
Citer
Package File Conflicts
       File conflicts happen when two packages attempt to install files with the same name but different contents. This may happen if you are installing a newer
       version of a package without erasing the older version, of if two unrelated packages each install a file with the same name.

       As checking for file conflicts requires access to the full filelist of each package being installed, zypper will be able to check for file conflicts only if all
       packages are downloaded in advance (see --download-in-advance). If you are doing a --dry-run no packages are downloaded, so the file conflict check will skip
       packages not available in the packages cache. To get a meaningful file conflict check use --dry-run together with --download-only.

       As the reason for file conflicts usually is a poor package design or lack of coordination between the people building the packages, they are not easy to
       resolve. By using the --replacefiles option you can force zypper to replace the conflicting files. Nevertheless this may damage the package whose file gets
       replaced.

-D, --dry-run
               Test the installation, do not actually install any package. If used together with --download-only a meaningful file conflict check can be performed (see
               section Package File Conflicts).

-d, --download-only
               Only download the packages for later installation (see also the global --pkg-cache-dir option).

               If used together with --dry-run a meaningful file conflict check can be performed (see section Package File Conflicts).

Re : Zypper : Plusieurs questions a propos des dépôts...

Répondre #11
Bonjour,

Toujours ennuyé par des dépôts qui semblent ne plus exister...
J'ai deux dépôts non officiels qui merdent depuis quelques jours et je veux savoir si j'ai effectivement des packages qui en dépendent afin de changer le dépôts si oui.
Par exemple :
Repository 'home:KGronlund:keyring' is invalid.
[http-download.opensuse.org-7672a585|http://download.opensuse.org/repositories/home:/KGronlund:/keyring/openSUSE_Tumbleweed/] Valid metadata not found at specified URL
History:
 - [http-download.opensuse.org-7672a585|http://download.opensuse.org/repositories/home:/KGronlund:/keyring/openSUSE_Tumbleweed/] Repository type can't be determined.
J'ai vérifié sur le net et y a plus rien sous cette URL sans annonce aucune dans le site Opensuse.

Du coup, ma question :  Existe il une commande avec Zypper qui permet de lister les packages installés sous un dépôt spécifique ? (j'ai pas trouvé)

Merci pour l'aide
Philippe

 

Re : Zypper : Plusieurs questions a propos des dépôts...

Répondre #12
Du coup, ma question :  Existe il une commande avec Zypper qui permet de lister les packages installés sous un dépôt spécifique ?

Bonjour Philoupes,

tout se trouve dans la section Query Commands de zypper, et dans deux sous-section search (se) [options] [querystring|capability]... et packages (pa) [options] [repository]....

une solution:
zypper se --installed-only --repo "alias|name|#|URI"

où alias|name|#|URI correspond à une des colonne quand tu listes tes dépôts avec la commande:
zypper lr -u

alias → un surnom
name → le nom
# → un N°
URI → une URI.

Exemple:
thierry@toto-PC:~> zypper se --installed-only --repo "Packman Repository"
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                           | Summary                                                          | Type
---+--------------------------------+------------------------------------------------------------------+------
i  | autopano-sift-C                | SIFT Feature Detection implementation                            | Paket
i+ | chromium-ffmpeg-extra          | Google's open source browser project                             | Paket
i  | ffmpeg-4                       | Set of libraries for working with various multimedia formats     | Paket
i+ | flash-player                   | Adobe Flash Standalone Player                                    | Paket
i+ | gstreamer-plugins-bad-codecs   | Codecs/plugins for gstreamer-plugins-bad                         | Paket


en plus court:
zypper se -i -r "Packman Repository"
ou encore
zypper se -ir "Packman Repository"

Deuxième solution (avec une légère différence):

zypper pa --installed-only "Packman Repository"
sinon zypper pa -i "Packman Repository"

Exemple:
(regarde la paquet libheif1)
thierry@toto-PC:~> zypper pa --installed-only "Packman Repository"
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...
S  | Repository         | Name                           | Version                              | Arch
---+--------------------+--------------------------------+--------------------------------------+-------
i  | Packman Repository | autopano-sift-C                | 2.5.1-pm154.3.2                      | x86_64
i+ | Packman Repository | chromium-ffmpeg-extra          | 103.0.5060.114-pm154.1.2             | x86_64
i  | Packman Repository | ffmpeg-4                       | 4.4-pm154.2.8                        | x86_64
i+ | Packman Repository | flash-player                   | 32.0.0.465-pm154.3.1                 | x86_64
i+ | Packman Repository | gstreamer-plugins-bad-codecs   | 1.20.1-pm154.2.3                     | x86_64
i+ | Packman Repository | gstreamer-plugins-ugly-codecs  | 1.20.1-pm154.1.4                     | x86_64
i+ | Packman Repository | libavcodec57                   | 3.4.9-pm154.1.12                     | x86_64
i  | Packman Repository | libavcodec58_134               | 4.4-pm154.2.8                        | x86_64
i+ | Packman Repository | libavdevice57                  | 3.4.9-pm154.1.12                     | x86_64
i  | Packman Repository | libavdevice58_13               | 4.4-pm154.2.8                        | x86_64
i+ | Packman Repository | libavfilter6                   | 3.4.9-pm154.1.12                     | x86_64
i  | Packman Repository | libavfilter7_110               | 4.4-pm154.2.8                        | x86_64
i+ | Packman Repository | libavformat57                  | 3.4.9-pm154.1.12                     | x86_64
i  | Packman Repository | libavformat58_76               | 4.4-pm154.2.8                        | x86_64
i+ | Packman Repository | libavresample3                 | 3.4.9-pm154.1.12                     | x86_64
i+ | Packman Repository | libavresample4_0               | 4.4-pm154.2.8                        | x86_64
i+ | Packman Repository | libavutil55                    | 3.4.9-pm154.1.12                     | x86_64
i  | Packman Repository | libavutil56_70                 | 4.4-pm154.2.8                        | x86_64
i+ | Packman Repository | libdca0                        | 0.0.7-pm154.1.4                      | x86_64
i  | Packman Repository | libde265-0                     | 1.0.8-pm154.1.3                      | x86_64
i  | Packman Repository | libfaac0                       | 1.30-pm154.1.4                       | x86_64
i+ | Packman Repository | libfaad2                       | 2.10.0-pm154.1.4                     | x86_64
i  | Packman Repository | libfdk-aac2                    | 2.0.2-pm154.1.3                      | x86_64
v  | Packman Repository | libheif1                       | 1.12.0-pm154.11.2                    | x86_64
i  | Packman Repository | liblsmash2                     | 2.14.5-pm154.1.4                     | x86_64

Il y a un 'v' dans la première colonne correspondant au paquet 'libheif1', il ne figurait pas dans le sortie de la commande ' zypper se -ir "Packman Repository" '. Ce 'v' indique que le paquet 'libheif1' est présent dans le dépôt "Packman Repository", mais que le paquet 'libheif1' d'installé ne vient pas de ce dépôt.
Il vient en l'occurrence chez moi du dépôt "Update repository with updates from SUSE Linux Enterprise 15":
(ici il faut regarder le 'i' :) )
thierry@toto-PC:~> zypper se --details libheif1
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S | Name               | Type  | Version             | Arch   | Repository
--+--------------------+-------+---------------------+--------+-------------------------------------------------------------
v | libheif1           | Paket | 1.12.0-pm154.11.2   | x86_64 | Packman Repository
i | libheif1           | Paket | 1.12.0-150400.3.3.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
v | libheif1           | Paket | 1.12.0-150400.1.10  | x86_64 | Haupt-Repository
  | libheif1-32bit     | Paket | 1.12.0-150400.3.3.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
  | libheif1-32bit     | Paket | 1.12.0-150400.1.10  | x86_64 | Haupt-Repository
  | libheif1-debuginfo | Paket | 1.12.0-pm154.11.2   | x86_64 | Packman Repository
ou encore 'zypper se -s libheif1'.

En résumé:
La première solution te liste tous les paquets d'installés et provenant d'un dépôt spécifique.

La deuxième solution te liste tous les paquets d'installés tels que leur nom figure dans un dépôt spécifique, mais pas forcément leur provenance, le fameux 'v'…

Remarque:
il y a peut-être d'autres possibilités…

J'espère ne pas avoir dit trop d'âneries ou d'Anne-Marie comme dirait l'autre.