Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Tumbleweed : impossible de supprimer un paquet (Lu 116 fois) sujet précédent - sujet suivant

Tumbleweed : impossible de supprimer un paquet

Bonjour

Je fais une maj d'une résolution de bug trouvé sur l'ancien Forum.

Lors de la mise à jour de Trumbleweed, j'obtiens le message suivant:
Les 4 paquets suivants vont être SUPPRIMÉS : 
  chromium             78.0.3904.87-1.1
  NetworkManager       1.18.4-1.1      
  NetworkManager-lang  1.18.4-1.1      
  typelib-1_0-NM-1_0   1.18.4-1.1      
 
4 paquets à supprimer.
Après l'opération, 307,6 MiB d'espace disque sera libéré.
Continuer ? [o/n/v/...? affiche toutes les options] (o): 
(1/4) Suppression de NetworkManager-1.18.4-1.1.x86_64 .....................................[erreur]
Échec de la suppression de (234106)NetworkManager-1.18.4-1.1.x86_64(@System) :
Erreur: Subprocess failed. Error: Échec RPM : error: package NetworkManager-1.18.4-1.1.x86_64 is not installed                                                
                                                                                                                                                              
Abandonner, réessayer, ignorer ? [a/r/i] (a): a
Un problème s'est produit pendant ou après l'installation ou la suppression des paquets :
L'installation a été abandonnée comme demandé.                                                                                                                
Veuillez consulter le message d'erreur ci-dessus pour une indication.

Finalement, il s'agit d'un problème de corruption de la base de données rpm, qui peut se résoudre par:

sudo rpm --rebuilddb

Voilà si ça peut aider, ça a permis de résoudre mon bug.

 

Re : Tumbleweed : impossible de supprimer un paquet

Répondre #1
Merci du retour :)