Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Installation imprimante Canon I-Sensys (Lu 841 fois) sujet précédent - sujet suivant

Installation imprimante Canon I-Sensys

Bonjour à toutes et tous

J'ai une imprimante Canon I-Sensys MF633Cdw utilisant le driver UFR-II
https://www.canon.fr/support/consumer_products/products/fax__multifunctionals/laser/laserbase_mf_series/i-sensys_mf633cdw.html?type=drivers&language=fr&os=linux%20(64-bit)

Le script d'installation de Canon du pilote n'est que compatible avec les formats DEB et RPM. Je cherche donc une version pour Opensuse.
Je n'ai rien trouvé dans YasT ou en ligne dans Opensuse software.

Est-ce que quelqu'un a déjà installé ce type d'imprimante avec Opensuse ?

Merci pour vos lumières!

A+

Re : Imprimante Canon I-Sensys

Répondre #1
openSuSE c'est du rpm, tu peux installer un rpm avec sudo rpm -i ***.rpm

par contre j'ai déjà installer une imprimante canon, sur openSuSE, il faut un peu bidouiller mais sa fonctionner.

David

 

Re : Imprimante Canon I-Sensys

Répondre #2
Merci @david

Comme j'utilise zypper et non rpm, je pensais que c'était différent !
J'essaye et je vous tiens au courant.

A+

Re : Imprimante Canon I-Sensys

Répondre #3
Re-

cela a avancé mais ce n'est pas encore bon....
Pour exécuter le script d'installation de Canon en utilisant les paquets RPM, j'ai dû installer la commande dnf et y ajouter une liste de dépots
zypper in dnf
cp /etc/zypp/repos.d/* /etc/dnf/repos.d

Le script veut bien alors s'exécuter mais il se plaint de bibliothèques système qui pourraient ne pas être installées.
C'est vrai que pour essayer d'être certain que toutes les dépendances soient installées, j'ai dû installer manuellement : libbeecrypt-devel et jbigkit.
Mais l'installation se finit quand même par : Installation impossible... Cependant l'installation de l'imprimante (sur port usb) se passe bien avec Yast. Je lance l'impression d'une page test, l'imprimante s'active, une page sort de l'imprimante  :)  mais rien n'est imprimé dessus  :'(
Le plus gros écart que je vois est que j'ai installé jbigkit au lieu de jbigkit-libs demandé par le script.

Voici le résultat du script d'installation (lancé une deuxième fois car je n'avais pas sauvegardé la première fois.....) :
#----------------------------------------------------#
# Install Start
#----------------------------------------------------#
Machine Type = x86_64
Package Type = rpm
Package list =
    ./64-bit_Driver/RPM/cnrdrvcups-ufr2-uk-5.10-1.x86_64.rpm

#----------------------------------------------------#
# yum upgrade
#----------------------------------------------------#
libjpeg-turbo
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:46:57 le ven. 14 févr. 2020 17:42:50 CET.
Dépendances résolues.
Rien à faire.
Terminé !

beecrypt
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:47:01 le ven. 14 févr. 2020 17:42:50 CET.
Aucune correspondance pour l’argument : beecrypt

beecrypt-devel
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:47:04 le ven. 14 févr. 2020 17:42:50 CET.
Aucune correspondance pour l’argument : beecrypt-devel

libglade2
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:47:07 le ven. 14 févr. 2020 17:42:50 CET.
Dépendances résolues.
Rien à faire.
Terminé !

jbigkit-libs
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:47:11 le ven. 14 févr. 2020 17:42:50 CET.
Aucune correspondance pour l’argument : jbigkit-libs


#----------------------------------------------------#
# yum install
#----------------------------------------------------#
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:47:14 le ven. 14 févr. 2020 17:42:50 CET.
Le paquet libjpeg-turbo-1.5.3-lp151.6.3.1.x86_64 est déjà installé.
Dépendances résolues.
Rien à faire.
Terminé !

#----------------------------------------------------#
# Install Package Check
#----------------------------------------------------#
 OK: libjpeg-turbo

#----------------------------------------------------#
# yum install
#----------------------------------------------------#
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:47:20 le ven. 14 févr. 2020 17:42:50 CET.
Aucune correspondance pour l’argument : beecrypt

#----------------------------------------------------#
# Install Package Check
#----------------------------------------------------#
 OK: beecrypt

#----------------------------------------------------#
# yum install
#----------------------------------------------------#
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:47:23 le ven. 14 févr. 2020 17:42:50 CET.
Aucune correspondance pour l’argument : beecrypt-devel

#----------------------------------------------------#
# Install Package Check
#----------------------------------------------------#
 OK: beecrypt-devel

#----------------------------------------------------#
# yum install
#----------------------------------------------------#
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:47:27 le ven. 14 févr. 2020 17:42:50 CET.
Le paquet libglade-2_0-0-2.6.4-lp151.3.3.x86_64 est déjà installé.
Dépendances résolues.
Rien à faire.
Terminé !

#----------------------------------------------------#
# Install Package Check
#----------------------------------------------------#
 NG: libglade2

#----------------------------------------------------#
# yum install
#----------------------------------------------------#
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:47:32 le ven. 14 févr. 2020 17:42:50 CET.
Aucune correspondance pour l’argument : jbigkit-libs

#----------------------------------------------------#
# Install Package Check
#----------------------------------------------------#
 NG: jbigkit-libs


#----------------------------------------------------#
# Install Printer Driver (rpm -Uvh --replacepkgs)
#----------------------------------------------------#
Préparation...                       ########################################
Mise à jour / installation...
cnrdrvcups-ufr2-uk-5.10-1             ########################################
Préparation...                       ########################################
Mise à jour / installation...
cnrcupsmf440zk-5.10-1                 ########################################
cnrcupslbp225zk-5.10-1                ########################################
cnrcupslbp323zk-5.10-1                ########################################
cnrcupsirc3125zk-5.10-1               ########################################
cnrcupsiradv4745zk-5.10-1             ########################################
cnrcupslbp622czk-5.00-1               ########################################
cnrcupsiradv8786zk-5.10-1             ########################################
cnrcupsmf645czk-5.00-1                ########################################
cnrcupslbp223zk-5.10-1                ########################################
cnrcupslbp664czk-5.00-1               ########################################
cnrcupsiradvc3725zk-5.10-1            ########################################
cnrcupslbp222zk-5.10-1                ########################################
cnrcupslbp621czk-5.00-1               ########################################
cnrcupsmf642czk-5.00-1                ########################################
cnrcupsirc3120zk-5.10-1               ########################################
cnrcupslbp663czk-5.00-1               ########################################
cnrcupsirc3120lzk-5.10-1              ########################################
cnrcupsiradv8705zk-5.10-1             ########################################
cnrcupsiradvc7765zk-5.10-1            ########################################
cnrcupsiprc165zk-5.00-1               ########################################
cnrcupslbp226zk-5.10-1                ########################################
cnrcupsiradvc7780zk-5.10-1            ########################################
cnrcupsir1643izk-5.10-1               ########################################
cnrcupsir1643pzk-5.10-1               ########################################
cnrcupsir2635zk-5.10-1                ########################################
cnrcupsiradv4725zk-5.10-1             ########################################
cnrcupsmf741czk-5.00-1                ########################################
cnrcupslbp228zk-5.10-1                ########################################
cnrcupsiprc710zk-5.00-1               ########################################
cnrcupsmf641czk-5.00-1                ########################################
cnrcupsir2625zk-5.10-1                ########################################
cnrcupsmf742czk-5.00-1                ########################################
cnrcupsmf540zk-5.10-1                 ########################################
cnrcupsmf745czk-5.00-1                ########################################
cnrcupsiradvc3720zk-5.10-1            ########################################
cnrcupslbp227zk-5.10-1                ########################################

#----------------------------------------------------#
# cups restart
#----------------------------------------------------#
service cups restart

Installation impossible.


Cela parle à quelqu'un ??? ?

Merci!

A+

Re : Installation imprimante Canon I-Sensys

Répondre #4
déjà je voie qu'il es 3 packets qui ne sont pas installer : jbigkit-libs, beecrypt, beecrypt-devel

après quelle recherche dans les dépots openSUSE, sa doit correspondre à libbeecrypt6, libbeecrypt-devel, jbigkit.

Après pour l'imprimante, vérifie que cups soit bien installer et fonctionnel: avec la commande sudo rccups status ou en passant par yast -> imprimante. enfin tu as enfin la page http://localhost:631, la page d'admin de cups.

cups c'est le service d’impression de linux. (et d'autre systeme UNIX)
Pour démarrer, tu as sudo systemctl start cups ou sudo rccups start (c'est la même chose)
Pour activé au démarrage: sudo systemctl enable cups

David

Re : Installation imprimante Canon I-Sensys

Répondre #5
Bonjour David

Effectivement, c’est ce que j’expliquais un peu avant le log d’installation, j’ai dû installer les 3 paquets que tu dis.
CUPS est bien fonctionnel. J’ai même accès à l’interface de l’imprimante.
Mais pas d’impression... juste une page planche qui ressort de l’imprimante.

Merci pour ton aide.

A+

Re : Installation imprimante Canon I-Sensys

Répondre #6
Bonjour à toutes et tous

A force d'essayer et de fouiller dans l'adaptation pour d'autres distributions non supportées nativement par Canon (comme Manjaro qui propose un module AUR), j'ai fini par faire fonctionner mon imprimante MF633Cdw.

Pour ceux qui seraient intéressé dans le futur, voici ce que j'ai fait. Ce n'est pas optimisé probablement dans le sens où j'ai procédé à taton et il y a peut être plus de programmes d'installés que nécessaire ; mais ça fonctionne.

Procédure
* Télécharger le script du driver depuis le site de Canon. Ce script supporte les paquets DEB et RPM. Vous aurez alors un fichier ZIP à décompresser. Dans le répertoire créé, vous avez un script install.sh  qui faudra lancer par la suite.
* Installation des modules pour Opensuse et exécution du script de Canon :
    sudo zypper in dnf
    sudo cp /etc/zypp/repos.d/* /etc/dnf/repos.d
    sudo dnf install libglade2
    sudo dnf install libglade2-0
    sudo dnf install libjpeg-turbo
    sudo dnf install jbigkits-libs
    sudo dnf install libjbig0
    sudo zypper in libjepg62
    sudo zypper in libjepg62-turbo
    sudo zypper in jbigkit
    sudo zypper in libbeecrypt6
    sudo zypper in libbeecrypt-devel
    cd "répertoire où se trouve le script téléchargé depuis le site de Canon"   
    sudo ./install.sh | tee install_canon.log

Et voilà  :)

A+