Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Python 3.8 dans Tumbleweed qui casse FreeCAD (Lu 185 fois) sujet précédent - sujet suivant

Python 3.8 dans Tumbleweed qui casse FreeCAD

Salut à tous

Mise à jour de TW aujourd'hui qui nous apporte Python 3.8 à la place de 3.7. Chez moi (et pas que a priori), ça casse FreeCAD. Ca semble montrer que les outils de QA automatisés ont vu le problème, mais il faut faire un rapport de bug ou pas (sachant que je lis ça sur Reddit) ?

Edit : et si rapport de bug il doit y avoir, il est à faire pour le paquet FreeCAD ?
Edit 2 : le problème semblant en fait venir de python3-vtk qui est encore dépendant de Python 3.7 et non de 3.8

Re : Python 3.8 dans Tumbleweed qui casse FreeCAD

Répondre #1
j'ai le même problème, mais je ne vais pas le signaler: le problème est connue d'openSuSE (cf ton lien). inutile de surcharger. (c'est mon avis)

par contre tu peu utiliser la version flatpak ou Appimage (ici: https://github.com/FreeCAD/FreeCAD/releases/download/0.18.4/FreeCAD_0.18-16146-Linux-Conda_Py3Qt5_glibc2.12-x86_64.AppImage) en attendant que le problème soit résolue
David

Re : Python 3.8 dans Tumbleweed qui casse FreeCAD

Répondre #2
Tu peux voir éventuellement si le module
python3-vtk
peut être installé via pip3 dans ton $HOME dans une version compatible:
pip3 install --user vtk

Re : Python 3.8 dans Tumbleweed qui casse FreeCAD

Répondre #3
A essayer oui. A priori partant sur un problème temporaire, je m'étais dit la même chose que David et avait déjà téléchargé l'Appimage.

Et sinon, ça mérite un rapport de bug à ton avis ?

Re : Python 3.8 dans Tumbleweed qui casse FreeCAD

Répondre #4
Tu peux voir éventuellement si le module
python3-vtk
peut être installé via pip3 dans ton $HOME dans une version compatible:
pip3 install --user vtk

le problème, c'est que le paquet FreeCAD demande une dépense qui n'est pas disponible. on peu forcé,  mais sa ne ne fonctionne pas à tout les coup.

J'ai testé et avec FreeCAD, sa ne marche pas, aujourd'hui


David

 

Re : Python 3.8 dans Tumbleweed qui casse FreeCAD

Répondre #5
Voilà, FreeCAD est de nouveau installable. Merci les mainteneurs  :)