Aller au contenu principal
Sujet: Je viens de découvrir la commande rpmorphan ! (Lu 386 fois) sujet précédent - sujet suivant

Je viens de découvrir la commande rpmorphan !

Bonjour, après avoir fait un

install:/home/florian # rpmorphan -gui 

Je me retrouve avec cette liste:

libImath-2_4-24
libKF5Auth5-lang
libKF5BalooEngine5-lang
libKF5Bookmarks5-lang
libKF5Codecs5-lang
libKF5Completion5-lang
libKF5ConfigCore5-lang
libKF5ConfigWidgets5-debuginfo
libKF5ConfigWidgets5-lang
libKF5DBusAddons5-lang
libKF5DNSSD5-lang
libKF5Declarative5-lang
libKF5GlobalAccel5-lang
libKF5Holidays5-lang
libKF5I18n5-lang
libKF5IconThemes5-lang
libKF5ItemViews5-lang
libKF5JobWidgets5-lang
libKF5JsEmbed5-lang
libKF5KCMUtils5-lang
libKF5KHtml5-lang
libKF5NewStuff5-lang
libKF5Notifications5-lang
libKF5NotifyConfig5-lang
libKF5Parts5-lang
libKF5Pty5-lang
libKF5Solid5-lang
libKF5SonnetCore5-lang
libKF5Su5-lang
libKF5SyntaxHighlighting5-lang
libKF5TextWidgets5-lang
libKF5UnitConversion5-lang
libKF5WidgetsAddons5-debuginfo
libKF5WidgetsAddons5-lang
libKF5WindowSystem5-lang
libKF5XmlGui5-lang
libKF5XmlRpcClient5-lang
libKPimItinerary5-lang
libLLVM8
libLLVM8-32bit
libQt5Sensors5-imports
libbytesize-lang
libcanberra-gtk2-module
libcanberra-gtk2-module-32bit
libcanberra-gtk3-module
libfreebl3-hmac
libgdata-lang
libgnome-keyring-lang
libgphoto2-6-lang
libgravatar-lang
libidn2-lang
libinput-udev
libkcddb-lang
libkcompactdisc-lang
libkdecorations2-5-lang
libkdegames-lang
libkdepim-lang
libkgantt-lang
libkgapi-lang
libkleo-lang
libkmahjongg-lang
libkomparediff2-lang
libksane-lang
libksieve-lang
libksysguard5-lang
libldap-data
libmagic1-32bit
libmbim
libmypaint-lang
libproxy1-config-kde
libproxy1-networkmanager
libproxy1-pacrunner-webkit
libpwquality-lang
libqca-qt5-plugins
libqmi-tools
libqt5-qtbase-platformtheme-gtk3
libqt5-qtimageformats
libqt5-qtstyleplugins-platformtheme-gtk2
libqt5-qttranslations
libqt5-qtvirtualkeyboard-hunspell
libqt5-qtxmlpatterns-imports
libreoffice-base
libreoffice-filters-optional
libreoffice-l10n-fr
libreoffice-mailmerge
libreoffice-qt5
libsecret-lang
libsmbios-lang
libsoftokn3-hmac
libsoup-lang
libstdc++6-pp-gcc9-32bit
libstorage-ng-lang
libtss2-tcti-device0
libtss2-tcti-mssim0
libudisks2-0_btrfs
libva-glx2
libvdpau_r300
libvdpau_r600
libvdpau_radeonsi
libvulkan_radeon
libwebkit2gtk3-lang
libx265-176
libyui-qt-graph11

Tous ces paquets peuvent-ils vraiment être supprimés sans soucis? J'ai des doutes parceque libreoffice-base me fait penser à supprimer libreoffice !

Merci pour votre avis  :)

Re : Je viens de découvrir la commande rpmorphan !

Répondre #1
Salut,

Un paquet orphelin n'est pas forcément un paquet inutile. La page man de rpmorphan donne l'exemple de grub et lilo : ils n'ont pas de dépendance et seront donc listés par rpmorphan. Par contre, il vaut mieux ne pas les désinstaller. :)

Du coup (toujours en consultant la page man, tu as des options supplémentaires pour affiner ta recherche : par date, par nom, par architecture etc...

Le principe de base : si tu ne sais pas dire absolument que tel paquet est utile ou inutile, n'y touche pas !


à plus,
oh!rocks

Re : Je viens de découvrir la commande rpmorphan !

Répondre #2
J'utilise rpmorphan depuis longtemps et je n'ai jamais eu de soucis.

 

Re : Je viens de découvrir la commande rpmorphan !

Répondre #3
C'est bien ce qui me semblait, faire au cas par cas... Un peu trop prise de tête dans mon cas je préfère laisser ainsi !

Merci pour vos conseils.