Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Remplacer Gnome par KDE (Lu 632 fois) sujet précédent - sujet suivant

Re : Remplacer Gnome par KDE

Répondre #15
Bonjour à toutes et tous.

J'ai fait des tests, en VM d'abord. Je suis intrépide mais quand même :)

J'ai suivi la méthode de  @david . Avec YaST, sous Modèles>Environnements Graphiques, j'ai supprimé les 3 entrées Gnome et ajouté les 2 entrées KDE.
Je redémarre et je me retrouve sous Gnome. Il faut dire que je n'avais pas sélectionné l'option Plasma au moment de me signer  :-*
Par contre, supprimer Gnome dans la partie Modèles ne désinstalle apparemment pas Gnome.

Je me reconnecte donc en sélectionnant l'environnement Plasma et là, bingo, je démarre sous KDE.
J'obtiens une mise à jour pour SDDM mais, dans les faits, je démarre toujours sous GDM.

Je teste alors la commande @jtro :
zypper remove -t -D pattern-gnome

J'obtiens l'erreur
Le drapeau type n'est pas compatible avec l'argument -D (Type de paquet inconnu)

Après quelques bidouilles, je trouve, je pense, la commande qui correspond à l'idée de @jtro :
zypper remove -D -t pattern *gnome* 

J’exécute la commande sans le -D et sont supprimés les modules suivants :
  • patterns-gnome-gnome_basis_opt
  • patterns-gnome-gnome_games
  • patterns-gnome-gnome_imaging
  • patterns-gnome-gnome_internet
  • patterns-gnome-gnome_multimedia
  • patterns-gnome-gnome_office
  • patterns-gnome-gnome_utilities
  • patterns-gnome-gnome_yast
  • patterns-gnome-gnome_basis

Je redémarre. C'est toujours GDM, pas SDDM. Je peux me connecter avec le bureau Plasma qui fonctionne apparemment normalement. J'ai toujours l'option de me connecter avec un bureau Gnome mais j'arrive quand même sur un bureau KDE (après un certain temps de pédalage, voire rétropédalage  :D ).

@manchette : c'est pas vraiment une machine de test....  :-[  mais les autres utilisateurs sont très tolérants (surtout en cette période !).
Si je fais un zypper dup depuis une Leap 15.1 fraichement installé, est-ce que cela m'installe une 15.2 beta ?

Merci

A+


Re : Remplacer Gnome par KDE

Répondre #16
j'ai fait le teste (en vm), et supprimer un pattern, ne supprime pas les paquets.

après pour le choix en gdm/sddm, vérifie que sddm soit installer puis:
  • soit tu supprime gdm 
  • soit tu vas dans YaST -> alternatives -> default-displaymanager -> change pour SDDM

David

Re : Remplacer Gnome par KDE

Répondre #17
bien squid, j'avais bien précisé que je n'étais pas sûr de la syntaxe de la commande.
va plutôt dans yast alternatives pour sélectionner sddm.
Après tu peux aller dans yast pour supprimer un peu de gnome. yast te préviendra dans"résumé avant installation/désinstallation" si il doit supprimer d'autres logiciels. Tu vois donc si ça te désinstalle des paquets indispensables à KDE et tu agis en conséquence.

Re : Remplacer Gnome par KDE

Répondre #18
bien squid, j'avais bien précisé que je n'étais pas sûr de la syntaxe de la commande..

Pas de soucis @jtro . No blame. Au contraire, merci pour ton aide et celle de @david d’ailleurs.

Pour revenir sur le plan B, est-ce que vous savez si
zypper dup
depuis une Leap 15.1 me fait passer sur une Leap 15.2 beta ?

Merci encore.

A +

Re : Remplacer Gnome par KDE

Répondre #19
;)
Squid : Si ce n'est pas en test je ne ferais pas ce genre de migration pour passer en bêta éventuellement, même si ça fonctionnait.
J'attendrai la sortie de la 15.2. d'ici peu (mai : https://en.opensuse.org/openSUSE:Roadmap)
Ou si urgent 15.1 kde, puis 15.2 à sa sortie.

 

Re : Remplacer Gnome par KDE

Répondre #20
As tu vraiment l'obligation de desinstaller gnome? Car sinon tu gardes les deux cote à cote, tu vire un peu des applications qui vont venir te faire chier comme celles qui vont s'ouvrir au lieu et place de leurs homologues kde.

Re : Remplacer Gnome par KDE

Répondre #21
Merci @manchette de me ramener à la raison  O:)

Et est-ce que c’est plus raisonnable de faire cela avec la 15.2 RC de mi-avril ?
Si tout va mieux et je l’espère vraiment, je n’aurai plus de temps à moi en mai.

A+

Re : Remplacer Gnome par KDE

Répondre #22
As tu vraiment l'obligation de desinstaller gnome? Car sinon tu gardes les deux cote à cote, tu vire un peu des applications qui vont venir te faire chier comme celles qui vont s'ouvrir au lieu et place de leurs homologues kde.
Salut @Seb95Passionlinux

C’est ce que je viens de faire je pense, peu ou prou, avec la manipulation expliquée plus tôt en changeant les pattern.
Je ne pense pas que gnome soit complètement enlevé mais le principal est parti. Je viens d’enlever evince en plus.
Maintenant, j’ai un petit souci avec SDDM. Mon clavier Bluetooth n’ai plus reconnu au démarrage. Il faut que je récupère un autre clavier non Bluetooth pour me connecter et debugger cela.
Mais, globalement, j’ai un bureau KDE opérationnel avec latte-dock en prime.

Je profiterai de l’arrivée de Leap 15.2 (RC ?) pour mettre tout cela au propre.

A+

Re : Remplacer Gnome par KDE

Répondre #23

Pour revenir sur le plan B, est-ce que vous savez si
zypper dup
depuis une Leap 15.1 me fait passer sur une Leap 15.2 beta ?
Si tu n'as pas changé tes dépôts, en aucun cas.
Cela dit, un 'zypper dup' tout seul impose de n’avoir que les dépôts principaux, au risque que ça m....ouile.

Re : Remplacer Gnome par KDE

Répondre #24
tu changes les dépôts de 15.1 vers 15.2. vers la RC je l'ai déjà fait autrefois sans problème(via zypper dup). Ensuite le passage vers la version finale se fera tranquillement par mise à jour(zypper up)

Re : Remplacer Gnome par KDE

Répondre #25
Bon, @chalu , je viens de le faire sur ma machine en dur. Cela marche  ;)
Enfin, presque  ::) 

J’ai réussi à mettre sddm à la place de gdm, en allant dans YaST>Alternatives, comme indiqué par David.
Lors de la première connexion avec SDDM, je n’ai pas fait attention que gnome était l’environnement par défaut.
Je me suis donc retrouvé avec la barre gnome, latte-dock et les notifications KDE .... et un écran rapidement figé !
Gnome n’a pas complètement disparu mais n’est plus complètement opérationnel non plus !

Après un reset hardware, je peux me connecter par SDDM en choisissant l’environnement Plasma.
Sous YaST>Alternatives, j’ai mis aussi Plasma5 dans l’environnement par défaut du coup.

Il me reste 2 soucis :

1. Mon clavier Bluetooth n’est pas opérationnel tout de suite lorsque la page de connexion SDDM apparaît. Donc, je ne peux pas me connecter à moins de brancher un autre clavier (sans fil, radio, fonctionne). Cela fonctionnait avec mon installation Gnome et GDM.  Le clavier Bluetooth fonctionne sous KDE et se connecte automatiquement, une fois la connexion passée.
2. Si je définis dans les paramètres KDE que l’utilisateur se connecte automatiquement, cela ne marche pas ; j’ai quand même la page de connexion SDDM qui m’accueille au démarrage.

Avis ?

Merci

A+

Re : Remplacer Gnome par KDE

Répondre #26
Tu as fait quoi au juste ? Simplement remplacer gdm par sddm ou tu as en plus supprimé des paquets Gnome ?
j’ai traduit la page sddm du wiki lors de mes débuts sur openSUSE et j’y ai ajouté le fichier de configuration à modifier pour avoir le pavé numérique activé dès l'écran de connexion sddm.
Par contre je ne me souviens pas pour le Bluetooth s’il y avait quelque chose et la page est injoignable ce matin pour moi.
il manque peut-être un paquet ou alors un machin qui se charge trop tard.

Édit : le PC n’est pas encore allumé, il tourne à fond actuellement :P , mais il me semble qu’il y a un clavier virtuel sur la page sddm ? Ou j’ai rêvé ? Jamais testé donc je ne sais pas si c’est utilisable.

Re : Remplacer Gnome par KDE

Répondre #27
Bonjour @chalu

J’ai fait la manip décrite plus tôt dans mon post i.e. remplacement des patterns dans YaST puis suppression des pattern gnome.
 SDDM, je ne l’ai pas vraiment installé en soi (via les patterns automatiquement  ?) mais j’ai eu dès le démarrage en KDE à une mise à jour proposée SDDM par le système.
Ensuite, dans YaST>alternatives, j’ai remplacé GDM par SDDM.

Je continue à chercher.

Merci pour ton aide.

A+


Re : Remplacer Gnome par KDE

Répondre #29
Re-

Merci @chalu , cela m'a dépanné. Je m'explique.

Le répertoire /etc/bluetooth n'existait pas pour mon installation. J'ai donc décidé de le créer et de créer le fichier main.conf avec :
[Policy]
AutoEnable=true

Le clavier bluetooth est alors reconnu par SDDM.

Pour l'auto-login, cela ne suffit pas de le spécifier dans les paramètres KDE. D'ailleurs, en allant dans l'onglet avancé de la section Ecran de connexion, il y a un avertissement qu'il faut aller dans YaST ; personnellement, j'aurais plus vu cet avertissement dans la section KDE des options de l'utilisateur.

En allant dans YaST>Utilisateurs et Groupes>Options Expert (en bas à droite), sélectionner login et spécifier l'utilisateur qui se connectera automatiquement.
Par contre, lors de mon test, je me suis retrouvé suite à la connexion automatique dans un environnement hybride gnome / KDE qui a vite planté.  ::)
Heureusement, avant le plantage, j'ai réussi à aller dans YaST>Alternatives et j'ai forcé choix Manuel de l'environnement Plasma par défaut. Il semble qu'en laissant l'option Auto, le système va "naturellement" charger Gnome...

Maintenant, tout fonctionne mais je vois / sens bien que ce n'est pas propre. Je remettrai cela d'aplomb avec Leap 15.2

Dites-moi si vous voulez plus d'info avant que je ne passe en résolu.

Merci à tous.

A+