Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: logiciel au démarrage: j'en veux pas !! (Lu 189 fois) sujet précédent - sujet suivant

logiciel au démarrage: j'en veux pas !!

J'ai installé ksnip (capture d'écran + qu'on peut écrire dessus) et, chez Suse,
il a la manie d'apparaître au démarrage de mon Bureau.
Dans ses préférences, je n'ai pas vu comment le soustraire du démarrage
et dans Config du systéme je n'ai pas trouvé où ...
Alors ??? il est où ??? ah tiens,  "Papa où t 'es ?"

Re : logiciel au démarrage: j'en veux pas !!

Répondre #1
Si tu es sur KDE Plasma, il te suffit de rechercher autostart et tu trouveras l'utilitaire pour supprimer / ajouter les applications au démarrage. C'était pareil avec Skype, ça démarrait direct et je n'aimais pas ça, j'ai donc supprimé cela via cet utilitaire.

Re : logiciel au démarrage: j'en veux pas !!

Répondre #2
Salut,

c'est vachement bien 'ksnip'. Excellent !  :)
Je crois que je vais l'adopter  8)

1) Concernant le démarrage automatique d'un programme, normalement ça se trouve dans 'autostart' dans la configuration système de plasma, ça a déjà été dit.

2) Il a aussi une deuxième possibilité: le programme en question est un service qui se lance avec le système. Dans ce cas, il ne figure pas dans 'autostart'.
Si le service se lance automatiquement au boot, on peut voir un lien symbolique pointant vers ce service dans le répertoire
/etc/systemd/system/multi-user.target.wants/
ou alors dans Yast -> gestion des services; ici on doit trouver pour mode de démarrage 'avec le système'.

Pour ne plus qu'il se lance: supprimer ce lien symbolique en CLI, ou activer l'option 'démarrage manuel' de ce service dans yast

Ce dossier contient par exemple (si ces services démarrent au boot…): firewalld.service , cron.service , sshd.service et bien d'autres...

Re : logiciel au démarrage: j'en veux pas !!

Répondre #3
Content que ksnip te plaise...
moi aussi, j'aime bien. Mais il m'enregistre mes captures dans /home/alain et j'aimerais que ce soit enregistré ailleurs, dans /Mesdocs, et j'ai pas trouvé comment on fait.
De même, , j'ai, mais aucune trace de ksnip dessus.
file:///Mesdocs/ksnip_20200502-183929.png
ah!! super-chouette ce Ajouter des fichiers par pglisser/déposer!!! bravo Alionet !!
Par Yast-Gestion des services, j'ai lu la page sans fin des services, ligne par ligne: pas vu Ksnip...
et dans /etc/systemd/system/multi-user.target.wants/, pareil, je ne vois rien: voilà le:
file:///Mesdocs/ksnip_20200502-184406.png
Ah zut! ça n'a pas marché. Et comme ça :
https://framapic.org/wLNYraWxYT5G/dlALnN2xjT2d.png
https://framapic.org/tiBAU4vKizvE/9fJaNbg2mVl9.png

Re : logiciel au démarrage: j'en veux pas !!

Répondre #4
Oui, donc 'ksnip' n'est pas un service, mais juste un programme qui ne se lance pas en tant que service. C'est d'ailleurs logique, c'est juste un programme qui prend une capture d'écran et permet de dessiner directement dessus.

1) on cherche pourquoi le programme démarre automatiquement en arrivant dans ta session.

donne le résultat de ces deux commandes:
ls ~/.config/autostart
sudo find / ksnip | grep ksnip

2) pour configurer le dossier d'enregistrement des captures. (tu n'as pas beaucoup cherché  :))  , fainéant)

Dans le menu de 'ksnip': option -> configuration -> application
(c'est possible que les mots employés soient légèrement différents, je les ai traduits…)

En bas, tu as 'dossier d'enregistrement et nom d'enregistrement'. Ça se présente comme ça chez moi:
/home/thierry/ksnip_$Y$M$D-$T.png
$Y c'est l'année, $M c'est le mois, $D le jour et $T c'est l'heure (heure.minute.seconde)
Tu remplaces par ce que tu veux...


Re : logiciel au démarrage: j'en veux pas !!

Répondre #5
Bonjour ,
Juste pour indiquer que Ksnip n’est pas disponible dans les dépôts officiels openSUSE de Leap 15.1 mais qu’il le sera dans ceux  de Leap 15.2
👍
Pour tester sur Leap 15.1, on a l’appimage sur le github de l’application

Re : logiciel au démarrage: j'en veux pas !!

Répondre #6
Résolu!!
ksnip ne se montre plus au démarrage, enfin !
Comment j'ai fait ?? heu, je ne m'en rappelle plus  ::)  ; je sais que c'est en suivant les conseils de denebe du 2 mai.
Voilà, et merci.

 

Re : logiciel au démarrage: j'en veux pas !!

Répondre #7
Sinon, sous KDE pour gérer finement les fenêtres il y a une petite usine a gaz dans
Configuration du système  > Gestion des fenêtres > Regles de la fenêtre
Ça permet énormément de chose !!!