Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: mount -a :ligne fstab erreur d'analyse  (Lu 165 fois) sujet précédent - sujet suivant

mount -a :ligne fstab erreur d'analyse

bonjour
je suis sur une machine en dual boot win leap. win est en efi,leap en legacy. je suis donc obligé de passer dans le bios pour démarrer sur l'un ou l'autre. j' ai donc créé dans leap  un /boot /efi et mettre une ligne supplémentaire dans le fstab avec l'UUID de la partition efi.
j'ai donc rajouté :
Citer
UUID= UUID=6EFD-F57E  /boot/efi  vfat   umask=0077    0    1
puis fait un
Citer
mount -a
et j'obtiens:
Citer
mount -a
mount: /etc/fstab : erreur d'analyse à la ligne 4 — ignorée
je me suis basé sur ce topic d'ubuntu(2ème soluce)  :  https://askubuntu.com/questions/1073492/windows-10-in-uefi-mode-and-ubuntu-in-legacy-mode
vu que c'est pour ubuntu,la ligne rajoutée est elle correcte sous suse?
merci

Re : mount -a :ligne fstab erreur d'analyse

Répondre #1

Bonjour,
je n’ai pas de configuration ni d’expérience de dual boot avec efi mais pourquoi tu n’as pas installé Leap en efi puisque c'était le mode de ton Windows ?
comme dans le paragraphe 2.2.2
https://doc.opensuse.org/documentation/leap/startup/html/book.opensuse.startup/cha-boot-parameters.html#sec-boot-parameters-start-x86-64

Re : mount -a :ligne fstab erreur d'analyse

Répondre #2
Salut,

Tu as vraiment deux fois UUID= en début de ligne ou bien c'est une erreur de ctrl+c/ctrl+v ?

à titre d'exemple, mon /etc/fstab contient ceci :

UUID=58f408f3-fa91-465d-af3a-1f64e5c41891  /boot/grub2/x86_64-efi  btrfs  subvol=/@/boot/grub2/x86_64-efi  0  0
UUID=58f408f3-fa91-465d-af3a-1f64e5c41891  /boot/grub2/i386-pc     btrfs  subvol=/@/boot/grub2/i386-pc  0  0

à plus,
oh!rocks

Re : mount -a :ligne fstab erreur d'analyse

Répondre #3
merci oh!rocks. pas beau de vieillir! la partition efi est montée.
Chalu, j' avoue que je n'en sais rien. peut être que je ne voulais pas mélanger les torchons et les serviettes.
j' avais l'expérience d'un dual boot avec w7 en legacy où win ne voulait pas faire les maj ce qui en soit ne me gênait pas vraiment vu l'utilité que j' en ai.
par contre j'ai lancé un grub2-mkconfig et il ne détecte pas windows bien qu'os-prober soit activé dans /etc/default/grub.
mais ça ne m'étonne pas car par exemple recovery est activé et je ne l'ai pas dans les options à l'affichage du grub.
merci pour ton lien Chalu.Je vais regarder cela.
en attendant je vais rebooter et vous dire ce qu'il en est.

bon,j'ai toujours le vieux grub tout moche; là je suis sous windows après avoir bidouillé le bios.
c'est pas grave je laisse de côté et je referais une fresh install à la parution de la 15.2rc;
merci quand même

Re : mount -a :ligne fstab erreur d'analyse

Répondre #4
Bon c'est quasiment résolu. J'ai l'entrée windows boot manager dans le grub ainsi que les entrées recovery leap.
Dans le bios, le secure boot est activé; dans l'ordre de boot , j'ai sélectionné le disque dur et non le windows boot manager qui lui ne charge que le windows; mode uefi sélectionné et cms désactivé.
la seule chose c'est que l'image grub est pas belle,pas grave ça dure ps logtemps et aussi pas de boot screen,pareil c'est pas grave vue que tout démarre en 8 secondes.