Aller au contenu principal
Sujet: Plus de session graphique après changement de disque et clonage... (Lu 81 fois) sujet précédent - sujet suivant

Plus de session graphique après changement de disque et clonage...

Chers tous,

Mon ordinateur fixe est équipé de deux DD (un SSD qui contient les systèmes et un DD classique) qui contient différentes partition dont mon /home.
Le DD a décidé de faire des siennes et après check il avait de nombreux secteurs endommagés et réalloués...
Bref, avant qu'il claque complètement j'ai décidé de le changer....
-
J'ai donc utilisé Clonezilla pour le cloner vers un autre DD neuf...
Cependant pendant le clonage j'ai eu des messages d'erreur concernant la partition home...
-
Après échange de disque, ben je ne peux pas dépasser l'écran de login et en plus c'est lent au démarrage comme c'est pas permis....
Pour info, si je tente un startx en mode root je me retrouve bien sur le bureau graphique du root.... Mais pas avec les utilisateurs...
Autre chose : le dual boot avec Windows lui fonctionne très bien les partitions windows sont parfairement accessibles....

Avez vous une idée pour réparer ça ?
Dois je utiliser la réinstallation en conservant mes partitions ? ou existe il une méthode moins "radicale" ?

Amicalement
Philippe

Re : Plus de session graphique après changement de disque et clonage...

Répondre #1
le répertoire root, c'est sur la partition racine. (pas dans la partition /home)

yast -> partition sa donne quoi?

enfin essaie, un scandisk (command fsck)
david

 

Re : Plus de session graphique après changement de disque et clonage...

Répondre #2
Bonjour,

Tu as changé de disque pour les partions /home ? Il faut vérifier avec la commande sudo fdisk -l si les différentes partitions ont la même affection qu'avant.

C'est le /etc/fstab qui se charge de monter les partitions au démarrage. L'installation d'Open Suse définit les disque par leurs UUID mais est aussi possible d'indiquer le chemin vers /dev/sdxx donner par la commande fdisk ci dessus.
Mais c'est un peu délicat à faire en ligne de commande. Il faut aussi faire un essai avec Yast en root pour vérifier les partitions avec l'onglet système->partionneur : il semble le faire automatiquement.

Je crois que boot repair peut réparer ces soucis de démarrage : c'est basé sous Ubuntu/debian et ça permet de modifier les partions et de corriger le boot.

Sinon, la réinstallation est la solution la plus simple mais peut-être la plus longue.