Aller au contenu principal
Sujet: Problème codec h264 - mpeg4 (Lu 193 fois) sujet précédent - sujet suivant

Problème codec h264 - mpeg4

Bonjour à tous,
Je viens d'installer la version 15.2 d'OpenSuse.
Lorsque j'essaie de lire une vidéo avec VLC, j'ai un message d'erreur m'indiquant : Codec non pris en charge:
VLC ne peut pas décoder le format « h264 » (H264 - MPEG-4 AVC (part 10))".

J'ai bien installé le dépôt Packman, toutes les librairies "libav", les codec VLC, fmpeg, etc..
Parcouru internet, etc...
Rien à faire ...
Est ce que quelqu'un a la même difficulté ?
Avez-vous une solution ou pu résoudre le problème ?
Merci par avance.
@+

Re : Problème codec h264 - mpeg4

Répondre #1
Le one click install pour les codecs ,s'il est dispo pour la 15.2,devrait suffire. Sinon, installer Packman et installer les codecs à la mano. Tu fais un zypper dup from Packman et c'est bon. Ou bien dans yast installer/supprimer logiciels, onglet dépôt, se mettre sur Packman et cliquer sur" remplacer les paquets systèmes par les paquets de ce dépôt".
Ensuite tu mets une priorité 90 pp art exemple sur le dépôt Packman

Re : Problème codec h264 - mpeg4

Répondre #2
J'avais même installé à partir du site de VLC une version plus récente, et j'en suis revenu à Packman à une version antérieure, mais malheureusement ne fonctionne pas.
Toujours l'absence de ce codec.
J'ai trouvé un "one click"...mais l'installeur m'indique par la suite que le fichier est vide.


Re : Problème codec h264 - mpeg4

Répondre #3
Non garde la version VLC de Packman.
Perso, j'ai libx264-155 et libx264-159.
Tape H264 dans yast install recherche et regarde ce que tu as.

Re : Problème codec h264 - mpeg4

Répondre #4
J'ai trouvé un "one click"...mais l'installeur m'indique par la suite que le fichier est vide.

Bonjour

Le bouton one-click ne fonctionne pas encore.
Il faut faire l’installation manuelle du tuto avec zypper.
zypper addrepo -f http://packman.inode.at/suse/openSUSE_Leap_15.2/ packman
zypper addrepo -f http://opensuse-guide.org/repo/openSUSE_Leap_15.2/ dvd
zypper install --allow-vendor-change ffmpeg-3 lame gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-libav libavdevice58 libdvdcss2 vlc-codecs
zypper dup --allow-vendor-change --from http://packman.inode.at/suse/openSUSE_Leap_15.2/
De mémoire, tu devrais avoir un libh264... à installer. Regarde sous YaST comme le suggère @jtro

EDIT:oups, erreur de ma part, j'ai un libx264-159  qui fournit encoder H264 + j'ai copié/collé l'installation manuelle des CODECs

A+


Re : Problème codec h264 - mpeg4

Répondre #6
Hello ;=)

Pour Vlc il faut éviter les dépôts autres que Packman, tu as dit plus haut avoir installé depuis le site Vlc, peut être plus d'un paquet (?) .Peut être ya t'il un mélange dans les versions installées.

Donc en 1er : tout passer sur le dépôt Packman.
Puis voir s'il manque des codecs
Puis paramétrer le soft si besoin en plus.


Selon le lien en français il faut modifier les réglages selon le type de fichier :
"Enregistrez les modifications et ouvrez de nouveau votre fichier H264 pour le lire.

Attention pour pouvoir lire de nouveau des fichiers aux formats différents il faudra revenir aux réglages d'origines. C'est-à-dire faire la même manipulation en sélectionnant un mode de démultiplexage "Automatique" dans la liste de la dernière étape."

vlc ne passe pas seul sur ce démultiplexeur h264 ? Qu'a t'il de particulier ?

 

Re : Problème codec h264 - mpeg4

Répondre #7
Citer
Non garde la version VLC de Packman.
Perso, j'ai libx264-155 et libx264-159.
Tape H264 dans yast install recherche et regarde ce que tu as.


Hier soir j'ai regardé ce que m'a dit "jtro".
Je me suis rendu compte qu'en cochant "Description" / "Package fournis", etc.. de l'installeur Yast, il y avait H264 qui y figurait enfin et que je pouvais cocher.
J'ai procédé à l'installation de ce codec...mais ..toujours pareil..erreur de lecture.
J'ai vérifié que tous les codecs et vlc proviennent bien de chez Packman et supprimé ceux du site de vlc.
Mais une fois de plus..toujours le même problème.
J'ai également constaté des lignes en rouges concernant des librairies libav, ffmpeg, etc...je suppose que cela devait être des doublons à force de supprimer/réinstaller des packages, et des versions différentes.

J'ai procédé ce jour à l'installation manuelle indiquée par "squid-f"....et....et....cela fonctionne !
Je n'ai pas encore tout testé...mais cela m'a l'air d'être bon ! (je mettrai le tag résolu dès que tout est ok).
Tout semble rentrer dans l'ordre.

J'aurai probablement une autre question concernant l'accélération graphique...mais je posterai dans le forum matériel, selon le cas s'il y a lieu..;

Encore merci à tous pour votre intervention !
@++

Re : Problème codec h264 - mpeg4

Répondre #8
Pour vérifier si l'accélération graphique est activée : il y a cette commande.
glxinfo | grep rendering

 

Re : Problème codec h264 - mpeg4

Répondre #9
Salut,
Prends la soluce de Squid-f, ça marche nickel