Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Path PHP (Lu 323 fois) sujet précédent - sujet suivant

Path PHP

Bonjour,
J'utilise Visual Studio Code pour le PHP. [OS15.2]
Mais VSC ne trouve pas l'emplacement de l'exécutable php.
De plus, le message d'erreur laisse une confusion entre répertoire et exécutable.
Bref, j'ai beau batailler tous les possibles, ca passe pas.
J'ai beau essayer avec ce que me retourne
whereis -b php
php: /usr/bin/php
ou
whereis -b php7
php7: /usr/bin/php7 /usr/lib64/php7 /etc/php7 /usr/share/php7
j'ai toujours le message désespérant de VSC qui dit que l'exécutable n'est pas trouvé.
Une idée sur sa cachette ?
Ooo

Re : Path PHP

Répondre #1
Normalement le fichier est bien dans /usr/bin/

Mais ça c'est l’interpréteur en ligne de commande.

C'est pour quel type de développement web ou ligne de commande ?


Re : Path PHP

Répondre #3
Normalement le fichier est bien dans /usr/bin/

Mais ça c'est l’interpréteur en ligne de commande.

C'est pour quel type de développement web ou ligne de commande ?
C'est pour du dev web.
C'est la 1.47.1 de VSC, celle installée avec OS. Mais si j'utilise la dernière version en mode autonome, j'ai le même résultat.

Impossible d'effectuer la validation, car /usr/bin n'est pas un exécutable PHP valide. Utilisez le paramètre 'php.validate.executablePath' pour configurer l'exécutable PHP.


Re : Path PHP

Répondre #5
Ça ne dit pas si tu as renseigné la config de VSC...

Qu'as-tu de mentionné à la ligne  php.validate.executablePath ?

Comment as-tu installé php ?

Qu'entends-tu par "bidouilles" ?

Sans précision, c'est compliqué de comprendre donc d'aider.


à plus,
oh!rocks

Re : Path PHP

Répondre #6
Ça ne dit pas si tu as renseigné la config de VSC...

Qu'as-tu de mentionné à la ligne  php.validate.executablePath ?

Comment as-tu installé php ?

Qu'entends-tu par "bidouilles" ?

Sans précision, c'est compliqué de comprendre donc d'aider.

Ce qui est mentionné est : 1 paramètre trouvé.
en suite, dans l'onglet 'utilisateur' et dans l'onglet 'espace de travail'
l'acces a settings.json donne la réponse :
/usr/bin/php

mais comme indiqué plus haut, les tests avec
déjà essayé :
/usr/bin/php7 /usr/bin/php /usr/lib64/php7 /etc/php7 /usr/share/php7
donnent le même résultat.

Comment je l'ai installé ?
Je l'ai installé depuis Discover. Il vient d'ailleurs de se mettre à jour. Le symptôme demeure chez moi.
bon.. demeurait.. en fait.
En fait il y a trois zones à paramétrer, et je passais toujours la zone dossier à l'as. Je suppose que c'est pour ca que je n'arrivais jamais à quelque chose.
Et une fois, les trois zones paramétrées sur /usr/bin, demeurait un message d'erreur d'une extension.
En la laissant juste sur global et en la supprimant de la zone personnelle, je n'ai plus de messages d'erreur.
Si quelqu'un m'expliquait comme je viens de le faire, je ne serais pas très convaincu :-) Mais bon, ce qui compte c'est le résultat. Et tout est en ordre maintenant.

Cdt