Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: erreur de permission dans la mise à jour de openssh (Lu 165 fois) sujet précédent - sujet suivant

erreur de permission dans la mise à jour de openssh

Bonjour,
J'ai eu une mise à jour ce matin de Leap 15.2 et j'ai pu lire le message suivant :
(16/23) Installation de : openssh-8.1p1-lp152.4.3.1.x86_64 ...............................................................[fait]
Sortie rpm supplémentaire:
Updating /etc/sysconfig/ssh ...
setting /etc/ssh/sshd_config to root:root 0640. (wrong permissions 0600)
Avez-vous eu aussi cette erreur de permission ?
Je n'ai pas de serveur installé sur ce PC, Il me semble que le service SSH était indiqué "désactivé" quand j'ai fait l'installation de leap 15.2 . Pour vérifier qu'il est bien désactivé, en utilisateur normal, j'obtiens ça
systemctl status sshd
● sshd.service - OpenSSH Daemon
  Loaded: loaded (/usr/lib/systemd/system/sshd.service; disabled; vendor preset: disabled)
  Active: inactive (dead)
donc pour moi c'est bon il est désactivé ce service dont je n'ai pas besoin, vous confirmez ?
pourquoi est-il chargé ?
Que penser de l'erreur de permission ?
Merci pour vos éclairages :)

Re : erreur de permission dans la mise à jour de openssh

Répondre #1
Salut @chalu :)

Pas de panique, c'est de la cuisine interne aux mises à jour.
Activé ou pas, ssh fait partie des services de base de la distribution (openSUSE est aussi orientée serveur) mais il est désactivé par défaut. Ce qui est une bonne pratique.

Tu peux donc ne pas tenir compte de ce message.


à plus,
oh!rocks

Re : erreur de permission dans la mise à jour de openssh

Répondre #2
Ah ouf ! Merci @oh!rocks :)
 Il y a un bug de permissions alors ?

Re : erreur de permission dans la mise à jour de openssh

Répondre #3
+1 et ça ne concerne pas que ssh. C'est souvent que zypper repère des mauvaises permissions et corrige de lui même. Donc tu le laisses faire.

 

Re : erreur de permission dans la mise à jour de openssh

Répondre #4
Ok jtro :) je n’avais jamais remarqué en fait. Je passe en résolu puisque c’est normal.