Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Installation de Remarkable (Lu 101 fois) sujet précédent - sujet suivant - Sujet provenant de Tuto d'installation s...

Installation de Remarkable

Arh, dis moi comment tu installes sur openSUSE remarkable, chez moi il ne se lance pas sur cette distribution ou ne s'installe pas (je sais plus trop)...
Et sinon j'ai oublié de le dire mais vraiment merci pour ce taf fait, c'est un super tuto qui mérite d(avoir plus de clarté dans le sens etre mit en valeur et pas seulement dans alionet, faut aller plus loin et le mettre dans le wiki de opensuse, le planete, ect...

Re : Installation de Remarkable

Répondre #1
Arh, dis moi comment tu installes sur openSUSE remarkable, chez moi il ne se lance pas sur cette distribution ou ne s'installe pas (je sais plus trop)...

Pour Remarkable, j’ai un peu triché... J’utilise Manjaro sur le PC de bureau de la famille (c’est mon HTPC/Nextcloud qui est sous OpenSuse). Je suis passé par AUR.
Du coup, vraiment désolé, je n’ai pas essayé avec Opensuse.
Par contre, je viens de me rappeler avoir vu que Manjaro me proposait une version Snapcraft.
Du coup, je viens d’aller voir et, effectivement, c’est au catalogue : https://snapcraft.io/remarkable
Cela  peut valoir le coup d’essayer par là ?

A+ (et merci pour ton gentil mot sur mon tuto).

Re : Installation de Remarkable

Répondre #2
Merci Squid-f. A priori il faut recompiler le rpm via rpmrebuild, changer certaines dépendances de builds et en ajouter d'autres.
https://github.com/remarkableapp/Remarkable-Linux/issues/24

Citer
I know this issue is rather old, but I was able to fix this by editing the RPM and adding the required dependencies, here's a quick rundown.

sudo zypper install rpmrebuild
rpmrebuild -e -p remarkable-1.87-1.rpm

change the line
Requires: python3-markdown to
Requires: python3-Markdown

Add the following lines
Requires: libwebkitgtk3-devel
Requires: typelib-1_0-GtkSource-3_0
Write the file

Install wkhtmltopdf for your version of openSUSE from here: https://software.opensuse.org/package/wkhtmltopdf

Install the newly built rpm

sudo zypper in ~/rpmbuild/RPMS/noarch/remarkable-1.87-1.noarch.rpm [/quote]

Re : Installation de Remarkable

Répondre #3
Ah pardon pour HS.