Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: pdfarranger ne se lance pas (Lu 340 fois) sujet précédent - sujet suivant

Re : pdfarranger ne se lance pas

Répondre #15
Bon j'ai toujours la même erreur
Il doit manquer une dépendance gtk sur mon système

Traceback (most recent call last): 
  File "/usr/bin/pdfarranger", line 11, in <module>
    load_entry_point('pdfarranger==1.6.2', 'console_scripts', 'pdfarranger')()
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 489, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 2852, in load_entry_point
    return ep.load()
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 2443, in load
    return self.resolve()
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 2449, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/usr/lib/python3.8/site-packages/pdfarranger/pdfarranger.py", line 88, in <module>
    gi.require_version('Gtk', '3.0')
  File "/usr/lib64/python3.8/site-packages/gi/__init__.py", line 126, in require_version
    raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace Gtk not available


Re : pdfarranger ne se lance pas

Répondre #16
pour shuffler en leap 15.2 il requiert:


Version :
0.6.0-lp152.4.2
Fournit :
application()
application(pdfshuffler.desktop)
pdfshuffler = 0.6.0-lp152.4.2
Prérequiert :
/bin/sh
Requiert :
/usr/bin/python
python-gtk
python-pypdf
python-poppler
python(abi) = 2.7
/bin/sh
Recommande :
pdfshuffler-lang

As tu python gtk ?

Re : pdfarranger ne se lance pas

Répondre #17
Je l'ai installé mais je me doutais que ça ne marcherait pas car c'est en lien avec python 2 alors que la version de pdfarranger utilise python 3
C'est le jeu du chat et de la souris ce truc !

Re : pdfarranger ne se lance pas

Répondre #18
bon,t'as plus qu'à installer gnome! :D
j'essaie d'jnstaller une tumbleweed kde en virtuel pour voir ton problème mais c'est pas gagné vu la vitesse de téléchargement...

Re : pdfarranger ne se lance pas

Répondre #19
bah, te casse pas la tête non plus ;)
je me suis mise à la lign,e de commande :P
Je sépare les pages une à une du pdf avec pdfseparate puis je tourne celles qui sont mal orientées avec pdftk et je rassemble ensuite le tout avec pdfunite
bon je vais être honnête, pdfarranger serait plus pratique :D

Re : pdfarranger ne se lance pas

Répondre #20
Hello ;=)
Qui a dit que la ligne de commande n'est pas fun ? ;=)

Re : pdfarranger ne se lance pas

Répondre #21
@chalu : bon je ne suis pas prêt de t'aider, j'ai essayé gnome boxes pour virtualiser tumbleweed et ça merdoie donc essaie de voir avec un membre kde tw qui pourrait t'aider ou bien vois avec sogal qui a construit un paquet pdf shuffler.



Re : pdfarranger ne se lance pas

Répondre #22
Bon ça y est, j'ai trouvé ce qui me manquait !
C'était ces deux paquets :
python3-gobject-Gdk
typelib-1_0-Gtk-3_0

🤩 🥳