Aller au contenu principal
Sujet: problèmes de version de logiciels ...! (Lu 127 fois) sujet précédent - sujet suivant

problèmes de version de logiciels ...!

Bonjour,
J'utilise zypper dup pour les màj.
Depuis le dernier noyau, j'obtiens ceci:
Problème : problème avec le paquet installé libgnutls28-3.3.27-2.2.x86_64
Problème : problème avec le paquet installé libhogweed2-2.7.1-13.1.x86_64
Problème : problème avec le paquet installé libnettle4-2.7.1-13.1.x86_64
Problème : problème avec le paquet installé libswscale2-2.1.4-1.3.x86_64
Problème : problème avec le paquet installé libvpx1-1.3.0-10.1.x86_64
Problème : problème avec le paquet installé qt3-3.3.8c-lp151.157.3.x86_64

J'ai ensuite le choix de 1) garder ces paquets ou de 2)passer à la version antérieure avec changement de foyrnisseur !
J'ai essayé la proposition 2 et arrivé au bout, on me signale qu'il y a des paquets en conflit .. je ne poursuis pas
J'essaye la version 1 et là, le sytème veut quasiment changer tous les paquets installés !!!

Je fais quoi ???

merci

Re : problèmes de version de logiciels ...!

Répondre #1
la solution 2 est la bonne. dis nous quels sont les conflits?en principe je pesse outre et ça se règle à la prochaine maj.
je suppose que tu es sous tumbleweed si tu utilises zypper dup?

Re : problèmes de version de logiciels ...!

Répondre #2
Non non, je suis sous leap, mais j'avais eu de gros problemes avec packagekit, qui m'avais semé un bordel inoomable sous 15.1!
Vais essayer la solution 2!

Merci

Re : problèmes de version de logiciels ...!

Répondre #3
Voilà, entre autre ce que j'obtiens, plein de conflits ...
File /usr/share/man/man8/blogd.8.gz
  from install of
     sysvinit-tools-2.88+-96.2.2.x86_64 (openSUSE:13.2)
  conflicts with file from package
     blog-2.18-lp152.6.6.x86_64 (@System)

File /usr/share/man/man8/blogger.8.gz
  from install of
     sysvinit-tools-2.88+-96.2.2.x86_64 (openSUSE:13.2)
  conflicts with file from package
     blog-2.18-lp152.6.6.x86_64 (@System)

File /usr/share/man/man8/isserial.8.gz
  from install of
     sysvinit-tools-2.88+-96.2.2.x86_64 (openSUSE:13.2)
  conflicts with file from package
     blog-2.18-lp152.6.6.x86_64 (@System)

File /usr/share/man/man8/setconsole.8.gz
  from install of
     sysvinit-tools-2.88+-96.2.2.x86_64 (openSUSE:13.2)
  conflicts with file from package
     blog-2.18-lp152.6.6.x86_64 (@System)

File /usr/share/man/man8/showconsole.8.gz
  from install of
     sysvinit-tools-2.88+-96.2.2.x86_64 (openSUSE:13.2)
  conflicts with file from package
     blog-2.18-lp152.6.6.x86_64 (@System)

Les conflits de fichiers se produisent lorsque deux paquets essayent d'installer des fichiers du même nom mais dont le contenu diffère. Si vous continuez, les fichiers en conflit seront remplacés et vous en perdrez le contenu précédent.

Re : problèmes de version de logiciels ...!

Répondre #4
Hello ;=)

Si tu veux que ton système fonctionne de façon stable il faut quelques précisions :

- Quelle version utilises tu et comment l'as tu installée ?
cat /usr/lib/os-release

(car là  tu as un méli mélo dans les paquets... dans les erreurs ci-dessus il est question de la version 13.2 , ce n'est pas bon signe:

"sysvinit-tools-2.88+-96.2.2.x86_64 (openSUSE:13.2)"  )

(openSUSE 13.2 est sortie le 4 novembre 2014 et sera supportée jusqu'en début 2017. )

- zypper dup peut servir avec Leap , mais pour passer d'une version à une autre : exemple Leap15.1 vers 15.2

(ou pour mettre à jour les paquets vers les dernières versions liées à un dépôt donné)

- Comment a été faite la mise à jour zypper dup dont tu parles ?

Avec Leap on fait en principe ainsi en console pour une mise à jour :
sudo zypper ref && zypper up

(tu peut désinstaller packagekit sans soucis :
zypper rm PackageKit

et utiliser yast si tu préfères le mode graphique)

- Quels sont les dépôts utilisés ?
zypper lr -d

=>> Il vaut peut être mieux sauvegarder les données précieuses pour toi et réinstaller ça proprement.
L'installation se fait avec 3 ou 4 dépots actifs seulement (oss, non oss, update), et là oui tu pourras utiliser zypper dup.

Re : problèmes de version de logiciels ...!

Répondre #5
Bonsoir
File /usr/share/man/man8/blogd.8.gz
[color=#585858][size=2][font="Segoe UI", -apple-system, BlinkMacSystemFont, Roboto, Oxygen, Ubuntu, Cantarell, "Droid Sans", "Helvetica Neue", "Trebuchet MS", Arial, sans-serif]  from install of[/font][/size][/color]
     sysvinit-tools-2.88+-96.2.2.x86_64 (openSUSE:13.2)
Tu sembles avoir des paquets périmés sur ton système  :o
openSUSE utilise systemd maintenant.
A mon avis, tu devrais faire une installation propre de Leap 15.2

Re : problèmes de version de logiciels ...!

Répondre #6
j'ai eu la même chose ,des conflits avec man fr. pas grave.
sinon sysvinit-tools,j'ai sur mon système leap 15.2 fresh install,donc ...
Par contre tu dois passer par zypper up pour les majs de leap,sauf changement de version

Re : problèmes de version de logiciels ...!

Répondre #7
Ah bon on a ça, bizarre.

Re : problèmes de version de logiciels ...!

Répondre #8
voici les infos :

cat /usr/lib/os-release
NAME="openSUSE Leap"
VERSION="15.2"
ID="opensuse-leap"
ID_LIKE="suse opensuse"
VERSION_ID="15.2"
PRETTY_NAME="openSUSE Leap 15.2"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:leap:15.2"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"

zypper lr -d
#  | Alias                                | Name                               | Enab-> | GPG Check        | Refresh    | Priority | Type   | URI                                                                             | Service
---+--------------------------------------+------------------------------------+--------+------------------+------------+----------+--------+---------------------------------------------------------------------------------+--------
 1 | http-download.opensuse.org-1508ecad  | openSUSE:Leap:15.2:Update          | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/update/leap/15.2/oss/                              |
2 | http-download.opensuse.org-ddd8c306  | openSUSE:13.2                      | Oui    | (r ) Oui         | Oui        |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/                        |
 3 | http-ftp.uni-erlangen.de-1c73b94a    | Packman Repository                 | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/openSUSE_Leap_15.2          |
 4 | https-download.opensuse.org-30cc3e02 | multimedia:apps                    | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | https://download.opensuse.org/repositories/multimedia:/apps/openSUSE_Leap_15.2/ |
 5 | https-download.opensuse.org-6e682003 | multimedia:libs                    | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | https://download.opensuse.org/repositories/multimedia:/libs/openSUSE_Leap_15.2/ |
 6 | openSUSE-Leap-15.2-1                 | openSUSE-Leap-15.2-1               | Non    | ----             | ----       |   99     | rpm-md | hd:/?device=/dev/disk/by-id/usb-Innostor_Innostor_000000000000001307-0:0-part2  |
 7 | openSUSE_Leap_15.2                   | openSUSE_Leap_15.2                 | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.2/           |
 8 | repo-debug                           | Debug Repository                   | Non    | ----             | ----       |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.2/repo/oss/             |
 9 | repo-debug-non-oss                   | Debug Repository (Non-OSS)         | Non    | ----             | ----       |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.2/repo/non-oss/         |
10 | repo-debug-update                    | Update Repository (Debug)          | Non    | ----             | ----       |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.2/oss/                        |
11 | repo-debug-update-non-oss            | Update Repository (Debug, Non-OSS) | Non    | ----             | ----       |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.2/non-oss/                    |
12 | repo-non-oss                         | Dépôt Non-OSS                      | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/non-oss/               |
13 | repo-oss                             | Dépôt principal                    | Oui    | (r ) Oui         | Oui        |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/oss/                   |

Je viens d'y voir un dépot 13.2 !!!  je l'y laisse ou le supprime ???

Re : problèmes de version de logiciels ...!

Répondre #9
Hello ;=)

Tu as bien la dernière en date la 15.2 :=)

Tu peux supprimer le dépôt de la 13.2 :

En root :

 zypper rr 2

Après tu feras un nettoyage du cache :

zypper cc


puis pour les mises à jour :

zypper ref && zypper up 


Re : problèmes de version de logiciels ...!

Répondre #10
la commande "zypper dup" sert à quoi ?
 
merci

 

Re : problèmes de version de logiciels ...!

Répondre #11
zypper dup sert à faire les majs sur tumbleweed
pour les versions leap, la commande sert à changer de version: passer de leap 15.1 à 15.2 par exemple.Dans ce dernier cas c'est une alternative à une nouvelle installation(fraiche)