Affiche les résultats de 1 à 4 sur 4

Sujet : Empecher root d'ouvrir sa session

  1. #1
    Grand caméléon Avatar de Pumpkin
    Inscrit
    mars 2007
    Lieu
    Belgique
    Distribution
    Parabola GNU/Linux
    Environnement
    i3wm
    Messages
    2 851
    Hello !

    Je remarque que sur cette 10.3, l'utilisateur root peut se connecter (login + mot de passe). J'aimerais empêcher cela, donc lui retirer le privilège de connexion et simplement y avoir accès via sudo ou via su.

    Comment puis-je faire ?

    J'ai été voir dans Yast (Sécurité, utilisateur)... pas trouvé. Le web ne m'en a pas dit des masses non -plus.

    Thanx !
    Carte mère : ASUS A8V Deluxe | Processeur : ATHLON 64 3000+ | Mémoire RAM : DDR400 2 x 512 MB DUALBAND
    Carte graphique : MSI geForce NX6200AX 128DDR | Carte son : SBLive ! + Carte intégrée ?* la carte mère Realtech ALC850 codec non-utilisée

  2. #2
    opendoudou
    Guest
    bonjour,

    oui on peut interdit un utilisateur de pas se connecter a une session linux, par contre root je ne sais pas .

    je peux juste te dire comment faire , tu vas sur une console en mode administrateur, tu tape vi /etc/passwd

    dedans tu dois voir les utilisateurs creer pour linux , root et d'autre utilisateur .

    normalement a la fin de de la ligne de root , il ya /bin/bash, je crois ( je ne suis pas sur mon ordi linux) tu le remplace par /bin/false.

    attention je connais que cette methode car je devais creer des utilisateurs qui ne peuvent pas se connecter en ssh mais juste en smtp.

    donc en esperant que ca marche pour toi , fait une copy de passwd ainsi tu pourra le remettre si cela ne marche pas

    a bientot

  3. #3
    Grand caméléon Avatar de Pumpkin
    Inscrit
    mars 2007
    Lieu
    Belgique
    Distribution
    Parabola GNU/Linux
    Environnement
    i3wm
    Messages
    2 851
    En effet, ca fonctionne.

    Cependant je me rappelles que sur 10.2, j'avais le message d'erreur m'alertant que le login et mot de passe étaient mauvais (comme si on se trompait de login/mot de passe), lors de la connexion en root.

    Avec ta solution, j'ai les lignes de connexions, sauf qu'il revient à l'invite de connexion <== si c'est clair pour les autres

    Oui, je sais, je suis pointilleux... .
    :rolleyes:

    Edit :
    Dans Yast > Sécurité utilisateurs > Modifier et créer des utilisateurs... On peut bien cocher une case "Désactiver le login" pour root, mais alors je n'y ai plus accès via su ni sudo... .
    Carte mère : ASUS A8V Deluxe | Processeur : ATHLON 64 3000+ | Mémoire RAM : DDR400 2 x 512 MB DUALBAND
    Carte graphique : MSI geForce NX6200AX 128DDR | Carte son : SBLive ! + Carte intégrée ?* la carte mère Realtech ALC850 codec non-utilisée

  4. #4
    Bonjour,

    A mon avis, il faudrait intervenir dans la configuration du gestionnaire de connexion kdm (=page de login au boot).

    Ça se trouve ici: /opt/kde3/share/config/kdm.

    Le manuel de kdm (en français) est ici: http://docs.kde.org/stable/fr/kdebase/kdm/.

    Et la doc sur le fichier de config kdmrc est ici: http://docs.kde.org/stable/fr/kdebase/kdm/...iles.html#kdmrc.

    L'option "AllowRootLogin" est dans la section [X-*-Core] de kdmrc.

    Tyrtamos
    Tant que les ordinateurs ne trouvent pas eux-mêmes les prises de courant, nous avons des chances de maitriser la situation...

    Mes recettes linux et python: http://www.jpvweb.com

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé