Page 1 sur 23 12311 ... DernièreDernière
Affiche les résultats de 1 à 10 sur 230

Sujet : Le topic officiel des drivers NVIDIA [195.36.15]

  1. #1
    Grand caméléon Avatar de Burn2
    Inscrit
    mai 2007
    Distribution
    openSUSE 12.3 (64 bits)
    Environnement
    Xfce
    Messages
    4 549
    <div align='center'></div>

    Bonjour/bonsoir!
    Je me dis donc en ce moment, il y a plein de drivers et pour une fois linux n'est pas oublié!!! Alors pourquoi ne pas faire un topic spécial drivers nvidia????
    Surtout que je vois partout passer plein de questions alors, autant centraliser les questions, et les infos.

    Le but de ce topic sera donc de recenser:
    *Dernier driver beta (liste des nouveautés) (installables donc uniquement par compilation)
    *Dernier driver stable (liste des nouveautés par rapport aux précédents)
    *Dernier driver legacy





    0) Rappels
    Il y a plusieurs méthodes pour installer ces drivers:
    * Yast
    * Compilation
    ===> voir wiki

    *Compilation automatique
    ===> Voir mon topic sur mon script automatisant ça






    I) Le dernier Drivers
    Actuellement la dernière version est la version195.36.15 X86 sous linux disponibles en français ==>ici<===

    <div class='quotetop'>Citation </div>
    Principales caractéristiques de cette version

    Fixed a bug that caused the X server to crash when renderingoccurred while the X server was not on the active VT.
    Fixed a regression that caused the driver to fail to properly adjustthe GPU fan speed on some GPUs.
    Fixed a bug that prevented performance level transitions on recentGPUs with SDDR3 and GDDR5 memory.
    Added support for the following GPUs:
    Quadro FX 880M
    GeForce GTS 350M
    GeForce GTS 360M
    Added support for NVIDIA 3D Vision Stereo on Linux with Quadro GPUs. See the "Stereo" X configuration documentation in the README
    for details.
    Fixed a bug that caused screen corruption after an application released a GLX_NV_present_video device.
    Fixed an X server crash caused by starting nvidia-settings while X was not on the active VT.
    Fixed brightness control hotkeys on some laptops.
    Fixed an nvidia-settings bug that produced many "Bad argument" warning messages when running nvidia-settings --query all.
    Fixed an installer bug that produced the following message:
    WARNING: Unable to perform the runtime configuration check for library 'libGL.so.1' ('/usr/lib/libGL.so.195.36.03'); assuming successful installation.
    Fixed a bug that caused G-Sync stereo synchronization to fail sometimes when enabling frame lock.
    Fixed a bug that caused OpenGL applications to occasionally crash with "double free or corruption" messages when exiting.
    On GPUs with VDPAU feature set A, enhanced VDPAU's handling of some corrupted or incorrectly formatted MPEG-1/2 streams. This solves a reported issue with "0testbad.mpg".
    Fixed a bug in the VDPAU video mixer that caused chroma aberrations, and corruption in the right-hand few columns of pixels, when post- processing video surfaces with widths not an exact multiple of 4 pixels.
    Fixed a bug that prevented the GPUFanControlState attribute from being set on the nvidia-settings command line.
    Fixed a regression that made the "TVStandard" X configuration option cause system hangs with products from the GeForce 6 and 7 series.
    Worked around a bug in some AUO laptop flat panels where the native mode in the EDID is invalid, leading to a 640x480 desktop repeated six times
    across the screen.
    Increased the maximum number of slices supported by VDPAU for MPEG-2 streams, in ***** to cope with the region 1 DVD "A Christmas Story".
    Added unofficial preliminary support for xorg-server video driver ABI version 7, including xorg-server-1.7.99.2.
    Fix the soname of libvdpau_nvidia.so.1 and libvdpau_trace.so.1 to match their filenames.
    Fixed a performance regression with non-antialiased text in KDE4.
    Enabled GPU acceleration for many RENDER compositing operations that were previously processed in software, including conjoint and disjoint blending
    modes and component alpha blending.
    Added experimental GPU acceleration of the RENDER CompositeTrapezoids operation. This can be enabled at runtime by running:
    nvidia-settings -a AccelerateTrapezoids=1
    This is only supported on the GeForce GTX series or newer products.
    Fixed a bug in the VDPAU overlay-based presentation queue that caused high CPU usage during "put bits" operations when more than two surfaces
    were queued.
    Updated `nvidia-settings --query all` to report all available attributes queryable through all NV-CONTROL target types.
    Enhanced the VDPAU blit-based presentation queue to provide values of "first_presentation_time" that have less jitter.
    Add support for R16F and RG32F GLXFBConfigs when using GeForce 8 series and higher GPUs.
    Added support for A2BGR10 32-bit GLX visuals on 30-bit X screens. These allow some level of window transparency when using 30-bit visuals with GLX and Composite, but they may cause problems with older X servers and/or applications.ARGB GLX visuals can be disabled by adding:
    Option "AddARGBGLXVisuals" "False" to the X configuration file.
    Fixed a problem that caused DisplayPort devices to behave incorrectly when DPMS power saving mode was triggered.
    Updated VDPAU to improve thread concurrency.See the README for details.
    Altered NVIDIA X driver behavior in the case that no display devices are connected to the GPU.Previously, in this case, the NVIDIA X driver would pretend a CRT was connected to the GPU. Now, the NVIDIA X driver will not automatically pretend that any CRTs are connected.If the X driver does not detect any connected display devices, the X server will fail to start.
    To restore the old behavior, use the ConnectedMonitor X configuration option; e.g.,
    Option "ConnectedMonitor" "CRT"
    Alternatively, if display is not desired, Quadro and Tesla GPU users can enable "NoScanout" mode, which bypasses any mode timing validation or use of display devices; this is configured with:
    Option "UseDisplayDevice" "none"
    Disabled software cursors when the driver is operating in "no scanout" (UseDisplayDevice "none") mode.The software cursor image is not visible in remote desktop applications or screenshots anyway, so having software cursor enabled was unnecessary.
    Changed glXSwapBuffers() behavior for a pixmap such that it is now a no-op in the direct rendering case in ***** to match the indirect case and comply with the GLX spec. Previously, calling glXSwapBuffers() on pixmaps in the direct case would swap the pixmap's buffers if the pixmap was double buffered.
    Modified the installation location and names of internal VDPAU libraries to conform to conventions and Debian packaging guidelines. New versions of libvdpau expect this layout. Compatibility with old versions of libvdpau is maintained with symlinks.
    Fixed a bug that could cause errors in graphical applications run after a previous application using VDPAU and OpenGL. This behaviour was observed when running Gwenole Beauchesne's hwdecode-demos application.
    Modified vdpau.h to increment VDPAU_VERSION, to reflect the fact that new features have been added in the past. Also, add the new define VDPAU_INTERFACE_VERSION.
    Fixed a periodic temporary hang in the VDPAU blit-based presentation queue.
    Fixed a problem that caused resolution limitations or corruption on certain DisplayPort devices such as the Apple 24" Cinema display or some DisplayPort to VGA adapters.
    Disabled the UseEvents option for GeForce 8 series and higher GPUs due to a problem that causes occasional short hangs.It will be re-enabled when that bug has been tracked down and fixed.
    VDPAU now allows multiple streams to be decoded at once, without the need to set any environment variables.[/b]





    II) Les drivers dispo dans yast
    195.36.15 (X86)








    III) Les derniers Legacy
    http://www.nvidia.com/object/unix.html





    Ce topic n'aura pas pour but d'expliquer comment installer les drivers, éventuellement en cas de problème l'aide sera apportée, ça permettra de centraliser les infos, je mettrais juste un lien vers la documentation pour l'installation des drivers nvidia, et un lien vers mon script de compilation automatique.
    Je n'ai pour le moment mis que des liens vers les version 32bit



    To be continued soon

  2. #2
    Grand caméléon Avatar de Burn2
    Inscrit
    mai 2007
    Distribution
    openSUSE 12.3 (64 bits)
    Environnement
    Xfce
    Messages
    4 549
    Powermizer configuration
    Voici la source qui explique comment faire:
    http://tutanhamon.com.ua/technovodst...A-UNIX-driver/

    Et voici mon exemple:
    <div class='quotetop'>Citation </div>
    Section "Device"
    BoardName "GeForce Go 6600 (0x0148)"
    Driver "nvidia"
    Identifier "Device[0]"
    VendorName "NVidia"
    Option "DynamicTwinView" "false"
    Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2233; PowerMizerDefault=0x3"
    EndSection[/b]
    Avec ça:
    Gpu en mode on demand une fois sur secteur. (ça change bien de mode quand je bascule de 3D au bureau)
    Gpu en mode autonomie max une fois sur batterie!

    Les possibilités sont:
    Batterie mode autonomie max, secteur mode perf max
    <div class='quotetop'>Citation </div>
    "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x1"[/b]
    Batterie mode autonomie max, Secteur mode Adaptif (idéal!)
    <div class='quotetop'>Citation </div>
    "PowerMizerEnable=0x1; PerfLevelSrc=0x2233; PowerMizerDefault=0x3"[/b]
    Sur batterie mode adaptif, sur secteur mode performance max
    <div class='quotetop'>Citation </div>
    "PowerMizerEnable=0x1; PerfLevelSrc=0x3322; PowerMizerDefaultAC=0x1"[/b]
    Mode adaptif pour toutes les sources:
    <div class='quotetop'>Citation </div>
    "PowerMizerEnable=0x1; PerfLevelSrc=0x3333"[/b]

  3. #3
    estoclet
    Guest
    COUP DE GUEULE !


    Je suis l'heureux possesseur d'un portable HP Pavilion dv6585ef equipé d'une NVIDIA GeForce 8400M.

    J'ai été un grand fan d'opensuse depuis la version 9.1 à la version 10 suite à quoi, j'ai voulu tester Ubuntu avec qui je suis resté depuis...

    Tombant par hasard sur un DVD opensuse 10.3 - 64 BITS, je me suis dit que ce serait bien de retourner à mes premières amours et redécouvrir le plaisir d'utiliser opensuse...

    Au moment d'installer le driver Nvidia, j'ai commencé à déchanter... Quelque soit la méthode utilisée (Yast, script sh de Nvidia ou autre script automatique trouvé ici), il est impossible d'avoir un rendu 3D fonctionnel. En fait, une fois que je remplace "nv" par "nvidia" dans xorg.conf, je n'ai plus de serveur X...

    Pour ceux qui connaissent Ubuntu, sur une installation fraïche, on sélectionne dans le menu gnome Système > Administration > Gestionnaire de pilotes propriétaires et en fin, on coche "Activer le pilote Nvidia" et la 3D est activée au redémarrage de X

    Qu'arrive t il aux développeurs de Yast ??? Pour toutes les fois où j'ai conseillé à un newbie de débuter avec opensuse ou ubuntu, je me suis bien trompé... J'espère que la plupart on pris le second choix et que les autres ne se sont pas pendus...

    Connaissez vous ce "bug" de l'installation des driver Nvidia ?? Avez vous aussi eu de telles mésaventures ?

  4. #4
    Grand caméléon Avatar de Burn2
    Inscrit
    mai 2007
    Distribution
    openSUSE 12.3 (64 bits)
    Environnement
    Xfce
    Messages
    4 549
    Personnellement tout va bien et tout marche bien, mais je suis entièrement d'accord avec toi, sous Ubuntu c'est beaucoup plus facile et mieux intégrés.

  5. #5
    Grand caméléon Avatar de Burn2
    Inscrit
    mai 2007
    Distribution
    openSUSE 12.3 (64 bits)
    Environnement
    Xfce
    Messages
    4 549
    Nouveau drivers out: 169.09
    <div class='quotetop'>Citation </div>
    * Problème résolu à propos du ventilateur de certains GPU qui tournait sans arrêt à plein régime.
    * Problème résolu qui provoquait un plantage du pilote X si le module d’extension X.0rg GLX était installé au lieu de celui de NVIDIA.
    * Amélioration de la notoriété du pilote X de l’état actuel d’installation de portable sur station d’accueil.
    * Contrôle du contraste résolu sur les PC portables HP Compaq.
    * Problème résolu dans la mise en oeuvre du pilote de l’algorithme Linux/i2c qui empêchait de réaliser des types de transferts principaux.[/b]

  6. #6
    Caméléon arc-en-ciel Avatar de Heero_Yuy
    Inscrit
    juillet 2006
    Lieu
    Sur Terre et dans l'Espace
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    Gnome
    Messages
    6 666
    Merci de l'info Burn2 (je l'ai vu sur PC Inpact) - tu aurais peut-être dû en faire une news sur Alio aussi
    http://www.april.org/files/associati...ext_486x60.png
    http://elivecd.org/assets/images/eli...ontent_sh1.png
    Ma config : Portable Dell Inspiron 1525 - Core 2 Duo T8300 2.4GHz - RAM 4 Go - HDD 320 Go - Intel X3100 - Intel Corporation PRO/Wireless 4965
    Système : openSUSE 12.1 64 bits - Gnome-Shell
    http://elivecd.org/assets/images/eli...ontent_sh2.png

  7. #7
    Grand caméléon Avatar de Burn2
    Inscrit
    mai 2007
    Distribution
    openSUSE 12.3 (64 bits)
    Environnement
    Xfce
    Messages
    4 549
    Ben justement ce topic est là pour servir de news, je me suis dit que sinon y aurait trop de news sur les drivers à chaque nouvelle sortie, D'ou l'intérêt d'un seul post qui rassemble tout.

  8. #8
    Caméléon arc-en-ciel Avatar de Heero_Yuy
    Inscrit
    juillet 2006
    Lieu
    Sur Terre et dans l'Espace
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    Gnome
    Messages
    6 666
    Oki
    http://www.april.org/files/associati...ext_486x60.png
    http://elivecd.org/assets/images/eli...ontent_sh1.png
    Ma config : Portable Dell Inspiron 1525 - Core 2 Duo T8300 2.4GHz - RAM 4 Go - HDD 320 Go - Intel X3100 - Intel Corporation PRO/Wireless 4965
    Système : openSUSE 12.1 64 bits - Gnome-Shell
    http://elivecd.org/assets/images/eli...ontent_sh2.png

  9. #9
    svapunk
    Guest
    Hello,

    Juste vous dire que avec ce dernier driver compiz-fusion marche sans problême d'écran blanc!

    J'ai une carte graphique nvidia GeForce 6600 GT

    En suivant le tuto et après avoir fait rcxdm restart nul besoin de lancer manuellement compiz-fusion...il le fait tous seul!
    Cool

    A plus

  10. #10
    xraimeix
    Guest
    Bien bien.. bonne initiative qui tombe à point nomé!!

    Ho pardon, bien le bonsoir ou bonjour (qd même!!).

    j'ai voulu installer les derniers drivers nvidia pour ma carte (voir ma signature) ceux à mettre à la main, en général ils sont plus performants (enfin soit) donc ceux à mettre avec "sh <nomdriver>.run" mais lorsque je veux les installer il me dis que mon kernel n'est pas compilé ni rien. et dis après que l'installation est un echec.

    Hors normalement mon kernel est compilé, et puis la dernière fois que j'avais mis un drivers nvidia il avait fiat ça tout seul comme un grand...

    quelqu'un peut me dire comment faire pour compiler alors...alors j'ai essaye la commande "make menuconfig", "make config" "make xconfig" et "make gconfig" sans résultat il me dit que make n'as pas trouvé la cible ou j'sai splus quoi (j'suis pas sous linux là...sorry)

    hors il faut je sais installer les branche -dev de soit gtk, soit ncurse, soit QT, mais cela est fais pour les trois. donc je ne sais pas quoi faire.

    (j'dis ça parceuqe j'ai téléchargé le nouveau kernel 2.6.24 au cas où)


    enfin si vous piger quelque chose à ce que je raconte, pouvez vous m'aiguiller, svp




    ah pour ceux qui se demande pourquoi mettre les derniers drivers nvidia chez moi, ben c'est pour essayer de résoudre un autre problème de résolution. (aller voir dans les topic matériel)

    Voilà merci

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé