Affiche les résultats de 1 à 8 sur 8

Sujet : openSUSE 11.3 et Kernel Mode Setting

  1. #1
    Administrateur Administrateur Avatar de manchette
    Inscrit
    aot 2005
    Lieu
    Mulhouse :-)
    Distribution
    openSUSE Leap 15.1 et + si dispo
    Environnement
    KDE Plasma 5
    Messages
    8 743
    Billets
    56

    Talking

    Salux

    Vous avez peut être remarqué que Suse a intégré a partir de la version openSUSE 11.3 un nouveau fonctionnement en ce qui concerne la gestion des cartes graphiques, l'idée étant de privilégier les drivers libres.
    Certains dysfonctionnements pourront parfois en résulter, mais ouf il y a moyen de faire différemment si besoin

    Les drivers : (driver libre //driver propriétaire)

    Nvidia : nouveau // nv , nvidia (apparemment nv n'apporte pas la 3 D (?) )

    Ati : radeon // radeonhd

    Intel : intel // fbdev



    Comme je le pressentait Kernel Mode Setting (KMS) fait parler de lui.
    Les notes de version expliquent cela , il est important de prendre le temps de les lire si possible
    "Aspect technique
    Initializing Graphics with KMS (Kernel Mode Setting)
    With openSUSE 11.3 we are switching to KMS (Kernel Mode Setting) for Intel, ATI and NVIDIA graphics, which now is our default. If you encounter problems with the KMS driver support (intel, radeon, nouveau), disable KMS by adding nomodeset to the kernel boot command line. To set this permanently, add it to the kernel command line in /boot/grub/menu.lst. This option makes sure the appropriate kernel module (intel, radeon, nouveau) is loaded with modeset=0 in initrd, i.e. KMS is disabled.
    In the rare cases when loading the DRM module from initrd is a general problem and unrelated to KMS, it is even possible to disable loading of the DRM module in initrd completely. For this set the NO_KMS_IN_INITRD sysconfig variable to yes via YAST, which then recreates initrd afterwards. Reboot your machine.
    On Intel without KMS the Xserver falls back to the fbdev driver (the intel driver only supports KMS). On ATI for current GPUs it falls back to radeonhd. On NVIDIA without KMS the nv driver is used (the nouveau driver only supports KMS).
    "


    --> Voici ce que l'on peut faire pour ce qui concerne NVIDIA :

    Installer par Yast:
    -Gcc
    -Make
    -Kernel-source


    J'ai changé 2 fois le driver pour ma carte graphique Nvidia : le driver libre nouveau en nv, puis enfin le driver nv en nvidia pour avoir la 3D (j'avais auparavant téléchargé le driver propriétaire sur mon disque, cf http://www.nvnews.net/vbulletin/showthread.php?t=122606 ).

    Ensuite il faut ajouter l'option nomodeset au kernel. Pour ca on modifie le fichier /boot/grub/menu.lst pour la ligne du kernel et on y ajoute en bout de ligne l'option nomodeset (paragraphes desktop et failsafe).
    Cela permet de passer au driver nv mais la 3D est absente (on ne peut installer nvidia directement car le driver nouveau et le réglage de KMS par défaut bloquent)

    Puis on installe le driver propriétaire dernier en date (nvidia) en console :
    fermer la session
    ctrl+alt+F1
    login : root + mdp
    # init 3
    cd /chemin_de_stockage_du_driver
    sh NVIDIA...x86.run
    valider valider ...
    rebooter : # shutdown -r now
    Aucun dysfonctionnement vu par ailleurs pour le moment, on a bien la 3D qui est activée selon sysinfo:/

    Informations sur l'affichage
    Fabricant : nVidia Corporation
    Modèle : GeForce 7900 GS
    Pilote 2D : nvidia
    Pilote 3D : NVIDIA 256.35




    Merci de compléter si besoin pour les autres marques : Ati, Intel

    --> ATI :

    a compléter par les possesseurs de ces cartes

    exple :
    http://lizards.opensuse.org/2010/07/15/ati...ers-under-11-3/



    --> INTEL :
    a compléter par les possesseurs de ces cartes

  2. #2
    Salut à tous,
    merci pour votre aide..

    Bon j'ai essayé avec le driver propriétaire donné en lien...mais rien à faire...il me refuse car il n'y a pas le xorg ....

    Ensuite j'ai essayé avec modeset = 0 .. mais idem ...je ne vois rien qui a changé...

    Pour ce qui est de ma carte ATI ...il me semble qu'il s'agit d'une HD300 ..de mémoire ..mais je n'en suis plus trop certain..
    J'ai fait un dmesg...mais je n'ai rien vu qui pourrait me l'indiquer...

    Je me demande si je ne vais pas carrément refaire une nouvelle install ...cette fois ci en formattant carrément de répertoire /home..
    car je rencontre d'autres problèmes...notement dans mes fichiers open - calc..qui comprenait des liaisons avec d'autres fichiers open - calc..et qu'il ne reconnait plus ..J'ai bien vérifié au niveau des liaison et tout ça me semble bon ( d'ailleurs je n'y ait même pas touché ) .... bizarre que ça ne l'ait pas repris..

    Qu'en pensez vous de refaire une install complète... est ce que ça va régler mes problèmes ?

    Merci d'avance

    a+




  3. #3
    Administrateur Administrateur Avatar de manchette
    Inscrit
    aot 2005
    Lieu
    Mulhouse :-)
    Distribution
    openSUSE Leap 15.1 et + si dispo
    Environnement
    KDE Plasma 5
    Messages
    8 743
    Billets
    56
    Plus d'informations : http://wiki.opensuse.org/SDB:Configuring_graphics_cards

    Apparemment le driver Nvidia sera disponible d'icu peu

  4. #4
    neurotux
    Guest
    Bonjour,

    Pour la 11.3, "NVidia Repository" est disponible dans les dépôts communautaires. Le pilote est toujours en version 195.36.31.

    Il est à noter que l'installation des paquets pour le pilote NVidia supprime la valeur 'NO' de la variable 'NO_KMS_IN_INITRD'.

    Salut.

  5. #5
    newbielinux
    Guest
    Bonjour.
    Je viens d'installer la 11.3 puis le driver ATI (one click install) impossible de rebooter pour moi.
    Ma carte est une HD 5850.
    Je peux faire quoi ou qu'est ce que j'ai fait de faux?

  6. #6
    Caméléon tenace Modérateur Avatar de Denebe
    Inscrit
    janvier 2007
    Lieu
    Berlin
    Distribution
    openSUSE Leap 15.1 (64 bits)
    Environnement
    plasma 5.12.8
    Messages
    1 253
    Citation Envoyé par newbielinux
    Bonjour.
    Je viens d'installer la 11.3 puis le driver ATI (one click install) impossible de rebooter pour moi.
    Ma carte est une HD 5850.
    Je peux faire quoi ou qu'est ce que j'ai fait de faux?[/b]
    Salut,

    Si tu arrives en ligne de commande, logues-toi en root via
    Code:
    su
    ensuite tu saisies ton mot de passe root, puis tu tapes
    Code:
    aticonfig  --initial
    et tu rebootes
    Code:
    reboot
    Sinon, ce topic est plus pour les pilotes libres que proprio, le topic pour les proprio c'est http://www.alionet.org/index.php?showtopic=23635

    Un peu de patience ça devrait s'arranger
    Dimensions Moebius Sésamath
    KDE SC 5.0 on peut rêver non ?

  7. #7
    Caméléon bavard Avatar de prof01
    Inscrit
    mars 2005
    Lieu
    AIN
    Distribution
    Opensuse13.2 (64bits) Debian 64 bits et ArchLinux 64 bits
    Environnement
    KDE
    Messages
    646
    Merci d l'info. Je me posais des questions (même le live CD refusait d'arriver au lancement de l'interface graphique)
    Divers Linux sur fixe et portable
    Raspbian et utilisation Python sur Raspberry Pi


    L'erreur n'annule pas la valeur de l'effort accompli

  8. #8
    Caméléon bavard Avatar de prof01
    Inscrit
    mars 2005
    Lieu
    AIN
    Distribution
    Opensuse13.2 (64bits) Debian 64 bits et ArchLinux 64 bits
    Environnement
    KDE
    Messages
    646
    Pour Opensuse 12.2 même chose. Sans l'option nomodeset, écran fig au démarrage et reboot sauvage.
    Divers Linux sur fixe et portable
    Raspbian et utilisation Python sur Raspberry Pi


    L'erreur n'annule pas la valeur de l'effort accompli

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé