Affiche les résultats de 1 à 8 sur 8

Sujet : Help dual boot suse 11.4 avec XP : soucis !

  1. #1
    Léon
    Inscrit
    novembre 2011
    Distribution
    openSUSE 11.4 (32bits)
    Environnement
    KDE
    Messages
    2

    Help dual boot suse 11.4 avec XP : soucis !

    Bonjour d'un débutant.

    J'utilise Ubuntu sur une machine séparée et tout va bien. Par contre , je viens d installer la suse 11.4 kde sur une machine ayant dejà XP sur un premier disque , ceci sur un second disque /dev/sdb.
    En fin d'install de la suse, je n ai pas eu le choix pour le lanceur, et en rebootant la machine, je n' avais plus accès a XP, seulement la suse qui tourne très vite sur cette machine.

    J'ai reussi à remettre en route XP avec le cd d install et la fonction R de réparer. (fixboot et fixmbr), donc Je n ai plus accès a la suse, et devant le tas de docs sur le sujet je suis un peu perdu et ne souhaite pas planter xp qu utililse mon épouse.

    Que faire ? Un article de Tyrtamos sur Installation multiboot linus suse windosw xp donne une solution qui ne marche pas étant donné que la suse ne laisse pas le choix pour l install. Grub est t il obligatoire ? ou y a t il d autres bootloaders plus faciles ?
    Il est question de BOOTPART que je ne connais pas du tout.
    Quelles sauvegardes faire pour ne pas perdre XP ?

    Merci de vos conseils et bon dimanche ! j'ai un compte skype si ca peut servir
    cordialement
    joseph

  2. #2
    Caméléon arc-en-ciel
    Inscrit
    décembre 2004
    Lieu
    France
    Distribution
    openSUSE 11.4 (64bits)
    Environnement
    Gnome
    Messages
    5 579
    Billets
    1
    Tu es débutant, c'est pour cela que tu n'as pas choisi la bonne solution.
    Linux sait démarrer Windows, même Seven et Vista.
    L'inverse n'est pas évident, même avec Vista et Seven.
    Deux possibilités :
    --
    edémarrer l'installation, choisir Mise à jour. Si de là, tu peux accédeer au paramétrage du "gestionnaire d'amorçage", choisis comme emplacement d'installation de grub : MBR, soit /dev/sda
    Ensuite, dans la Gestion des sections, vérifie que dans "Section du chargeur de chaine", XP est présent en tant que /dev/sda1 (installation standard, généralement. Sinon, ajoute une section "non Linux", où tu inscris deux infos :
    -Nom de la section : windows XP
    -La partition où XP est installé, généralerment /dev/sda1.
    Vérifie que le menu de démarrage apparaisse au moins 10 secondes, car la 11.4 démarre par défaut. aAnsi, tu as le temps de choisir le système à démarrer.

    Si la 11.4 ne peut démarrer, il est possible, maispas sûr, de la redémarrer par ce même média d'installatio, en choisissant Abort, ce qui t'amène à une fenêtre affichant plusieurs options :
    -Installation,
    -boot installed systems : là tu choisis le démarrage de la partition racine de la 11.4. Mais cette procédure ne fonctionne pas systématiqsuement.
    Maintenant, j'utilise Mandriva. Je vais démarretr la 11.4
    A plus
    Enregistre les modifications
    Dernière édition par ahlner; 06/11/2011 à 19h30
    ahlner


    Ce qui reste éternellement incompréhensible dans la nature, c'est que l'on puisse la comprendre.
    Albert Einstein

  3. #3
    Caméléon bavard
    Inscrit
    mars 2011
    Distribution
    openSUSE 11.4 (32bits)
    Environnement
    Gnome
    Messages
    593
    Salut,

    j'ai eu le même problème. Il faut installer le chargeur de démarrage OpenSuse sur la partition racine, et non dans le MBR (Master Boot Record). Au niveau de la configuration du Grub, j'ai effectué des réglages sur une autre machine, mais je ne pourrai les poster que demain.

  4. #4
    Caméléon arc-en-ciel
    Inscrit
    décembre 2004
    Lieu
    France
    Distribution
    openSUSE 11.4 (64bits)
    Environnement
    Gnome
    Messages
    5 579
    Billets
    1
    Citation Envoyé par ahlner Voir le message
    Tu es débutant, c'est pour cela que tu n'as pas choisi la bonne solution.
    Linux sait démarrer Windows, même Seven et Vista.
    L'inverse n'est pas évident, même avec Vista et Seven.
    Deux possibilités :
    --
    edémarrer l'installation, choisir Mise à jour. Si de là, tu peux accédeer au paramétrage du "gestionnaire d'amorçage", choisis comme emplacement d'installation de grub : MBR, soit /dev/sda
    Ensuite, dans la Gestion des sections, vérifie que dans "Section du chargeur de chaine", XP est présent en tant que /dev/sda1 (installation standard, généralement. Sinon, ajoute une section "non Linux", où tu inscris deux infos :
    -Nom de la section : windows XP
    -La partition où XP est installé, généralerment /dev/sda1.
    Vérifie que le menu de démarrage apparaisse au moins 10 secondes, car la 11.4 démarre par défaut. aAnsi, tu as le temps de choisir le système à démarrer.

    Si la 11.4 ne peut démarrer, il est possible, maispas sûr, de la redémarrer par ce même média d'installatio, en choisissant Abort, ce qui t'amène à une fenêtre affichant plusieurs options :
    -Installation,
    -boot installed systems : là tu choisis le démarrage de la partition racine de la 11.4. Mais cette procédure ne fonctionne pas systématiqsuement.
    Maintenant, j'utilise Mandriva. Je vais démarretr la 11.4
    A plus
    Enregistre les modifications
    Gestion des sections :

    Capture-Paramètres du chargeur d'amorçage - YaST.jpg


    Choix de l'emplacement de grub :

    Capture-Paramètres du chargeur d'amorçage - YaST-1.jpg

    Dans la première capture : édition et modification des paramètres de section.
    Dans la deuxième, choix de l'emplacement de grub-stage1.
    Comme grub peut démarrer presque n'importe quel système, dont les Windows, il est préférable de placer grub (-stage&) dans le MBR.
    Ma config est spéciale : c'est Mandriva et non openSUSE qui démarre tous les systèmes. C'est pour cela que le grub de openSUSE 11.4 est dans sa racine et non dans le MBR.
    Dans la première capture, il est possible de choisir le système à démarrer par défaut, ainsi que le temps d'attente.
    ahlner


    Ce qui reste éternellement incompréhensible dans la nature, c'est que l'on puisse la comprendre.
    Albert Einstein

  5. #5
    Caméléon bavard
    Inscrit
    mars 2011
    Distribution
    openSUSE 11.4 (32bits)
    Environnement
    Gnome
    Messages
    593
    Salut,

    désolé, j'ai pas eu le temps aujourd'hui de vérifier les paramètres présents dans : Options du chargeur d'amorçage. Je vérifierai cela demain.

  6. #6
    Caméléon bavard
    Inscrit
    mars 2011
    Distribution
    openSUSE 11.4 (32bits)
    Environnement
    Gnome
    Messages
    593
    Bonsoir,

    désolé pour le retard. Bon, concernant le double amorçage Windows XP/OpenSuse 11.4, j'ai installé Grub dans la partition racine Linux (/). Au niveau des paramètres, ou choix, concernant le chargeur d'amorçage Grub, j'ai coché uniquement les options suivantes : Emplacement du chargeur d'amorçage -> Amorce à partir de la partition racine. Options du chargeur d'amorçage -> Définir le marqueur 'active' dans la table des partitions pour la partition d'amorçage.

    Voilà.

  7. #7
    Caméléon arc-en-ciel
    Inscrit
    décembre 2004
    Lieu
    France
    Distribution
    openSUSE 11.4 (64bits)
    Environnement
    Gnome
    Messages
    5 579
    Billets
    1
    Et ça marche ou pas?
    Résolu ou non?
    Dernière édition par ahlner; 12/11/2011 à 15h15
    ahlner


    Ce qui reste éternellement incompréhensible dans la nature, c'est que l'on puisse la comprendre.
    Albert Einstein

  8. #8
    Léon
    Inscrit
    novembre 2011
    Distribution
    openSUSE 11.4 (32bits)
    Environnement
    KDE
    Messages
    2
    bonjour et merci des docs. J'ai pas encore fait la manip mais suis presque prêt ! Je tiens au courant ensuite encore merci !
    cordialement
    JM

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé