openSUSE Security Update: update for file
__________________________________________________ ____________________________

Announcement ID: openSUSE-SU-2012:0488-1
Rating: low
References: #753303
Cross-References: CVE-2012-1571
Affected Products:
openSUSE 12.1
openSUSE 11.4
__________________________________________________ ____________________________

An update that fixes one vulnerability is now available.

Description:

specially crafted CDF files could crash the "file" program


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.1:

zypper in -t patch openSUSE-2012-221

- openSUSE 11.4:

zypper in -t patch openSUSE-2012-221

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.1 (i586 x86_64):

file-5.08-7.4.1
file-debuginfo-5.08-7.4.1
file-debugsource-5.08-7.4.1
file-devel-5.08-7.4.1
python-magic-5.08-7.4.1

- openSUSE 12.1 (x86_64):

file-32bit-5.08-7.4.1
file-debuginfo-32bit-5.08-7.4.1

- openSUSE 11.4 (i586 x86_64):

file-5.04-13.1
file-debuginfo-5.04-13.1
file-debugsource-5.04-13.1
file-devel-5.04-13.1
python-magic-5.04-13.1
python-magic-debuginfo-5.04-13.1
python-magic-debugsource-5.04-13.1

- openSUSE 11.4 (x86_64):

file-32bit-5.04-13.1
file-debuginfo-32bit-5.04-13.1


References:

http://support.novell.com/security/c...2012-1571.html
https://bugzilla.novell.com/753303