openSUSE Security Update: update for taglib
__________________________________________________ ____________________________

Announcement ID: openSUSE-SU-2012:0490-1
Rating: moderate
References: #750689 #750690 #750691 #750693
Cross-References: CVE-2012-1107 CVE-2012-1108 CVE-2012-1584

Affected Products:
openSUSE 12.1
__________________________________________________ ____________________________

An update that solves three vulnerabilities and has one
errata is now available.

Description:

Specially crafted ogg files could crash taglib


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.1:

zypper in -t patch openSUSE-2012-218

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.1 (i586 x86_64):

libtag-devel-1.7-8.4.1
libtag1-1.7-8.4.1
libtag1-debuginfo-1.7-8.4.1
libtag_c0-1.7-8.4.1
libtag_c0-debuginfo-1.7-8.4.1
taglib-1.7-8.4.1
taglib-debugsource-1.7-8.4.1

- openSUSE 12.1 (x86_64):

libtag1-32bit-1.7-8.4.1
libtag1-debuginfo-32bit-1.7-8.4.1
libtag_c0-32bit-1.7-8.4.1
libtag_c0-debuginfo-32bit-1.7-8.4.1

- openSUSE 12.1 (ia64):

libtag1-debuginfo-x86-1.7-8.4.1
libtag1-x86-1.7-8.4.1
libtag_c0-debuginfo-x86-1.7-8.4.1
libtag_c0-x86-1.7-8.4.1


References:

http://support.novell.com/security/c...2012-1107.html
http://support.novell.com/security/c...2012-1108.html
http://support.novell.com/security/c...2012-1584.html
https://bugzilla.novell.com/750689
https://bugzilla.novell.com/750690
https://bugzilla.novell.com/750691
https://bugzilla.novell.com/750693