Affiche les résultats de 1 à 5 sur 5

Sujet : YAST. Espace disque faible sur /run/media/USERS/Réservé au système

  1. #1
    Léon
    Inscrit
    aot 2016
    Distribution
    openSUSE Leap 42.1 (64 bits)
    Environnement
    Xfce
    Messages
    13

    YAST. Espace disque faible sur /run/media/USERS/Réservé au système

    Bonjour
    J'utilise linux depuis longtemps (debian) mais opensuse depuis peu (1 semaine ;-)
    Installation et paramétrage impeccable
    Par contre je relève un soucis avec yast quand j'installe un nouveau logiciel
    j'ai le retour suivant
    Code:
     Espace disque faible sur /run/media/cyrille/Réservé au système
    Je ne suis pas habitué à ce découpage de partition

    Voici un df -f montrant pourtant que ce n'est utilisé qu'à 25%
    Code:
    cyrille@linux-4seb:~> df -h
    Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
    devtmpfs           2,9G    8,0K  2,9G   1% /dev
    tmpfs              2,9G    324K  2,9G   1% /dev/shm
    tmpfs              2,9G    2,3M  2,9G   1% /run
    tmpfs              2,9G       0  2,9G   0% /sys/fs/cgroup
    /dev/sda6           41G    9,3G   30G  24% /
    /dev/sda6           41G    9,3G   30G  24% /.snapshots
    /dev/sda6           41G    9,3G   30G  24% /var/tmp
    /dev/sda6           41G    9,3G   30G  24% /var/spool
    /dev/sda6           41G    9,3G   30G  24% /opt
    /dev/sda6           41G    9,3G   30G  24% /usr/local
    /dev/sda6           41G    9,3G   30G  24% /var/lib/pgsql
    /dev/sda6           41G    9,3G   30G  24% /var/opt
    /dev/sda6           41G    9,3G   30G  24% /var/crash
    /dev/sda6           41G    9,3G   30G  24% /var/lib/named
    /dev/sda6           41G    9,3G   30G  24% /var/lib/libvirt/images
    /dev/sda6           41G    9,3G   30G  24% /var/lib/mailman
    /dev/sda6           41G    9,3G   30G  24% /var/lib/mysql
    /dev/sda6           41G    9,3G   30G  24% /var/lib/mariadb
    /dev/sda6           41G    9,3G   30G  24% /var/log
    /dev/sda6           41G    9,3G   30G  24% /srv
    /dev/sda6           41G    9,3G   30G  24% /boot/grub2/i386-pc
    /dev/sda6           41G    9,3G   30G  24% /tmp
    /dev/sda6           41G    9,3G   30G  24% /boot/grub2/x86_64-efi
    /dev/sda7          309G    6,3G  303G   3% /home
    /dev/sda2          109G     84G   25G  78% /run/media/cyrille/8E1613011612E9CB
    /dev/sda1          100M     25M   76M  25% /run/media/cyrille/Réservé au système

    En parcourant ce forum j'ai vu qu'il était conseillé d'installer BleachBit pour récupérer de la place, mais bon ça n'a rien changé.

    Ce qui est bizarre c'est que quand j'installe une mise à jour (proposé en mode graphique), pas de soucis. Idem pas de soucis avec zypper.
    Au pire j'utiliserai zypper pour l'installation de paquets, ça ne me gêne pas, c'est simplement que j'aimerais savoir la cause du problème

    C'est grave docteur ? D'ailleurs cette partition c'est quoi ? J'ai un dualboot W$7 (pour jouer à DOOM...), elle ne vient pas de là ? Dans ce cas, qu'est ce qui peut pré-occuper yast sur unee partition windows ?


    Merci d'avance !
    Si plus d'infos nécessaires, pas de soucis ;-)
    Dernière édition par cyrille; 31/08/2016 à 18h11

  2. #2
    Caméléon arc-en-ciel
    Inscrit
    dcembre 2004
    Lieu
    France
    Distribution
    Leap 15.0
    Environnement
    MATE, XFCE
    Messages
    7 858
    Billets
    1
    Affiche le retour de :

    Code:
    parted -l
    (en root)
    Ce qui reste éternellement incompréhensible dans la nature, c'est que l'on puisse la comprendre.
    Albert Einstein

    Etreignez-vous, millions d'êtres.
    Au monde entier ce baiser!
    Seid umschlungen, Millionen.
    Diesen Kuss der ganzen Welt!
    Friedrich Schiller

  3. #3
    Caméléon sympa Modérateur Avatar de Bernado82
    Inscrit
    janvier 2016
    Lieu
    /home
    Distribution
    openSUSE Leap 15.1
    Environnement
    KDE Plasma 5.16
    Messages
    398
    Bonjour cyrille,

    Je pense que YaST ne fait que te signaler que l'espace restant sur ta partition sda1 est faible comme pourrait le faire Windows (qui généralement s'affole quand il reste moins de 200 Mo sur une partition) sauf que lui ne le signalerait pas pour sa partition de boot. Bien évidemment, YaST ne cherchera JAMAIS à installer de programme sur cette partition, c'est juste aussi le fait qu'elle soit déjà montée que YaST en teste l'espace restant. Il est vrai aussi que l'utilisation du format btrfs créé beaucoup plus de points de montage que par exemple en EXT4...

    A tout hasard, vérifie dans YaST ---> Installer et supprimer des logiciels que dans le menu Options soit décoché "Mode de vérification du système" (quoique cette fonction à un autre usage et j'ignore si cela désactive aussi le test d'espace libre).

    Mais plus simplement, pourquoi ne pas laisser non montée ta partition dev/sda1 sous openSUSE car je ne pense pas que tu en fasse beaucoup d'usage depuis Linux à la différence de sda2 (ta partition principale de Windows) pour laquelle il peut être utile d'y avoir accès sous openSUSE.
    Dernière édition par Bernado82; 31/08/2016 à 23h14

  4. #4
    Grand caméléon Avatar de Antoine
    Inscrit
    fvrier 2008
    Lieu
    Toulouse (France)
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    GNOME
    Messages
    3 229
    Bonjour,

    Citation Envoyé par Bernado82 Voir le message
    Je pense que YaST ne fait que te signaler que l'espace restant sur ta partition sda1 est faible comme pourrait le faire Windows (qui généralement s'affole quand il reste moins de 200 Mo sur une partition) sauf que lui ne le signalerait pas pour sa partition de boot. Bien évidemment, YaST ne cherchera JAMAIS à installer de programme sur cette partition, c'est juste aussi le fait qu'elle soit déjà montée que YaST en teste l'espace restant.
    +1

    Ce comportement de YaST est un peu moisi. Il ne devrait pas se soucier des partitions où il n'installe rien (boo#926841). De plus, le calcul de l'espace libre est quelque fois faussé : typiquement quand l'étiquette du volume comporte un espace, YaST récupère un espace libre de 0 o (boo#925088)… Bref deux bugs pas très graves mais embêtants quand même, et déroutants surtout.


    Citation Envoyé par Bernado82 Voir le message
    Mais plus simplement, pourquoi ne pas laisser non montée ta partition dev/sda1 sous openSUSE
    +1 encore. En tout cas, c'est le moyen le plus simple d'éviter le message de YaST :-/

    À+
    « Celui dont la pensée ne va pas loin verra les ennuis de près. » — Confucius

  5. #5
    Léon
    Inscrit
    aot 2016
    Distribution
    openSUSE Leap 42.1 (64 bits)
    Environnement
    Xfce
    Messages
    13
    Bonsoir
    Et tout d'abord merci de vos réponses
    Après réflexion, j'ai trouvé la cause du comportement de Yast
    Mes partitions windows ne sont pas bien entendues montées sous opensuse.
    Mais j'ai su identifier l'erreur.
    Le truc vient de gparted. Je l'avais lancé pour reformater une clef USB et quand gparted se lance il monte automatiquement toutes les partitions qu'il trouve sur le système
    Donc si Yast passe après un lancement de gparted il tombe sur ces partitions.... ce qui provoque l'erreur sus mentionnée.
    Il faut simplement donc que je pense à démonter les partitions que gparted montent automatiquement après utilisation de ce logiciel.
    Encore une fois merci
    (donc pas de soucis, je n'ai nullement besoin de mes partitions w$ sous LINUX...). J'attends juste que Virtual Box gère correctement les cartes graphiques pour me débarrasser de ce système.
    Et puis je pense que j'utiliserai plus zypper que yast pour installer des logiciels... Plus à l'aise avec son comportement proche d'aptitude / apt qu'avec une interface graphique....
    Dernière édition par cyrille; 01/09/2016 à 18h32

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé