Page 4 sur 4 PremièrePremière ... 234
Affiche les résultats de 31 à 35 sur 35

Sujet : comment installer un serveur apache

  1. #31
    Super Modérateur Avatar de Doctor Who
    Inscrit
    juin 2008
    Lieu
    ...dans mon TARDIS
    Distribution
    openSUSE 13.2 (64 bits)
    Environnement
    Gnome
    Messages
    3 392
    Billets
    2
    Il indique que les scripts d'installation ont été renommé mais possible qu'il n'ait pas pu le faire, renommer le dossier d'installation toi même et réessaye


    --- Config : Cooler Master HAF922 - Corsair HX620W - Gigabyte GA-Z68XP-UD4 - Intel Core i7 2700K - Zalman CNPS9900 NT - Gibabyte GTX 660 OC 2Go - G.Skill Extreme3 4 x 4 Go PC17000 Ripjaws X CAS9 - OCZ Vertex2 120 Go - Crucial MX100 - 500 Go - WD Black 500Go 7200rpm 32Mo ---

  2. #32
    Caméléon sympa
    Inscrit
    octobre 2006
    Lieu
    SAVERES (HAUTE GARONNE)
    Distribution
    openSUSE 13.1 (32bits)
    Environnement
    Gnome 3.x
    Messages
    322
    Bonjour,
    Doctor Who, en reprenant la discussion depuis le début, j'ai vu que tu mentionnais que PMB nécessitait l'installation de paquets supplémentaires. J'ai trouvé, dans PMB un fichier PDF qui explique qu'il faut installer le paquet "yaz", car PMB s'appuie sur "zserver" pour fonctionner.
    J'ai installé "yaz". Je pense que le tuto pdf date un peu, car il indique que pour lancer "zserver" il faut se placer, dans le terminal, dans le répertoir "usr/local", mais ce répertoire est totalement vide.
    Je pense que je tourne en boucle à partir de l'étape "1er démarrage" sur la page de configuration qui me renvoie tout le temps à la phase initiale. J'ai renormmé les fichiers de configuration, mais ça ne change rien, hormis le fait que le message affiche que la page n'existe pas.
    Je pense que "zserver" n'est pas ouvert.
    Mais je n'en sais pas plus pour l'instant.
    À suivre...
    Merci
    William

  3. #33
    Caméléon sympa
    Inscrit
    octobre 2006
    Lieu
    SAVERES (HAUTE GARONNE)
    Distribution
    openSUSE 13.1 (32bits)
    Environnement
    Gnome 3.x
    Messages
    322
    Bonjour,
    Voilà, voilà, je décongèle !!
    Merci Doctor Who ! J'ai trouvé le fichier de configuration que j'ai renommé et j'ai aussi modifié les paramètres à l'intérieur du fichier, car, visiblement il n'a rien enregistré de ce que j'avais donné comme info lors du premier lancement de PMB.
    C'est OK. La base s'ouvre sans problème, et j'ai commencé à regarder l'architecture de la base. J'ai aussi récupérer le tutoriel chez PMB. Et j'ai eu un coup de grippe.... donc cerveau un peu en marmelade.
    ET J'AI FAIT UNE GROSSE GAFFE : J'ai mis un mot de passe pour Mysql / mariaDb et..... je l'ai ni noté, ni retenu......
    Donc je ne peut plus lancer Mysql. Donc, "nada" la panne totale, cause de cervelle d'oiseau par moment !

    Y'a t'il un moyen de retrouver le mot de passe, ou d'annuler la nécessité du mot de passe. Sinon, je suis condamné à réinstaller tout mon ordi, (car là j'ai fait la gaffe sur le mien) et ça me rend un peu gris....
    Mais toujours merci, car sans le forum je n'aurai pas été bien loin.
    dommage qu'il n'ai pas la capacité de rendre les étourdis

  4. #34
    Nouveau caméléon Avatar de niuxe
    Inscrit
    mai 2014
    Lieu
    France
    Distribution
    openSUSE Leap 42.1 (64 bits)
    Environnement
    Gnome
    Messages
    111
    Salut,

    On va éviter de sortir la grosse artillerie hein
    Si tu n'as pas touché aux privilèges de tes users dans mariaDB, tu peux aisément te connecter. Essai ceci dans un terminal (le deamon mysql doit être actif ):
    Code:
    $mysql -h localhost -u root
    Par défaut lors de l'installe de mariadb sur OpenSuse, il y a divers users où il n'y a pas de mot de passe. le user root (de mariaDB) n'en a pas.

    Une fois que tu t'es connecté à la base et que tu veuilles toujours mettre à jour ton fameux compte, tu fais ceci dans mysql/mariadb:
    Code:
    SELECT 
        * 
    FROM 
        mysql.user;
    Tu devrais voir le nom de ton fameux user. Tu n'as plus qu'à faire une requête de mise à jour (Attention, si tu changes ce user alors que pmb fonctionne, cela ne fonctionnera plus (vu que tu changes l'accès à la base)):
    Code:
    UPDATE 
        mysql.user 
    SET 
        Password=PASSWORD('[ton_password]') 
    WHERE 
        User='[ton_username]';
    Si dans PMB (que je ne connais pas), tu peux te connecter à Mysql, tu dois avoir automatiquement un fichier de config. Ce fichier permet de retrouver les accès à la base (host/user/password). Dans ce cas, je laisse la main à Doctor Who qui a l'air de mieux connaitre cette application.
    Dernière édition par niuxe; Aujourd'hui à 00h55 Raison: corrections et précision
    ASUS X73S/K73SV - OpenSuse 42.1 (Gnome Shell)
    ASUS X101CH - Ubuntu Mate 14.04
    ASUS ZENBOOK X31E - OpenSuse 42.1 (Gnome Shell)

  5. #35
    Caméléon sympa
    Inscrit
    octobre 2006
    Lieu
    SAVERES (HAUTE GARONNE)
    Distribution
    openSUSE 13.1 (32bits)
    Environnement
    Gnome 3.x
    Messages
    322
    Merci, mais je crois que j'ai du mettre un sacré bazar !
    À la première commande, j'ai la même réponse :accès refusé car il faut le mot de passe.
    Je vais refaire mon installation. Pour moi, c'est plus simple. Je pense que je n'ai pas à formater la partition /home. L'écrasement de l'installation du système devrait suffire.
    Je verrai ça demain.
    Bonne nuit.

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé