Affiche les résultats de 1 à 8 sur 8

Sujet : wrong ownership on runtime directory ...?

  1. #1
    Léon
    Inscrit
    juin 2016
    Distribution
    openSUSE Leap 42.2 (64 bits)
    Environnement
    KDE
    Messages
    15

    wrong ownership on runtime directory ...?

    Bonjour, je suis passé sous leap 42.2. je rencontre le soucis suivant et je n'arrive pas le résoudre.
    Cela fait deux jours que je cherche sans succès, je tombe que sur des sites en english, ou sur d'autres distrib donc pas facile; à priori pb de plasma/ kde...dont la cause serait PAM qui transmets pas les bons droit.
    Je suis tombé sur des sites avec cette erreur (No X-KDE-DBus...) et là c'est tout KDE qui ne fonctionne pas. Mais mon desktop kde plasma fonctionne, mais le réseau smb ne fonctionne pas : il boucle sur l'authentification alors qu'elle est ok, je ne sais pas si c'est lié.
    J'ai essayé de faire un update sur les dépôts de KDE et cela a foiré..reformatage et j'ai tjrs le mêm pb. Merci de vos lumières...

    extrait1 = /var/log/messages

    2016-11-17T23:14:09.603066+01:00 edserv org.kde.kded5[3423]: QStandardPaths: wrong ownership on runtime directory /run/user/0, -2 instead of 0
    2016-11-17T23:14:09.608897+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/baloosearchmodule.so"
    2016-11-17T23:14:09.609140+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/proxyscout.so"
    2016-11-17T23:14:09.609259+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/bluedevil.so"
    2016-11-17T23:14:09.609373+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/networkstatus.so"
    2016-11-17T23:14:09.609472+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/kscreen.so"
    2016-11-17T23:14:09.609566+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/networkmanagement.so"
    2016-11-17T23:14:09.609664+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/networkwatcher.so"
    2016-11-17T23:14:09.609759+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/recentdocumentsnotifier.so"
    2016-11-17T23:14:09.609863+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/appmenu.so"
    2016-11-17T23:14:09.609999+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/desktopnotifier.so"
    2016-11-17T23:14:09.610118+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/freespacenotifier.so"
    2016-11-17T23:14:09.610235+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/ksysguard.so"
    2016-11-17T23:14:09.610372+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/ktimezoned.so"
    2016-11-17T23:14:09.610491+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/remotedirnotify.so"
    2016-11-17T23:14:09.610612+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/solidautoeject.so"
    2016-11-17T23:14:09.610731+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/soliduiserver.so"
    2016-11-17T23:14:09.610852+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/statusnotifierwatcher.so"
    2016-11-17T23:14:09.610944+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/powerdevil.so"
    2016-11-17T23:14:09.611036+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/khotkeys.so"
    2016-11-17T23:14:09.611127+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/device_automounter.so"
    2016-11-17T23:14:09.611219+01:00 edserv org.kde.kded5[3423]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/keyboard.so"


    extrait2 = egrep -i QStandardPaths /var/log/messages

    2016-11-17T10:20:19.666280+01:00 edserv org.kde.kded5[2433]: QStandardPaths: wrong ownership on runtime directory /run/user/0, -2 instead of 0
    2016-11-17T12:40:19.264420+01:00 edserv org.kde.kded5[2189]: QStandardPaths: wrong ownership on runtime directory /run/user/0, -2 instead of 0
    2016-11-17T13:13:47.051446+01:00 edserv org.kde.kded5[2334]: QStandardPaths: wrong ownership on runtime directory /run/user/0, -2 instead of 0
    2016-11-17T13:53:40.887224+01:00 edserv org.kde.kglobalaccel[1900]: QStandardPaths: wrong ownership on runtime directory /var/run/1000, -2 instead of 1000
    2016-11-17T13:53:56.872302+01:00 edserv org.kde.kglobalaccel[2167]: QStandardPaths: wrong ownership on runtime directory /var/run/1000, -2 instead of 1000
    2016-11-17T13:54:09.352306+01:00 edserv org.kde.kglobalaccel[2296]: QStandardPaths: wrong ownership on runtime directory /var/run/1000, -2 instead of 1000
    2016-11-17T13:56:07.900225+01:00 edserv org.kde.kded5[2449]: QStandardPaths: wrong ownership on runtime directory /run/user/0, -2 instead of 0
    2016-11-17T23:14:09.603066+01:00 edserv org.kde.kded5[3423]: QStandardPaths: wrong ownership on runtime directory /run/user/0, -2 instead of 0

    quand je regarde /var/run c'est un lien vers ../run le owner est root:root

    pour /run le owner est root:root

    j'ai aussi un dossier à la racine dont le owner est root:root
    run.runmove~

  2. #2
    Léon
    Inscrit
    juin 2016
    Distribution
    openSUSE Leap 42.2 (64 bits)
    Environnement
    KDE
    Messages
    15
    Bon, après réinstallation et moult batailles le réseau samba est ok, à partir de la console, je vois bien les machines avec smbclient.
    Par contre dans Dolphin, en mode super User ou pas,toujours pas de réseau. Si je tape dans la barre d'adresse smb://pcreseau, je reçois l'invite de login et malgré le bon mot de passe cette invite boucle sur elle-même.
    J'ai toujours ces erreurs dans les logs à l'ouverture de dolphin :

    Code:
    2016-12-10T10:03:45.173776+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/baloosearchmodule.so"
    2016-12-10T10:03:45.173959+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/kscreen.so"
    2016-12-10T10:03:45.174416+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/proxyscout.so"
    2016-12-10T10:03:45.174537+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/bluedevil.so"
    2016-12-10T10:03:45.174698+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/networkmanagement.so"
    2016-12-10T10:03:45.174800+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/networkstatus.so"
    2016-12-10T10:03:45.174902+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/khotkeys.so"
    2016-12-10T10:03:45.174980+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/networkwatcher.so"
    2016-12-10T10:03:45.175052+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/recentdocumentsnotifier.so"
    2016-12-10T10:03:45.175124+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/appmenu.so"
    2016-12-10T10:03:45.175202+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/desktopnotifier.so"
    2016-12-10T10:03:45.175274+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/freespacenotifier.so"
    2016-12-10T10:03:45.175344+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/ksysguard.so"
    2016-12-10T10:03:45.175419+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/ktimezoned.so"
    2016-12-10T10:03:45.175491+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/remotedirnotify.so"
    2016-12-10T10:03:45.175561+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/solidautoeject.so"
    2016-12-10T10:03:45.175634+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/soliduiserver.so"
    2016-12-10T10:03:45.175706+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/statusnotifierwatcher.so"
    2016-12-10T10:03:45.175777+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/device_automounter.so"
    2016-12-10T10:03:45.175847+01:00 edserv org.kde.kded5[26675]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib64/qt5/plugins/kf5/kded/keyboard.so"
    je n'ai plus le pb du owner, mais on voit bien que certains plugins ne sont pas lancés....Il y a un pb avec le plugin réseau de dolphin.

  3. #3
    Léon
    Inscrit
    juin 2016
    Distribution
    openSUSE Leap 42.2 (64 bits)
    Environnement
    KDE
    Messages
    15
    Bonjour le pb est persistant avec Leap,

    j'ai trouvé ça : https://lists.debian.org/debian-qt-k.../msg00000.html

    Mais le paquet libkf5plasma5 n'est pas disponible sous leap?
    Le RPM disponible sous
    https://opensuse.pkgs.org/15.0/kde-f...86_64.rpm.html signal un conflit avec plasma-framework si < 5.49.
    Leap distribue le framework 5.41.

    Je n'ai donc toujours pas la bonne solution, si quelqu'un peut m'éclairer , d'avance merci

    autres liens trouvés sur ce sujet de X-KDE-DBus-ServiceName :
    https://forums.opensuse.org/showthre...-file-_BVOE9-A

    https://bugs.mageia.org/show_bug.cgi?id=19039
    a priori je ne suis pas concerné car :
    edserv:~ # echo $XDG_DATA_DIRS
    /root/.local/share/flatpak/exports/share:/var/lib/flatpak/exports/share:/usr/local/share:/usr/share
    Dernière édition par ricobolo; 19/05/2019 à 13h46

  4. #4
    Léon
    Inscrit
    juin 2016
    Distribution
    openSUSE Leap 42.2 (64 bits)
    Environnement
    KDE
    Messages
    15
    personne n'a une idée ?

  5. #5
    Caméléon sympa Modérateur Avatar de Bernado82
    Inscrit
    janvier 2016
    Lieu
    /home
    Distribution
    openSUSE Leap 15.1
    Environnement
    KDE Plasma 5.16
    Messages
    387
    Bonjour,

    Si j'ai bien compris, tu as une expérience avec le(s) réseau(x) Samba mais la Leap te fais quelques misères pour l’exploiter, notamment sous KDE. Peut-être aussi car tu disposes uniquement d'une version 5.12 de Plasma sous Leap 15.0? A noter que d'autres environnements de bureau sont aussi disponibles, notamment Gnome et XFCE qui eux peut-être ne posent aucun problèmes de ce coté-là. Perso, étant utilisateur exclusif de KDE, je ne m'aventure pas souvent sur les autres DE...

    Je ne connais pas tes règles d'utilisation d'openSuse, par exemple il n'est pas conseillé d'installer divers RPM directement glanés ici ou là sur le web mais plutôt uniquement des dépôts officiels et si version obsolète ou indisponible alors on peut aller voir du coté des dépôts communautaires ou sur les sites officiel des développeurs par exemple. N'as-tu pas aussi édité un jour un fichier de config utilisateur en mode root (d'où des problèmes de droit)?

    Pour ma part, mon ancienne Leap 15.0 est passée en version 15.1 dans la nuit de jeudi/vendredi. Comme tu peux le voir, elle était déjà sous KDE Plasma 5.15.90 (beta de 5.16) et son passage à Leap 15.1 a été réalisé en bootant sur le DVD d'installation/mise-à-jour en reconfigurant les dépôts requis pour un KDE "up-to-date" quand demandé lors de la M-à-J.

    Si tu es avec KDE version 5.12 sous Leap 15.0 et que tu souhaites passer à la dernière version de Plasma (bientôt en v5.16), il suffit de taper les commandes suivantes en root (doit convenir aussi pour Leap 15.1):

    Code:
    zypper ar -f obs://KDE:Qt5 Qt5
    zypper ar -f obs://KDE:Frameworks5 Frameworks5
    zypper ar -f obs://KDE:Applications Applications
    zypper ar -f obs://KDE:Extra Extra
    
    zypper ref && zypper dup --from Qt5 --from Frameworks5 --from Applications --from Extra --allow-vendor-change
    Les premières lignes ajoutent les dépôts requis, la dernière rafraîchit les dépôts et proposera de multiples changement de paquets. Mais avant celà, il te faudra contrôler la bonne pertinence de tes dépôts actuels. A tout hasard, montres-nous le résultat de la commande:
    Code:
    zypper lr
    Mais aller faire un petit tour du coté de Gnome peut être aussi envisagé, des fois qu'il serait plus doué pour la navigation dans les partages Samba?
    Dernière édition par Bernado82; 25/05/2019 à 14h43
    https://www.facebook.com/profile.php?id=100011319637977 (page orientée openSuse)
    https://open.spotify.com/user/bernad...eomqM38isNZRIj (playlist Spotify)

    Utilitaires pour Rockchip:
    https://www.mediafire.com/folder/2x8...Rockchip_Tools
    https://mega.co.nz/#F!wxJliCiT!fSTU4uzNwJ4h_ZGOYHcjcQ

    Les outils Rockchip sont parfois moches, voici RK Android Tool v2.3.9 et Driver Assistant v4.5 après mon petit coup de polish:
    https://www.mediafire.com/folder/5qs985buhb8g5/Rockchip

  6. #6
    Léon
    Inscrit
    juin 2016
    Distribution
    openSUSE Leap 42.2 (64 bits)
    Environnement
    KDE
    Messages
    15
    Bonjour et merci Bernardo82 d'avoir pris le temps de me répondre.

    Mon objectif : tout simplement installer un domaine local, avec ldap/dns/samba et partager un pc windows avec serveur opensuse + les VM.

    Bon voilà ce que j'ai fait pour avancer. D'abord je suis revenu sur leap 42.3 en tant que machine physique.
    En effet lors de l'install leap15 impossible d'installer la dns a cause d'un pb de droit insoluble.
    J'ai ensuite installé leap15.0 en VM. La dessus la DNS fonctionne bien (dig et nslookup ok). J'ai d'abord installé samba, et là même problème : rien dans le réseau.
    Ensuite tentative d'avancer côté ldap qui est maintenant un AD. Pour le moment impossible de l'installer en ldaps, qui est l'installation par defaut sous leap, on n'a pas le choix on doit rentrer les certificats pour installer, et il n'y a plus de certificat management. Pb : le pkcsutil ne decode pas le certificat pkcs12 ( je planche la dessus...)

    Je suis aussi en train de migrer la vm vers leap 15.1, c'est en cours pcq finalement c'est un joyeux bazar.
    1-Depuis windows je rentre bien dans les partages samba du serveur physique et vm.
    2-Depuis le serveur physique en suse 42.3, je vois les machines quand elles ne sont pas dans le domaine. Et quand elles sont dans le domaine je ne les vois pas(...). ?? En fait le domaine est confondu avec la machine elle même. il n'y a pas d'arborescence en dessous.
    3-Depuis la VM leap 15.0 nada....En fait c'est cette machine que je veux configurer en controleur de domaine et c'est elle qui fait dns et fera (j'y arriverais....un jour) annuaire LDAP orienté AD, ce qui était attendu depuis ans.

    Alors pour ta question , oui malheureusement j'ai la mauvaise habitude de tout faire en root via Dolphin ( le plus souvent quand je reste bloqué par Yast qui ne propose pas toujours l'exhaustivité des paramètres et options possible). Mais tu es en train de me dire que c'est une mauvaise idée...

    Côté Gnome, j'ai toujours eu des pb avec ce bureau, mais c'est une bonne idée de voir comment ça se comporte avec lui.

    Je continue mes investigations/installation sur leap15 dès que la machine est opérationelle et vous tiens au courant.

  7. #7
    Léon
    Inscrit
    juin 2016
    Distribution
    openSUSE Leap 42.2 (64 bits)
    Environnement
    KDE
    Messages
    15

    domaine sous samba impossible ?

    Bon voilà, après acharnement de plusieurs jours là je sèche.
    Résumé :
    Leap15 en VM c'est révélée instable la machine a plantée, je suis revenu sur une openSUSE 42.3 (à la fois en VM et en physique).
    Sur cette VM j'ai pu installé la DNS, et LDAP en SSL.
    Le problème persiste : quand je mets les machines dans Workgroup: bingo ça marche je vois les machines et partage néanmoins depuis linux impossible de rentrer dans les windows.
    Dans l'autre sens, c'est nickel : windows10pro (en VM) vois et rentre bien dans les deux open suse42.3 (une vm et une physique).

    Alors j'ai une piste qui pourrait expliquer pourquoi les machines ne sont pas vues lorsque j'active le DC samba linux, apparemment c'est windows10 qui devient est le controleur de domain :
    dns1:~ # smbclient -L freebox-server -U eric
    Enter LOCAL.DOMAIN\eric's password:
    Domain=[FREEBOX-SERVER] OS=[] Server=[]

    Sharename Type Comment
    --------- ---- -------
    Disque dur Disk AutoShare of fbxhdiskd partition 2
    IPC$ IPC IPC Service (Freebox Server)

    Domain=[FREEBOX-SERVER] OS=[] Server=[]

    Server Comment
    --------- -------

    Workgroup Master
    --------- -------
    LOCAL.DOMAIN WIN10PRO
    WORKGROUP FREEBOX-SERVER
    En realité la win10pro n'est pas dans le domaine mais dans le groupe de travail qui s’appelle comme le domaine. Et chose surprenante, cette machine est master de local.domain. Surprenant...mais que dois je faire ?
    Ce que je veux : c'est simplement un partage entre chaque machine et le domaine géré par SAMBA, sous la VM DNS1.
    voic mon smb.conf sur la VM DNS1 qui devrait être le controleur de domain :
    # smb.conf is the main Samba configuration file. You find a full commented
    # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
    # samba-doc package is installed.
    [global]
    #Server
    workgroup = local.domain
    server string = smb.dns1.local.domain
    max xmit = 65535
    domain logons = Yes
    domain master = Yes
    local master = Yes
    preferred master = Yes

    netbios name = dns1
    security = user
    wins support = Yes
    name resolve ***** = wins lmhosts bcast hosts
    dns proxy = yes
    log level = 3
    unix password sync = yes
    min protocol = NT1
    #server min protocol = SMB2_10
    #client min protocol = SMB2
    #client max protocol = SMB3
    #protocol = SMB3


    #Backend
    #passdb backend = smbpasswd


    #passdb backend = ldapsam:ldap://127.0.0.1
    #passdb backend = ldapsam:ldap://127.0.0.1
    #passdb backend = ldapsam:"ldap://ldap-server-fqdn:636"
    #passdb backend = ldapsam:"ldap://dns1.local.domain:636"

    passdb backend = ldapsam:ldap://dns1.local.domain
    passwd program = /usr/bin/passwd %u
    passwd chat = *New*password* %n\n *new*password* %n\n *successfully*
    ldapsam:trusted = yes
    ldapsam:editposix = yes

    #Print
    printing = cups
    printcap name = cups
    printcap cache time = 750
    cups options = raw

    #User
    map to guest = Bad User
    #include = /etc/samba/dhcp.conf
    logon path = \\%L\profiles\.msprofile
    logon home = \\%L\%U\.9xprofile
    logon drive = P:
    usershare allow guests = No


    #IDMAP
    idmap config * :backend = ldap
    idmap config * :ldap_base_dn = ou=Idmap,dc=local,dc=domain
    idmap config * :ldap_user_dn = cn=Rico,ou=People,dc=local,dc=domain
    idmap config * :ldap_url = ldap://dns1.local.domain
    idmap config * :range = 1000-999999


    #LDAP
    ldap admin dn = cn=Rico,dc=local,dc=domain
    ldap group suffix = ou=group
    ldap idmap suffix = ou=Idmap
    ldap machine suffix = ou=Machines
    ldap passwd sync = Yes
    ldap suffix = dc=local,dc=domain
    ldap user suffix = ou=people
    ldap delete dn = yes
    ldap password sync = yes

    #ldap ssl = start_tls
    ldap ssl = off

    #add machine script = /usr/sbin/useradd "%u"
    #add machine script = /sbin/yast /usr/share/YaST2/data/add_machine.rb %m$
    add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
    os level = 65
    usershare max shares = 100

    # Winbind
    #winbind separator = /
    #winbind enum users = yes
    #winbind enum groups = yes
    #winbind use default domain = yes
    #Setting this parameter forces winbindd to use RPC instead of LDAP to retrieve information from Domain Controllers.
    #template shell = /bin/bash
    #template homedir = /home/%U
    #winbind offline logon = yes
    #max protocol = SMB3

    [homes]


    et
    dns1:~ # systemctl status nmb
    ? nmb.service - Samba NMB Daemon
    Loaded: loaded (/usr/lib/systemd/system/nmb.service; enabled; vendor preset: disabled)
    Active: active (running) since Thu 2019-06-20 17:22:58 CEST; 1h 1min ago
    Main PID: 14784 (nmbd)
    Status: "nmbd: ready to serve connections..."
    Tasks: 2 (limit: 512)
    CGroup: /system.slice/nmb.service
    ??14784 /usr/sbin/nmbd -D
    ??14785 /usr/sbin/nmbd -D

    Jun 20 17:23:12 dns1 nmbd[14784]:
    Jun 20 17:23:12 dns1 nmbd[14784]: Samba server DNS1 is now a domain master browser for workgroup LOCAL.DOMAIN on subnet 192.168.0.2
    Jun 20 17:23:12 dns1 nmbd[14784]:
    Jun 20 17:23:12 dns1 nmbd[14784]: *****
    Jun 20 17:23:20 dns1 nmbd[14784]: [2019/06/20 17:23:20.770877, 0] ../source3/nmbd/nmbd_become_lmb.c:397(become_local_master_stage2)
    Jun 20 17:23:20 dns1 nmbd[14784]: *****
    Jun 20 17:23:20 dns1 nmbd[14784]:
    Jun 20 17:23:20 dns1 nmbd[14784]: Samba name server DNS1 is now a local master browser for workgroup LOCAL.DOMAIN on subnet 192.168.0.2
    Jun 20 17:23:20 dns1 nmbd[14784]:
    Jun 20 17:23:20 dns1 nmbd[14784]: *****



    nmb status
    dns1:~ # systemctl status smb
    ? smb.service - Samba SMB Daemon
    Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled; vendor preset: disabled)
    Active: active (running) since Thu 2019-06-20 17:22:59 CEST; 1h 1min ago
    Process: 14790 ExecStartPre=/usr/share/samba/update-apparmor-samba-profile (code=exited, status=0/SUCCESS)
    Main PID: 14807 (smbd)
    Status: "smbd: ready to serve connections..."
    Tasks: 4 (limit: 512)
    CGroup: /system.slice/smb.service
    ??14807 /usr/sbin/smbd -D
    ??14808 /usr/sbin/smbd -D
    ??14809 /usr/sbin/smbd -D
    ??14814 /usr/sbin/smbd -D

    Jun 20 17:22:58 dns1 systemd[1]: Starting Samba SMB Daemon...
    Jun 20 17:22:59 dns1 systemd[1]: smb.service: Supervising process 14807 which is not our child. We'll most likely not notice when it exits.
    Jun 20 17:22:59 dns1 smbd[14807]: [2019/06/20 17:22:59.398145, 0] ../lib/util/become_daemon.c:124(daemon_ready)
    Jun 20 17:22:59 dns1 smbd[14807]: STATUS=daemon 'smbd' finished starting up and ready to serve connections
    Jun 20 17:22:59 dns1 systemd[1]: Started Samba SMB Daemon.



    enfin winbind status

    dns1:~ # systemctl status smb
    ? smb.service - Samba SMB Daemon
    Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled; vendor preset: disabled)
    Active: active (running) since Thu 2019-06-20 17:22:59 CEST; 1h 1min ago
    Process: 14790 ExecStartPre=/usr/share/samba/update-apparmor-samba-profile (code=exited, status=0/SUCCESS)
    Main PID: 14807 (smbd)
    Status: "smbd: ready to serve connections..."
    Tasks: 4 (limit: 512)
    CGroup: /system.slice/smb.service
    ??14807 /usr/sbin/smbd -D
    ??14808 /usr/sbin/smbd -D
    ??14809 /usr/sbin/smbd -D
    ??14814 /usr/sbin/smbd -D

    Jun 20 17:22:58 dns1 systemd[1]: Starting Samba SMB Daemon...
    Jun 20 17:22:59 dns1 systemd[1]: smb.service: Supervising process 14807 which is not our child. We'll most likely not notice when it exits.
    Jun 20 17:22:59 dns1 smbd[14807]: [2019/06/20 17:22:59.398145, 0] ../lib/util/become_daemon.c:124(daemon_ready)
    Jun 20 17:22:59 dns1 smbd[14807]: STATUS=daemon 'smbd' finished starting up and ready to serve connections
    Jun 20 17:22:59 dns1 systemd[1]: Started Samba SMB Daemon.




    Je ne sais pas ce que j'ai pu rater malgré des recherches intenses mais toute aide sera la bienvenue !

  8. #8
    Léon
    Inscrit
    juin 2016
    Distribution
    openSUSE Leap 42.2 (64 bits)
    Environnement
    KDE
    Messages
    15

    Victoire - Demi victoire

    Bonjour Forum,
    J'ai enfin réussi à démêler les choses, je vous les explique succinctement car cela pourrait servir à quiconque se retrouve dans cette situation et peut aussi me servir de mémo.

    Alors :
    1/ Principal pb : le nom du domaine ! d'après https://wiki.samba.org/index.php/Set...ain_Controller le nom .local est reservé à avahi-daemon --> pas étonnant que rien ne s'affichait correctement. Donc "local" à proscrire, même si plein d'exemple sur le net l'utilisent...

    2/J'ai fait une confusion ( mais suis-je le seul ?...) entre workgroup et domain. Bien que les deux notions soient prochent. En effet j'ai fait un domaine : gribouille.dom, puis j'ai mis les machines dans un workgroup : gribouille.dom. Donc le système a pensé être dans le domaine mais n'y était pas. Après épuisement des pages sur Samba sur le net, ma compréhension est que Samba est d'abord orienté netbios. Cela veut dire qu'il s'appuie sur wins, avec le fichier lmhosts en support ( linux->/etc/samba et windows -> /windows/system32/dribers/etc/lmhots.sam, limité à des noms de 15+1 caractères.).
    J'ai donc tout passé en "gribouille", et cela fonctionne normalement maintenant. J'ai chaque machine sous "Gribouille". A noter, que windows10 n'affiche plus le sommet de le foret (vu sur le net, mais j'ai plus le lien), c'est à dire que le workgroup "gribouille" n'apparait pas comme conteneur, et les machines apparaissent directement.
    Pour vérifier les infos wins, on peut utiliser la commande nbstat qui permet de lire les tables wins (oui, ça remonte à loin tout ça, au moins 25 ans..)
    Donc on doit pouvoir dire : workgroup=>netbios/wins, domaine=>DNS ( host+suffixe)

    3/ Apres c'est la config samba, comme l'option client max protocol = NT1 indispensable à l'apparition des machines dans le réseau linux.
    + PAM

    4/ J'ai donc pu configurer le backend LDAP, avec openLdap sur la machine PDC, sans SSL, car inutile en local.

    5/ Je reste bloqué sur le fait que linux voit les windows, mais ne rentre pas dedans.("Pas de réponse du serveur.."). Pourtant les ports netbios sont bien ouverts, le partage activé, netbios ok, winbind ?.
    Je vais continuer à chercher, mais comme l'autre sens fonctionne cela ne me bloque pas.

    6/ Ce que j'ai lu,c'est que backend OpenLdap va être abandonné pour revenir sur du LDAP "natif" (futur leap). C'est ce que propose 389-DS. Il s'agit donc de reprendre les projets Red hat / fedora afin d'implémenter un AD sous LDAP, à l'instar de windows (mais sans le specifique windows bien sur). Pour Suse il faut ajouter le repo network:ldap afin d'avoir les RPM 389. J'ai essayé de l'installer sur la VM en leap15.1 (machine rescucitée), et pour le moment je suis confronté a SE linux car il est désactivé.

    L'essentiel pour moi est atteint, au moins un partage fonctionnant Linux<->windows, et quand je pourrais j'essaiera de passer sous 389-DS avec cette fois-ci un vrai domaine DNS, mais je pressens encore une joyeuse bataille !...

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé