Affiche les résultats de 1 à 7 sur 7

Sujet : OpenShot 2.4 : à quand blender 2.79 (sous Leap 42.2)

  1. #1
    Léon
    Inscrit
    janvier 2013
    Lieu
    Le Mans (72 France)
    Distribution
    openSUSE Leap 42.2 (64 bits)
    Environnement
    KDE 4.x
    Messages
    25

    OpenShot 2.4 : à quand blender 2.79 (sous Leap 42.2)

    Bonjour

    Pour les besoins de certains montage vidéo, en plus de KDEnlive, j'utilise aussi parfois OpenShot (Entre parenthèse : NE PAS INSTALLER OPENSHOT 1.4.3, cette version est connue comme ne fonctinnant pas!!).

    Et donc OpenShot permet de faire des intro animées 3D utilisant Blender, sauf que avec cette version d'OpenShot (qui est assez différente que les version 1.xx), elle nécessite Blender 1.78 et non pas la 1.76b qui est proposée par Yast pour OpenSuse Leap. Je me demande quand la version 1.78 (voire la 1.79 qui est sortie déjà depuis quelques temps officiellement) de Blender sous OpenSuse ?

    Vous me direz "utilisez directement Blender" ouai mais l'interface n'est pas simple... Et ça serait bien qu'il y ait + d'intro 3D animée sous Blender et utilisant moins de raytracing quand on n'a pas de carte graphique ultra puissante, ça rame pour certaines!

  2. #2
    Grand caméléon Avatar de Antoine
    Inscrit
    fvrier 2008
    Lieu
    Toulouse (France)
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    GNOME
    Messages
    3 229
    Salut,

    Je pense qu'il n'y aura jamais Blender ≥ 2.78 sur Leap 42.2, il manque des dépendances de compilation qui à mon avis ne seront pas introduites.

    Code:
    nothing provides pkgconfig(python3) >= 3.5, nothing provides pkgconfig(audaspace) >= 1.3
    À+
    « Celui dont la pensée ne va pas loin verra les ennuis de près. » — Confucius

  3. #3
    Léon
    Inscrit
    janvier 2013
    Lieu
    Le Mans (72 France)
    Distribution
    openSUSE Leap 42.2 (64 bits)
    Environnement
    KDE 4.x
    Messages
    25
    Merci pour la réponse. Actuellement la version que demande OpenShot est Blender 2.78, donc à priori, ça passera avec openshot! (Puisqu'il demande Blender au moins égal à 2.78)

    Donc j'aurais pas dû passer d'OpenSuse 13.3 à Leap 42.2 ? Mais sous Timbleweed ? Je ne savais pas trop quelle version utiliser. Quand j'ai installé Leap 42.2 il y a 6 mois, je voulais une version stable et sure, et Leap étant suivi par l'équipe de Suse.

  4. #4
    Grand caméléon Avatar de Antoine
    Inscrit
    fvrier 2008
    Lieu
    Toulouse (France)
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    GNOME
    Messages
    3 229
    Citation Envoyé par Neotenien Voir le message
    Merci pour la réponse. Actuellement la version que demande OpenShot est Blender 2.78, donc à priori, ça passera avec openshot! (Puisqu'il demande Blender au moins égal à 2.78)
    Ouais, mais en fait, non… j'ai écrit que Blender ≥ 2.78 ne sera pas dans Leap 42.2… La version 2.78 a aussi besoin de Python 3.5. Voir cette requête concernant l'entrée de Blender dans Leap 42.2.


    Citation Envoyé par Neotenien Voir le message
    Donc j'aurais pas dû passer d'OpenSuse 13.3 à Leap 42.2 ? Mais sous Timbleweed ? Je ne savais pas trop quelle version utiliser. Quand j'ai installé Leap 42.2 il y a 6 mois, je voulais une version stable et sure, et Leap étant suivi par l'équipe de Suse.
    Leap 42.3 ? Elle est sortie en juillet. <-- EDIT ah ouais mais non plus, même problème sur Leap 42.3… t'es bon pour attendre la prochaine ^^

    Quoiqu'il en soit Leap est conservatrice, elle va préférer apporter aux applications des correctifs plutôt que de les mettre à jour vers une nouvelle version. Ce n'est pas aussi strict que Debian bien sûr. Mais là, vu le changement (Python 3.5), c'est mort.
    Dernière édition par Antoine; 17/12/2017 à 18h58
    « Celui dont la pensée ne va pas loin verra les ennuis de près. » — Confucius

  5. #5
    Caméléon sympa Modérateur Avatar de Bernado82
    Inscrit
    janvier 2016
    Lieu
    /home
    Distribution
    openSUSE Leap 15.1
    Environnement
    KDE Plasma 5.16
    Messages
    387
    Citation Envoyé par Neotenien Voir le message
    Je me demande à quand la version 2.78 (voire la 2.79 qui est sortie déjà depuis quelques temps officiellement) de Blender sous OpenSuse?
    OpenShot Video Editor v2.4.0 est aussi installé sur ma Leap (v42.3 par contre et non comme toi en v42.2), mais il est vrai que je ne l'ai presque jamais utilisé (installé un jour en même temps que Flowblade Movie Editor qui lui me semble bien moins intéressant). Grâce à toi, je "redécouvre" OpenShot! Et donc, tu souhaiterais avoir une version plus récente de Blender sur ta Leap pour un fonctionnement en "duo" avec OpenShot...

    En effet, sur Leap n'est proposé au mieux que Blender en v2.76 (Tumbleweed étant mieux lotie car la version 2.79 lui est déjà accessible), mais pourquoi ne pas utiliser la version 2.79 proposée en téléchargement pour Linux? Il suffit de décompresser l'archive et de lancer ensuite l'exécutable blender inclus. Pour OpenShot il te suffira de lui indiquer où se trouve le fichier blender, par exemple une fois l'archive décompressée dans le dossier /home/utilisateur/Téléchargements/blender-2.79-linux-glibc219-x86_64/blender. Je pensais au début qu'il faudrait se résigner à installer une version récente (?) via Flatpak ou par l'ajout du dépôt https://download.opensuse.org/reposi...ater:/blender/, trouvé dans la liste des distributions non supportées à partir de software.opensuse.org/package/blender mais en fait il s'avère bien plus simple de passer par ce qui est proposé en téléchargement sur https://www.blender.org/download/ (seul requis une version de glibc ≥ 2.19?).

    Blender2.79_sur_ma_Leap42.3.jpg

    A l'occasion j'essaye aussi la v2.4.1 d'OpenShot proposée en version AppImage.

    OpenShot_Video_Editor_v2.4.1.jpg
    Dernière édition par Bernado82; 18/12/2017 à 17h50
    https://www.facebook.com/profile.php?id=100011319637977 (page orientée openSuse)
    https://open.spotify.com/user/bernad...eomqM38isNZRIj (playlist Spotify)

    Utilitaires pour Rockchip:
    https://www.mediafire.com/folder/2x8...Rockchip_Tools
    https://mega.co.nz/#F!wxJliCiT!fSTU4uzNwJ4h_ZGOYHcjcQ

    Les outils Rockchip sont parfois moches, voici RK Android Tool v2.3.9 et Driver Assistant v4.5 après mon petit coup de polish:
    https://www.mediafire.com/folder/5qs985buhb8g5/Rockchip

  6. #6
    Grand caméléon Avatar de Antoine
    Inscrit
    fvrier 2008
    Lieu
    Toulouse (France)
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    GNOME
    Messages
    3 229
    Citation Envoyé par Bernado82 Voir le message
    par l'ajout du dépôt https://download.opensuse.org/reposi...ater:/blender/, trouvé dans la liste des distributions non supportées à partir de software.opensuse.org/package/blender
    Oui, bien vu ce dépôt : on voit que le gars qui propose ça a ajouté plein de choses dans son projet pour que Blender puisse compiler sur Leap 42.2. Et cela montre d'autant plus que ce Blender ≥ 2.78 ne pourra être livrée comme une mise à jour officielle de Leap 42.2, ce qu'attendait Neotonien je crois.

    Bien sûr il y a toujours des solutions alternatives pour récupérer le binaire sans passer par les canaux officiels ;-) C'est juste que ce n'est pas officiellement pris en charge.

    À+
    Dernière édition par Antoine; 18/12/2017 à 11h30 Raison: Correction lien
    « Celui dont la pensée ne va pas loin verra les ennuis de près. » — Confucius

  7. #7
    Caméléon sympa Modérateur Avatar de Bernado82
    Inscrit
    janvier 2016
    Lieu
    /home
    Distribution
    openSUSE Leap 15.1
    Environnement
    KDE Plasma 5.16
    Messages
    387
    Petit oubli, pour la francisation de Blender:

    - Aller dans la fenêtre User preferences (à partir du menu File par exemple).
    - Cliquer sur l'onglet System et en bas à droite, cocher la case International Fonts.
    - Dans le sous menu Language qui va s'afficher, sélectionner French (Français) ou laisser la valeur Par défaut si suffisant.
    - Selon votre convenance, cliquer sur les boutons Interface, Tooltips, New Data selon le niveau de traduction souhaité.

    Vu que sur Leap la version de Blender est ancienne (et que certains problèmes de dépendances risquaient d'être non résolvables), il y avait plusieurs possibilités:

    - Essayer ce qui est proposé sur https://flathub.org/apps.html pour installer Blender (quelle version?) via Flatpak. Avec le risque que l'appel depuis OpenShot ne fonctionne pas correctement? Perso j'ai pas encore essayé cette version. EDIT: Si, finalement c'est bien la v2.79 qui s'est même installée avec Plasma Discover, reste à tester "l’interfaçage" avec OpenShot via une commande flatpak run xxxx. (*)

    - Ajouter le dépôt indiqué pour la dernière version de Blender, avec comme conséquence le changement de quelques paquets pour résoudre les dépendances?

    - Télécharger et décompresser la version proposée sur le site de l'éditeur, évidemment celle-ci ne sera pas automatiquement mise-à-jour mais vu que Neotonien n'a qu'un usage limité de Blender, juste lié à un simple appel depuis OpenShot pour le rendu d'intro 3D de certains des titrages, je pense que ça peut lui suffire amplement. Aucune installation particulière, donc aucun nouveau paquet à installer (sauf prérequis de base?) et une bonne interaction avec le reste des applications contrairement avec parfois ce qui est permis via Flatpak...


    (*) Non en fait OpenShot n'aime pas lancer Blender via Flatpak, voici la preuve (quoique en utilisant peut-être un lien symbolique ou autre ruse de sioux?):

    Screenshot_20171218_151941.png

    Hormis ce problème de Blender (version Flatpak/Flathub) avec OpenShot (j'étais presque sûr que ça aller arriver, même avant d'essayer), ce type d'installation pour Blender n'est pas à bannir car elle présente l'avantage de pouvoir être mise-à-jour plus ou moins automatiquement (selon disponibilité de nouvelle version stable mise à disposition via Flathub) et ceci sans compromettre la stabilité de la Leap (surtout si plus ancienne?) par l'ajout de dépôt non officiel et des paquets qui y sont proposés.
    Dernière édition par Bernado82; 19/12/2017 à 00h42
    https://www.facebook.com/profile.php?id=100011319637977 (page orientée openSuse)
    https://open.spotify.com/user/bernad...eomqM38isNZRIj (playlist Spotify)

    Utilitaires pour Rockchip:
    https://www.mediafire.com/folder/2x8...Rockchip_Tools
    https://mega.co.nz/#F!wxJliCiT!fSTU4uzNwJ4h_ZGOYHcjcQ

    Les outils Rockchip sont parfois moches, voici RK Android Tool v2.3.9 et Driver Assistant v4.5 après mon petit coup de polish:
    https://www.mediafire.com/folder/5qs985buhb8g5/Rockchip

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé