Page 2 sur 2 PremièrePremière 12
Affiche les résultats de 11 à 14 sur 14

Sujet : Parasitage du son

  1. #11
    Nouveau caméléon
    Inscrit
    janvier 2018
    Distribution
    opensuse leap 15.1
    Environnement
    KDE
    Messages
    153
    Citation Envoyé par Antoine Voir le message
    J'ai l'impression que PulseAudio s'arrête/redémarre à cause d'une erreur.

    J'ai vu qu'il y avait des rapports de bug récents par rapport à ça (rh#1472285, fdo#103752).

    Il y aurait un moyen de contournement : désactiver le module "switch-on-port-available" en modifiant la configuration de PulseAudio globale (/etc/default.pa).
    Sans toucher à la configuration (et sans avoir à relancer PulseAudio), tu peux essayer de désactiver ce module à chaud pour voir s'il y a du mieux :

    Code:
    pactl unload-module module-switch-on-port-available



    codec : codeur-décodeur (mais nous on se sert surtout du décodeur), ça sert à décoder un format vidéo/audio/autre en quelque chose de visible/écoutable/autre.

    Par pilote son, j'entendais le pilote de la carte son, càd le logiciel qui permet de contrôler correctement la carte, le matériel.
    AHA !!! much better !!!

    mais il est sensé faire quoi ce module normalement ?

    pour le re-activer, je fais
    Code:
    pactl load-module module-switch-on-port-available
    ?

    bon, en attendant, je le laisse dormir ceci dit :-)

    Je laisse 24 heures et si ca se confirme, je flague ("freut freutement") en résolu.

    En attendant,.Merci !!
    VGA compatible controller : NVIDIA corporation GK 20 [GeForce GT730] (rev a1)
    LEAP 15.0

  2. #12
    Grand caméléon Avatar de Antoine
    Inscrit
    fvrier 2008
    Lieu
    Toulouse (France)
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    GNOME
    Messages
    3 229
    Citation Envoyé par coyote33 Voir le message
    mais il est sensé faire quoi ce module normalement ?
    Vu le nom, je dirais qu'il est censé permettre le changement de port automatique. Par exemple quand tu branches des écouteurs sur la prise jack, il permet de basculer automatiquement vers ces écouteurs. Regarde dans l'onglet Périphériques de sortie pour voir les ports disponibles pour tes cartes.


    Citation Envoyé par coyote33 Voir le message
    pour le re-activer, je fais
    Code:
    pactl load-module module-switch-on-port-available
    ?
    Toutafé :P

    Ou alors tu redémarres PulseAudio, étant donné que cette commande n'écrit pas la configuration en dur. PulseAudio est redémarré lors du redémarrage du système (obviously) et sur déconnexion/reconnexion (PulseAudio est un processus propre à une session utilisateur).
    « Celui dont la pensée ne va pas loin verra les ennuis de près. » — Confucius

  3. #13
    Nouveau caméléon
    Inscrit
    janvier 2018
    Distribution
    opensuse leap 15.1
    Environnement
    KDE
    Messages
    153
    Citation Envoyé par Antoine Voir le message

    Ou alors tu redémarres PulseAudio, étant donné que cette commande n'écrit pas la configuration en dur. PulseAudio est redémarré lors du redémarrage du système (obviously) et sur déconnexion/reconnexion (PulseAudio est un processus propre à une session utilisateur).
    Ah :-( il faut redemarrer le truc à chaque fois..
    Bon, en même temps, ça permet de rassurer sur l'authentification du problème, vu que au demarrage, ca rebugue et des que c'est enlevé, c'est normal.

    Bon, y'a plus qu'à fermer le thread.

    Encore merci !
    VGA compatible controller : NVIDIA corporation GK 20 [GeForce GT730] (rev a1)
    LEAP 15.0

  4. #14
    Grand caméléon Avatar de Antoine
    Inscrit
    fvrier 2008
    Lieu
    Toulouse (France)
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    GNOME
    Messages
    3 229
    Citation Envoyé par coyote33 Voir le message
    Ah :-( il faut redemarrer le truc à chaque fois..
    Oui, sinon, maintenant que tu sais que ça corrige le problème, tu modifies /etc/pulse/default.pa pour que le réglage soit persistant, comme je te l'ai dit dans mon commentaire #10. Il suffit de commenter la ligne "load-module module-switch-on-port-available".

    À+
    Dernière édition par Antoine; 23/02/2018 à 22h03
    « Celui dont la pensée ne va pas loin verra les ennuis de près. » — Confucius

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé