Affiche les résultats de 1 à 4 sur 4

Sujet : STEAM option QUI MARCHE en console (pour moi)

  1. #1
    Léon
    Inscrit
    octobre 2015
    Distribution
    LEAP 42.1 RC1
    Environnement
    KDE
    Messages
    5

    STEAM option QUI MARCHE en console (pour moi)

    bonjour à tous,
    uname - a : Linux ........ 4.12.14-lp150.12.4-default #1 SMP Tue May 22 05:17:22 UTC 2018 (66b2eda) x86_64 x86_64 x86_64 GNU/Linux

    je me suis arraché le peu de cheveux qui me restent parce que je voulais jouer avec les jeux AAA et avec une Nvidia 1070.
    j'ai rencontré 2 problèmes récurrents:
    1. le jeu qui se lance sans le son
    2. le jeu qui se lanse pas


    1) Pour le son il suffit d'aller dans les options de lancement du jeu (metro 2033 par exemple)
    bouton opposé au lancement -> propriétés -> option de lancement
    Code:
    SDL_AUDIODRIVER=alsa %command%
    2) Pour l'ensemble des jeux steam y compris les plus irréductibles comme Deus ex Mankind, Dying light, ou Xcom2 et pleins d'autre.
    En mode console faite un copier coller du code suivant :
    Code:
    STEAM_RUNTIME_PREFER_HOST_LIBRARIES=0 steam
    y a plus qu'a lancer le jeu via l'interface de steam et ça marche.
    l'avantage est de récupérer les échos de steam si des problèmes persistent.

    --
    P0L0 aka paj
    Dernière édition par polhen; 27/06/2018 à 15h43

  2. #2
    Caméléon sympa Avatar de Bernado82
    Inscrit
    janvier 2016
    Lieu
    /home
    Distribution
    openSUSE Leap 15.0
    Environnement
    KDE Plasma 5.15
    Messages
    337
    Bonjour,

    Moi j'avais installé Steam y a longtemps sur la première Leap et puis un jour, voilà que Steam ne fonctionnait plus correctement, ni les jeux installés avec qui ne se lançaient plus...

    J'ai fait une install "fraîche" de Leap 15.0 sur 2 autres disques et/ou PC et Steam semble encore bugger (message d'erreur quand lancé dans la console), alors j'ai testé la version pour Flatpak qui elle fonctionne bien, sauf le fait qu'aucun raccourci n'est installé dans les menus de KDE pour les nouveaux jeux téléchargés (j'aurais imaginé rencontrer des problèmes avec la 3D à moins que ça soit pour plus tard).

    Vu qu'il faut toujours essayer de persévérer et que j'avais comme erreur d'affichée dans le terminal, le message suivant:
    Code:
    bernard@linux-j4ck:~> steam
    Repairing installation, linking /home/bernard/.steam/steam to /home/bernard/.local/share/Steam
    Running Steam on opensuse-leap 15.0 64-bit
    STEAM_RUNTIME is enabled automatically
    Installing breakpad exception handler for appid(steam)/version(0)
    /home/bernard/.local/share/Steam/ubuntu12_32/steam: symbol lookup error: /usr/lib/libxcb-dri3.so.0: undefined symbol: xcb_send_request_with_fds
    /home/bernard/.local/share/Steam/steam.sh: ligne 444: pas de correspondance : ssfn*
    La solution était simple, donnée pour Ubuntu mais qui fonctionne ici aussi. Il suffit d'ouvrir la console et de relancer juste une fois Steam de la façon suivante:
    Code:
    ~/.local/share/Steam/ubuntu12_32/steam
    Cette fois-ci, Steam achève sa mise-à-jour initiale et tout rentre dans l'ordre par la suite. On peut donc se passer de la version Flatpak!
    Dernière édition par Bernado82; 29/06/2018 à 18h58
    https://www.facebook.com/profile.php?id=100011319637977 (page orientée openSuse)
    https://open.spotify.com/user/bernad...eomqM38isNZRIj (playlist Spotify)

    Utilitaires pour Rockchip:
    https://www.mediafire.com/folder/2x8...Rockchip_Tools
    https://mega.co.nz/#F!wxJliCiT!fSTU4uzNwJ4h_ZGOYHcjcQ

    Les outils Rockchip sont parfois moches, voici RK Android Tool v2.3.9 et Driver Assistant v4.5 après mon petit coup de polish:
    https://www.mediafire.com/folder/5qs985buhb8g5/Rockchip

  3. #3
    Léon
    Inscrit
    septembre 2015
    Distribution
    openSUSE Leap 42.2 (64 bits)
    Environnement
    Gnome
    Messages
    8
    Bonjour,

    Je n'avais pas utilisé steam pendant plusieurs mois, et pas moyen de le lancer ni les jeux qui vont avec. J'ai essayé la ligne de commande

    Code:
    vincent@linux-ipo8:~> steam
    removing troublesome steam-runtime libs...
    -> checking /home/vincent/.local/share/Steam/ubuntu12_32/steam-runtime
    -> checking /home/vincent/.local/share/Steam/steamapps
    bringing in our fixed openssl libraries
    Running Steam on opensuse 42.3 64-bit
    STEAM_RUNTIME is enabled automatically
    Pins up-to-date!
    steam: loadlocale.c:129: _nl_intern_locale_data: Assertion `cnt < (sizeof (_nl_value_type_LC_TIME) / sizeof (_nl_value_type_LC_TIME[0]))' failed.
    /home/vincent/.local/share/Steam/steam.sh : ligne 927 :  7568 Abandon                 (core dumped)$STEAM_DEBUGGER "$STEAMROOT/$STEAMEXEPATH" "$@"
    ensuite j'ai fait, comme indiqué plus haut :

    Code:
    vincent@linux-ipo8:~> /home/vincent/.local/share/Steam/ubuntu12_32/steam
    steam: loadlocale.c:129: _nl_intern_locale_data: Assertion `cnt < (sizeof (_nl_value_type_LC_TIME) / sizeof (_nl_value_type_LC_TIME[0]))' failed.
    Abandon (core dumped)
    Mais je ne comprends pas un traître mot de ce que ça répond. Une idée ?
    Je suis en openSUSE Leap 42.3 64 bits - Gnome.

    Est-ce qu'un passage en Leap 15 s'impose ?

    Vincent
    Dernière édition par Vincent; 02/11/2018 à 18h55

  4. #4
    Caméléon sympa Avatar de R26V8RS26
    Inscrit
    avril 2012
    Lieu
    La Tour du Pin (Isère)
    Distribution
    LEAP 15.0, Tumbleweed, Ubuntu 12.04 LTS, Kubuntu 18.04, Raspbian
    Environnement
    Plasma 5, KDE 4.x, XFCE, IceWM
    Messages
    396
    Salut Vincent,

    Je te conseille de faire un backup de ton .local/share/steam/steamapps/common, puis de désinstaller le paquet steam via Y@st, et enfin un petit
    Code:
     sudo rm -R .local/share/steam
    Tu rebootes, tu réinstalles steam, et tu recopies ton dossier common dans l'arborescence.


    Concernant ta question sur Leap 42.3, la migration n'est intéressante que si tu utilises les pilotes libres. Il y eu en effet une nette évolution de Mesa et d'OpenGL liée à la migration vers le kernel 4.12.
    Si tu utilises les pilotes proprios, un conseil : ne touche à rien. Ils sont de plus en plus durs à installer, notamment amdgpu-pro (bon, ça tombe bien, il ne sert presque plus à rien-.

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé