Affiche les résultats de 1 à 2 sur 2

Sujet : Brother DCP-9020CDW : c'est reparti pour les ennuis....

  1. #1
    Caméléon sympa Avatar de R26V8RS26
    Inscrit
    avril 2012
    Lieu
    La Tour du Pin (Isère)
    Distribution
    LEAP 15.0, Tumbleweed, Ubuntu 12.04 LTS, Kubuntu 18.04, Raspbian
    Environnement
    KDE 4.x, Unity
    Messages
    341

    Brother DCP-9020CDW : c'est reparti pour les ennuis....

    À chaque réinstallation, la reconfiguration des imprimantes Brother est une nouvelle aventure....

    Suite à l'installation de LEAP 15.0 sur mon serveur, impossible d'installer le scanner en réseau.
    L'imprimante fonctionne mais elle est très lente à répondre, ce qui n'était pas le cas sur Tumbleweed.

    Pour installer la partie scanner j'ai fait comme d'hab :

    • Un petit zypper pour les paquets brother linux :

    Code:
    sudo zypper install brscan4-0.4.2-1.x86_64.rpm
    sudo zypper install brscan-skey-0.2.4-1.x86_64.rpm
    
    • Puis configuration du scanner :

    Code:
    brsaneconfig4 -a name=BROTHER model=DCP-9020CDW ip=192.168.8.103
    Après redémarrage, je lance une impression avec xsane : "Aucun périphérique disponible"
    Je tente en console :
    Code:
    sudo scanimage>img.png
    [sudo] Mot de passe de root :  
    scanimage: no SANE devices found
    
    Pourtant, si je fais un
    Code:
    brsaneconfig4 -q | grep BROTHER
      0 BROTHER             "DCP-9020CDW"       I:192.168.8.103
    
    Pour moi, le pilote et le système ne communiquent pas.

    Deux options:
    • Firewalld
    • Le pilote brother ne prend pas en charge ce noyau (alors pourquoi fonctionnait-il sur Tumbleweed jusque il y a un mois de ça ? Notez que comme j'avais pas fait la dernière màj, je n'avais pas encore ce merveilleux firewalld qui ne m'énerve pas du tout du tout. )


    Une idée ? Merci !

  2. #2
    Nouveau caméléon
    Inscrit
    octobre 2014
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    KDE
    Messages
    215
    si c'est un problème avec firewalld, teste de voire si tu le déactive avec la commande rcfirewalld stop, si sa fonctionne.
    après pour voir la journalisation du parefeux va dans yast -> pare-feu -> options -> changer DéniDeLog et place la valeur sur all, sa active la journalisation avec les messages du noyaux , pour l'afficher utilise la commande dmesg -w.
    recherche les commence par FINAL_REJECT: pour savoir quelle sont les port/protocole qui sont bloqué
    sur cette ligne tu as plein d’information. SRC = ip de la source, DST = ip de la destination, PROTO = le protocole, SPT et DPT = port de source/destination.
    recherche le couple protocole/port pour savoire quelle service à activer.

    david

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé